LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2008, 05:51 AM   #1
james3545
LQ Newbie
 
Registered: Oct 2008
Posts: 6

Rep: Reputation: 0
Boot Up Program Mystery


Hello all!

I have a problem that I can't figure out. When I shut down and restart my computer Amarok (the music player) always starts when I get into GNOME. I am running Fedora 9 with GNOME. I have already checked in System -> Preferences -> Personal -> Sessions and it is definitely not there. I have some programs in there that I do want to load on boot up, and they are behaving as expected (ie: they load when I put them in there, they don't when I take them out). Amarok is not in there and I'm not sure where else to look.

Since I installed this just last week I have spent a considerable amount of time playing around with just about everything and I have a feeling that in some of my tinkering I must have added it to some boot up list. I couldn't tell you all of the things I've done playing around with settings on this system, but I have spent time in XFCE, KDE, and GNOME. In those different desktop environments I have added and removed programs to their respective boot up lists. Is it possible that I added Amarok to a start up list in XFCE or KDE and it is still being loaded into GNOME? I have a very limited understanding of what happens during boot up, but I would like to learn what happens on boot up so I can find the culprit for this little annoyance and find out what I did to cause it.

Any ideas? If you need any more information about my system please don't hesitate to ask.

Thanks!
 
Old 10-13-2008, 04:32 AM   #2
indeliblestamp
Member
 
Registered: Feb 2006
Distribution: Fedora
Posts: 341
Blog Entries: 3

Rep: Reputation: 39
KDE's autostart programs are in ~/.kde/Autostart or something, so Gnome's definitely not running one of those.
Do a grep amarok ~/.* and see if any hits come up. Its possible you (or XFCE) added it in one of your .x* files: .xprofile, .xinitrc, .xsession or whatever.
 
Old 10-13-2008, 12:52 PM   #3
james3545
LQ Newbie
 
Registered: Oct 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the reply! Here's the output of "grep amarok ~/.*" :

Code:
/home/username/.bash_history:amarok
/home/username/.recently-used.xbel:          <bookmark:application name="File Manager" exec="&apos;amarok&apos;" timestamp="1223086048" count="1"/>
/home/username/.recently-used.xbel:          <bookmark:application name="File Manager" exec="&apos;amarok&apos;" timestamp="1223086092" count="1"/>
/home/username/.xsession-errors:Amarok: [Loader] Starting amarokapp..
/home/username/.xsession-errors:Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.

Last edited by james3545; 10-13-2008 at 12:54 PM.
 
Old 10-14-2008, 02:28 AM   #4
indeliblestamp
Member
 
Registered: Feb 2006
Distribution: Fedora
Posts: 341
Blog Entries: 3

Rep: Reputation: 39
uh Okay its not there in any of those files. I don't use Gnome so I don't know where it puts its startup files, somewhere in ~/gnome* perhaps. Maybe someone else looking in can offer a tip or two.
 
Old 10-14-2008, 02:56 AM   #5
james3545
LQ Newbie
 
Registered: Oct 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Here is a copy of my /home/user/.gnome2/session file: http://pastebin.com/m6abe097f

I have a hunch that the answer is in this file. Is it safe to erase the contents of this file? Will that remove the history of all GNOME sessions?
 
Old 10-14-2008, 03:42 AM   #6
indeliblestamp
Member
 
Registered: Feb 2006
Distribution: Fedora
Posts: 341
Blog Entries: 3

Rep: Reputation: 39
Ok you could try this then:
Backup ~/.gnome2/session to some other name or location and restart gnome and see. You should get Gnome with the default settings. Is amarok starting now? If its not, then the session file is what's starting it up. You could either manually reconfigure your remaining startup programs in the new session file now, or you could move back the old session file and fiddle with it a bit (remove all entries with amarok in it, for example).
 
Old 10-14-2008, 05:43 AM   #7
james3545
LQ Newbie
 
Registered: Oct 2008
Posts: 6

Original Poster
Rep: Reputation: 0
I figured it out! The answer was in GNOME sessions. I was able to go to System -> Preferences -> Personal -> Sessions and remove Amarok from starting up.

This thread helped: http://ubuntuforums.org/showthread.php?t=199415
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The mystery behind PID the_gripmaster Linux - General 5 12-05-2007 05:13 PM
libMagick.so.6 mystery baronsam Linux - Software 0 11-06-2004 08:26 PM
mystery jhon Linux - Networking 1 09-01-2004 10:38 AM
The font mystery MATJA_KAE_92 Linux - Newbie 1 02-02-2004 10:52 AM
Mystery Directories!!! j0hn0n1 Linux - Newbie 2 01-23-2003 10:33 AM


All times are GMT -5. The time now is 11:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration