LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-13-2011, 07:02 PM   #1
ic_torres
Member
 
Registered: Nov 2005
Location: ABAP
Distribution: slackware 12.0, Vector Linux STD 6.0 and 5.8, ZenWalk 4.6.1, OpenBSD 3.9
Posts: 389

Rep: Reputation: 34
Boot sector of installed Vector Linux doesn't have a boot signature


upon adding the installed VL on the existing LILO.. (btw i have not installed its LILO on the installation setup) since i know that i will just add it to the "existing" LILO

the error above arises upon doing the lilo run command..

$adding Vector6.0 etc....
FATAL : Boot sector of /dev/hdc13 doesn't have a boot signature

1. i have tagged the /dev/hdc13 bootable via CFDISK. but same problem arises..
 
Old 02-13-2011, 09:46 PM   #2
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Arch
Posts: 3,013

Rep: Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225
Are you chainloading the Vector partion in lilo.conf? Like this:
Code:
other = /dev/hdc13
In that case you would need to install a bootloader in /dev/hdc13 as well. Otherwise you can boot the Vector kernel directly with
Code:
image = /mnt/hdc13/boot/vmlinuz # path to the Vector Linux kernel
  initrd = /mnt/hdc13/boot/initrd.gz # if initrd is used
 
Old 02-14-2011, 06:48 AM   #3
ic_torres
Member
 
Registered: Nov 2005
Location: ABAP
Distribution: slackware 12.0, Vector Linux STD 6.0 and 5.8, ZenWalk 4.6.1, OpenBSD 3.9
Posts: 389

Original Poster
Rep: Reputation: 34
here is my existing LILO's content :

Quote:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
append = "=ide-scsi"
default = linux
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
bitmap = /boot/bitmap/boot.bmp
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769


# End LILO global section
# Partition 1 : DOS/Windows
other = /dev/hda1
label = Windows
table = /dev/hda
# Partition 2: Linux GUI mode
image = /boot/vmlinuz
root = /dev/hdc3
label = linux
append = " "
read-only

# Partition 3: Linux TUI mode
image = /boot/vmlinuz
root = /dev/hdc3
label = linux-tui
append = "2 "
read-only

# Partition 4: Linux GUI mode
image = /boot/vmlinuz
root = /dev/hdc3
label = Vector5.8
append = "4 "
read-only

# Partition 5: Linux
#image = /boot/tamu/vmlinuz-linux-hdc2
#root = /dev/hdc2
#label = ZW4.6.1
#read-only
#initrd = /boot/tamu/initrd-linux-hdc2

# Partition 6: Linux
#image = /boot/tamu/vmlinuz-vector-hdc12
#root = /dev/hdc12
#label = Vector6.0
#read-only

# Partition 7 : Linux
#other = /dev/hdc5
#label = Slackware

# Partition 8: OpenBSD
other = /dev/hdc1
label = OpenBSD

# Slackware
other = /dev/hdc5
label = Slack12.0

# Zenwalk
other = /dev/hdc2
label = Zenwalk4.6.1

# Vector6.0
other = /dev/hdc13
label = Vector6.0
root@slackerz:/mnt/vl/etc#
 
Old 02-14-2011, 07:54 AM   #4
ic_torres
Member
 
Registered: Nov 2005
Location: ABAP
Distribution: slackware 12.0, Vector Linux STD 6.0 and 5.8, ZenWalk 4.6.1, OpenBSD 3.9
Posts: 389

Original Poster
Rep: Reputation: 34
and here is the LILO of the installed VL6.0

Quote:

# Partition 1 : DOS/Windows
other = /dev/sda1
label = Win
table = /dev/sda
# Partition 2: Linux GUI mode
image = /boot/vmlinuz
root = /dev/sda6
label = linux
append = "splash=silent "
read-only
initrd = /boot/initrd
# Partition 3: Linux TUI mode
image = /boot/vmlinuz
root = /dev/sda6
label = linux-tui
append = "2 splash=silent "
read-only
initrd = /boot/initrd
# Partition 4: Linux GUI mode
image = /boot/vmlinuz
root = /dev/sda6
label = linux-gui
append = "4 splash=silent "
read-only
initrd = /boot/initrd
# Partition 5: Linux
image = /boot/tamu/vmlinuz-vector-sda3
root = /dev/sda3
label = vector-sda3
read-only

# Partition 6: Linux
image = /boot/tamu/vmlinuz-vector-sda5
root = /dev/sda5
label = vector-sda5
read-only

# Partition 7: Linux
image = /boot/tamu/vmlinuz-vector-sda7
root = /dev/sda7
label = vector-sda7
read-only
initrd = /boot/tamu/initrd-vector-sda7
# Partition 8: Linux
image = /boot/tamu/vmlinuz-vector-sda8
root = /dev/sda8
label = vector-sda8
read-only
initrd = /boot/tamu/initrd-vector-sda8




 
Old 02-14-2011, 08:52 PM   #5
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Arch
Posts: 3,013

Rep: Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225
Since you are chainloading Slackware and Zenwalk I'll assume you want to chainload Vector as well. You should have at least this in the Vector Linux lilo.conf:
Code:
boot = /dev/hdc13
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
prompt
timeout = 1200

# Vector6.0
image = /vmlinuz # path to Vector Linux kernel from its root filesystem
  label = Vector6.0
  initrd = /initrd.gz # if needed
Then run lilo from Vector Linux, or run lilo -r /mnt/hdc13 from your main distro. Then you should be able to rerun lilo from your main distro without error.
 
Old 02-14-2011, 09:13 PM   #6
ic_torres
Member
 
Registered: Nov 2005
Location: ABAP
Distribution: slackware 12.0, Vector Linux STD 6.0 and 5.8, ZenWalk 4.6.1, OpenBSD 3.9
Posts: 389

Original Poster
Rep: Reputation: 34
do you mean that i just need to add this lines on the "Vector6.0" LILO file?

Quote:

boot = /dev/hdc13
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
prompt
timeout = 1200

# Vector6.0
image = /vmlinuz # path to Vector Linux kernel from its root filesystem
label = Vector6.0
initrd = /initrd.gz # if needed
did i get it right?

then run lilo to update the file. ..
then reboot.. then try to load the VL6.0 again. . .
 
Old 02-15-2011, 05:24 PM   #7
ic_torres
Member
 
Registered: Nov 2005
Location: ABAP
Distribution: slackware 12.0, Vector Linux STD 6.0 and 5.8, ZenWalk 4.6.1, OpenBSD 3.9
Posts: 389

Original Poster
Rep: Reputation: 34
BIG THANKS to ntubski. . .you gave me the idea
 
  


Reply

Tags
lilo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to use Windows Boot Loader - Install to Boot Sector of Linux Partition? Xenarios Linux - Newbie 7 07-30-2010 04:41 AM
Setting up a /boot sector after windows and linux are installed? lifeforce4 Linux - Newbie 11 02-19-2008 05:47 PM
Installed GRUB on MBR or First Sector of boot zillah Fedora 6 06-16-2005 12:46 PM
Miseries at install from HDD&floppies, with vector ISO& how to boot with vector linux prctom VectorLinux 9 06-29-2004 06:27 AM
"LI" from boot floppy? Can't load XP or Linux. Damaged MBR or boot sector or ...? SparceMatrix Linux - General 10 09-27-2002 02:20 PM


All times are GMT -5. The time now is 10:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration