LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-17-2004, 02:18 PM   #1
boombastic
LQ Newbie
 
Registered: Aug 2004
Location: Italy
Distribution: Vidalinux(Gentoo stage 3)
Posts: 21

Rep: Reputation: 15
boot loader problem


I had winxp, i installed first mandrake 10(hda5,lilo as bootloader) and then fedora core 2(hda6,grub) with hda7 as common /home partition.Mandrake didn't boot anymore so i put initrd and kernel.img from /boot folder from Mandrake partition into the boot folder of Fedora and updated the grub.conf ao everything went ok:i could boot both fedora and mandrake.Then i set in the grub .conf the win os as default but now always lilo starts and i cannot boot fedora anymore,only win and mandrake.How can i remove lilo or configure it to also boot fedora?Where is its conf file?
 
Old 08-17-2004, 02:27 PM   #2
doctor1986
LQ Newbie
 
Registered: Jul 2004
Location: some place where no one can find me
Posts: 10

Rep: Reputation: 0
well mate i had similar problem. infact you are able to boot i was not!!! what happened was on my one is i did made a 7 gig of partition for linux and i was trying to make a dual boot with winxp pro. everything went very well and as well as booting but then i did not like the madrakes boot loader and i thought only way to remove this would be booting in windows and deleting the partition.... guest what then.... i did delete the partition and then i try to re boot but however this time i could not even boot on to any OS !! ! ! !! !

can you Imagen how do i feel. i did not have any 2nd PC for me to boot it on that that as a slave and try to back up the data but for get it.. i had to do a hard format which means i had to erase everything. don't ask me about back ups because they did not work either. i have lost about 50GB of data in 45 mins....
 
Old 08-17-2004, 05:44 PM   #3
boombastic
LQ Newbie
 
Registered: Aug 2004
Location: Italy
Distribution: Vidalinux(Gentoo stage 3)
Posts: 21

Original Poster
Rep: Reputation: 15
I think that lilo is now installed onto my hda1 while grub is on the mbr so when i set win(hda1) as default os to boot always starts lilo.MAybe i really wrong,don't know,anyone else has some ideas?
 
Old 08-21-2004, 02:05 PM   #4
two_black_dogs
LQ Newbie
 
Registered: Jan 2004
Location: Western NY, USA
Distribution: DamnSmallLinux 0.5.3.1 , Knoppix 3.3, Morphix 0.4-1, SLAX 3.0.25-2, Puppy Linux 097
Posts: 10

Rep: Reputation: 0
I don't use GRUB, but I found this on a tips page.
I found it weird and noteworthy.
It might be part of your problem.
Quote:
Remember: GRUB numbers partitions from ZERO while linux counts from ONE So:

root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1
... and:

root (hd0,5)
kernel /boot/vmlinuz root=/dev/hda6
... note how GRUB's (hd0,0) is Linux' /dev/hda1 and GRUB's (hd0,5) is Linux' /dev/hda6
Also this:
Quote:
Note: One slight wrinkle with grub is that /etc/grub.conf is a symbolic link to /boot/grub/grub.conf. This can be useful to know when /boot is a separate partition.
HTH
 
Old 08-21-2004, 03:00 PM   #5
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there
u cannot havve both lilo and grub on ur MBR
u can have either
to installl grub u need ti run
#grub-install /dev/hda

for lilo do

#lilo

if u do not get what u want,,,post the output of the grub-install command here and ur grub.conf also

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot loader problem euaruksakul Linux - Newbie 10 01-13-2007 11:31 AM
Problem with Boot up loader blackman890 Mandriva 1 04-09-2005 07:12 PM
problem with boot loader makaveli0129 Mandriva 1 11-01-2004 11:20 PM
Problem with boot loader alexr186 Linux - Software 4 06-17-2004 08:43 AM
boot loader problem rzee Linux - Newbie 12 02-14-2003 11:49 AM


All times are GMT -5. The time now is 01:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration