LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-17-2004, 06:55 PM   #1
eddieb
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Rep: Reputation: 0
Question boot hangs after running /etc/init.d/boot.local


Hello,

I am running Suse 9.1 and I have had it up and running after initial problems with GRUB and partitions etc. but now it hangs during bootup and I don't recall changing anything within Linux.

Here are the last few lines that are displayed:

.
.
.
.
System Boot Control: The system has been
Skipped features:
System Boot Control: Running /etc/init.d/boot.local
INIT: Entering runlevel: 5


Then it just hangs. It appears /etc/init.d/boot runs OK but not boot.local

Is it a problem with the run level it's trying to enter? I haven't a clue.

Any ideas on how I can solve this problem would be greatly appreciated. I think (sounds crap, I know) I am using lilo and not grub. Any further info required, please get back to me.

Thanks in advance.,
Leon
 
Old 07-18-2004, 06:08 AM   #2
eddieb
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Unhappy also hangs on runlevel 3

Hello,

I have also tried to boot in failsafe mode but this hangs too, only trying to enter runlevel 3 and not 5.

Are there any boot options I could use so I can access Linux and investigate?

Thanks in Advance,
Leon
 
Old 07-18-2004, 06:57 AM   #3
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: Ubuntu, FreeBSD, NetBSD
Posts: 1,449

Rep: Reputation: 47
boot it in single user mode and take a peek at the start files for those run levels.

Probably in /etc/rc3.d/ and /etc/rc5.d/ But I don't have linux memorized... and I can't tell you specifically what order those run the files but I am certain there is a pattern. One of those files is likely causing the problem. It might get stuck or just take a long time to start...

EDIT: Scripts in these directories are executed for each boot state of operation until it becomes fully operational. Scripts beginning with S denote startup scripts while scripts beginning with K denote shutdown (kill) scripts. Numbers follow these letters to denote the order of execution. (lowest to highest)

You might want to try seeing if one of the early S scripts is causing the problem.

Last edited by frob23; 07-18-2004 at 07:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
boot hangs ...init ppp2 sollon Red Hat 0 05-04-2005 08:08 AM
rc.local not running at boot anthjaz Fedora 7 05-12-2004 01:40 PM
rc.local not running on boot??? Evilone Linux - Software 1 09-08-2003 01:01 PM
My box hangs when running boot scripts elkrammer Linux - Distributions 5 03-31-2003 07:02 PM
boot up hangs with init:error while loading /lib/libc.so.6 nates71 Linux - General 0 05-09-2001 01:40 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration