LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-13-2010, 12:21 AM   #1
bond_ruet
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
Arrow bluetooth pairing failed


i have all the setting for bluetooth ok. my pin is 1234 in pin file of my system. when executing wvdial or pppd call gp command, mobile ask for passcode. although i m giving 1234 it's showing pairing failed.
in terminal it's showing

unable to open /dev/rfcomm0 : connection refused

at first there was no file /dev/rfcomm0 and later i created one and named it rfcomm0

can anybody help me to fix the bug

#####################################################################
tnx for ur quick response

******** i'm sorry for not mentioning the details of my broblem and the environment i m using ******

actually i m new to linux so i couldn't understand what might be required to solve my problem.

i m using fedora 6 and nokia 5130

hcid.conf contents are:

options {

autoinit yes;
security auto;
pairing multi;
pin_helper /etc/bluetooth/pin-helper;
}

device {

name "t43 (%d)";
class 0x3e0100;
iscan enable; pscan enable;
lm accept;
lp rswitch,hold,sniff,park;
}

rfcomm.conf file contains:

rfcomm0 {
bind yes;
device 00:25:CF:08:7A:51;
channel 1;
comment "Nokia";
}


#please help me

Last edited by bond_ruet; 02-14-2010 at 02:57 AM.
 
Old 02-13-2010, 09:01 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,778

Rep: Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625Reputation: 2625
Quote:
Originally Posted by bond_ruet View Post
i have all the setting for bluetooth ok. my pin is 1234 in pin file of my system. when executing wvdial or pppd call gp command, mobile ask for passcode. although i m giving 1234 it's showing pairing failed.
in terminal it's showing

unable to open /dev/rfcomm0 : connection refused

at first there was no file /dev/rfcomm0 and later i created one and named it rfcomm0

can anybody help me to fix the bug

tnx
Spell out your words, please, and this isn't a bug.

You say "i have all the setting for bluetooth ok". Obviously not, since you're not pairing with your phone. You don't say what version/distro of Linux you're using, or what desktop environment, or what hardware, but try using Blueman or another bluetooth utility, and get your pairing fixed first. After that, the man pages on rfcomm and hcitool would be of help to you.

Manually creating the rfcomm0 device is not a good idea...that's created when the channel bonding takes place. Since you're doing it manually, either the mknod process is going to fail, or it's creating another rfcomm device, which wvdial isn't finding.

Give us some details about what you're running, and we can try to help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pairing Samsung SPH-m510 mobile phone through Bluetooth USB 2.0 Dongle failed Scubyw Mandriva 3 10-05-2009 12:04 AM
bluetooth pairing deadlinx Ubuntu 15 08-02-2009 03:26 PM
Bluetooth pairing jmike72 Linux - Hardware 2 01-06-2008 09:08 AM
Bluetooth pairing Dj Blaze Linux - Laptop and Netbook 0 01-28-2006 05:46 AM
bluetooth pairing meknb Linux - Hardware 0 01-05-2006 05:06 PM


All times are GMT -5. The time now is 11:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration