LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-04-2011, 07:20 AM   #1
tiomoco
Member
 
Registered: Apr 2009
Posts: 45

Rep: Reputation: 15
blocked update lucid lynx


Lucid Lynx here..! I can't update my system, neither by Update Manager, nor by command line as root. This is what i got:
Reading package lists... Done
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://deb.opera.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A2019EA84E7532C8

W: Failed to fetch http://deb.opera.com/opera/dists/stable/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.
demian@demierda:~$

NOW, a pal told me to write this code and i want to check with you guys if it's right:


gpg --keyserver keyserver.ubuntu.com --recv A2019EA84E7532C8
gpg --armor --export A2019EA84E7532C8 --output A2019EA84E7532C8 | sudo apt-key add -

Thanks for reading this..!
 
Old 03-04-2011, 07:48 AM   #2
redgoblin
Member
 
Registered: Jun 2005
Location: UK
Distribution: Debian
Posts: 189

Rep: Reputation: 41
It looks like the key you have for the repository at opera.com has expired (or you never had it). The commands that your friend has given you grabs the new key from Ubuntu's keys server and installs it for apt to use. It should work fine.

If for some reason it doesn't resolve your problem then could you post the contents of /etc/apt/sources.list and the exact command you're running prior to the error. But that shouldn't be necessary.
 
1 members found this post helpful.
Old 03-08-2011, 01:54 PM   #3
tiomoco
Member
 
Registered: Apr 2009
Posts: 45

Original Poster
Rep: Reputation: 15
update at last!

Quote:
Originally Posted by redgoblin View Post
It looks like the key you have for the repository at opera.com has expired (or you never had it). The commands that your friend has given you grabs the new key from Ubuntu's keys server and installs it for apt to use. It should work fine.

If for some reason it doesn't resolve your problem then could you post the contents of /etc/apt/sources.list and the exact command you're running prior to the error. But that shouldn't be necessary.
The said gpg keys worked fine. next, i used command sudo apt-get update and down came a bunch of updates. The Update Manager loaded automatically, fetched packages and installed them. System updated at last..!!
Thank you guys..!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Puppy 5.1 codename Lucid is out- Now is compatible with Ubuntu 10.04 Lucid Lynx package LXer Syndicated Linux News 0 08-15-2010 03:20 PM
Cannot install Lucid lynx ezzy96 Linux - Newbie 6 06-15-2010 01:59 AM
lucid lynx samba johnh10000 Linux - Networking 7 06-13-2010 10:53 AM
Kivio on Lucid Lynx? leupi Linux - Software 1 05-12-2010 11:26 AM
[SOLVED] Lucid Lynx Beta 1 ? taylorkh Ubuntu 2 03-18-2010 08:28 PM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration