LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Blinking cursor (used to be distorted) on multiple screens, ATI driver (http://www.linuxquestions.org/questions/linux-newbie-8/blinking-cursor-used-to-be-distorted-on-multiple-screens-ati-driver-861162/)

folone 02-07-2011 07:01 AM

Blinking cursor (used to be distorted) on multiple screens, ATI driver
 
Today my cursor became distorted. It worked fine on the second screen, connected to my notebook and screenshots displayed it well. So I did a little googling, and found out, that it is a known bug. I followed different tutorials. And now my cursor is blinking and disappearing. And it drives me crazy. It was a lot better when it was distorted. My xorg.conf:


Code:

Section "ServerLayout"
        Identifier    "amdcccle Layout"
        Screen      0  "Configured Screen Device" 0 0
        Screen        "amdcccle-Screen[2]-0" RightOf "Configured Screen Device"
EndSection

Section "Files"
EndSection

Section "Module"
        Load  "glx"
        Load  "dri"
EndSection

Section "ServerFlags"
        Option            "Xinerama" "off"
EndSection

Section "Monitor"
        Identifier  "0-LVDS"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
        Option            "PreferredMode" "1366x768"
        Option            "TargetRefresh" "60"
        Option            "Position" "1920 330"
        Option            "Rotate" "normal"
        Option            "Disable" "false"
EndSection

Section "Monitor"
        Identifier  "0-CRT1"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
        Option            "PreferredMode" "1920x1080"
        Option            "TargetRefresh" "60"
        Option            "Position" "0 0"
        Option            "Rotate" "normal"
        Option            "Disable" "false"
EndSection

Section "Device"
        Identifier  "Configured Video Device"
        Driver      "fglrx"
        BusID      "PCI:2:0:0"
EndSection

Section "Device"
        Identifier  "amdcccle-Device[2]-0"
        Driver      "fglrx"
        Option            "Monitor-LVDS" "0-LVDS"
        Option            "Monitor-CRT1" "0-CRT1"
        BusID      "PCI:2:0:0"
EndSection

Section "Screen"
        Identifier "Configured Screen Device"
        Device    "Configured Video Device"
        DefaultDepth    24
        SubSection "Display"
                Virtual  3286 1080
        EndSubSection
EndSection

Section "Screen"
        Identifier "amdcccle-Screen[2]-0"
        Device    "amdcccle-Device[2]-0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Virtual  3286 3286
                Depth    24
        EndSubSection
EndSection

Section "Extensions"
        Option            "Composite" "yes"
EndSection

How can I make my cursor look fine, or at least stop blinking?

folone 02-07-2011 08:38 AM

Anyone?

folone 02-07-2011 08:54 AM

Edited:

Code:

Section "Extensions"
  Option      "Composite" "no"
EndSection

It would be great to have compiz enabled, but my eyes really hurt.


All times are GMT -5. The time now is 12:14 PM.