LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2009, 09:25 PM   #1
dcroxton
Member
 
Registered: Apr 2004
Distribution: Ubuntu Jaunty
Posts: 74

Rep: Reputation: 16
Unhappy Blank screen (with background) after logging in


I'm having a weird problem on Ubuntu 8.10. I had the same problem intermittently on 8.04, but it has been constant since upgrading. When I boot up, I get to the Gnome login screen. From there, if I log in to anything except Failsafe Terminal -- that includes Gnome, Xfce, and IceWM -- I get a blank screen. It has the brown Ubuntu background and a cursor, but nothing else.

I'm not exactly a newbie, but I am as far as figuring this out goes. I don't see anything in the log files, and I can't post the full Xorg.0.log here because it is too long. I get "underrun on pipe A!" errors, but that can't be the primary cause, because I can't log in even when that error doesn't show up in Xorg.0.log. Also, when I press ctrl-alt-F1 to try to open up a terminal for debugging, I get errors about unable to open the xdisplay (in the log file: AUDIT: Wed Jun 3 21:49:48 2009: 7586 X: client 4 rejected from local host ( uid=0 gid=0 pid=7601 )).

Please help, I really don't want to have to do another clean install. I have a separate partition for /home, but I still have to re-install all my software, which is a real pain. I've already gone through two clean installs since I began using Ubuntu. I ran 8.04 for a long time with no errors, and I'm running 9.04 on a separate partition, so I know it all works with my hardware; I just need to narrow down this particular problem.

(I see there is an attachment facility, so I am uploading daemon.log, Xorg.0.log, and Xorg.0.log.old. I was able to get into a gnome failsafe session -- I have tried before, unsuccessfully, but it worked this time for some reason -- so the Xorg.0.log is from that, and Xorg.0.log.old from the prior attempt. Both of these came after I followed some advice from another thread and deleted all of my gnome settings -- .gconf, .gconf-2, etc.)
Attached Files
File Type: txt Xorg.0.log.txt (36.6 KB, 7 views)
File Type: txt Xorg.0.log.old.txt (31.3 KB, 7 views)
File Type: txt user.log.txt (3.9 KB, 8 views)

Last edited by dcroxton; 06-03-2009 at 10:13 PM. Reason: Updated information
 
Old 06-03-2009, 11:14 PM   #2
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mint-xfce
Posts: 183

Rep: Reputation: 21
Have you tried Ctl-Alt-Backspace to see if you can kill the gui?
Or you can try booting to a console mode then manually starting X using startx?
You can also try telinit 5 (??), to see if anything in the startup scripts could be messing things up!

I have seen this on a Debian install, but it was related to a boot parameter that was invalid.

Hope it helps.
 
Old 06-04-2009, 06:57 AM   #3
dcroxton
Member
 
Registered: Apr 2004
Distribution: Ubuntu Jaunty
Posts: 74

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by roy_lt_69 View Post
Have you tried Ctl-Alt-Backspace to see if you can kill the gui?
Or you can try booting to a console mode then manually starting X using startx?
You can also try telinit 5 (??), to see if anything in the startup scripts could be messing things up!

I have seen this on a Debian install, but it was related to a boot parameter that was invalid.

Hope it helps.
Sometimes I can Ctl-Alt-Backspace, but it automatically restarts X and returns to the login screen -- other times it just leaves me a blank screen.

What parameters do I put into grub to boot into the console? I've tried just adding the number "1", "init 1," and "init=1" -- in all cases, X starts anyway.

I'll try the telinit command tonight. Thanks for your help.
 
Old 06-04-2009, 01:35 PM   #4
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mint-xfce
Posts: 183

Rep: Reputation: 21
In the grub boot menu you should have an option for a different linux.
It might be rescue, debug, single user, or console.
But if not you can edit (temporarily for that boot) the default boot choice and add 2 or 3
on the kernel line to get a console boot (see /etc/inittab).
Quote:
1 is a single user mode with X (can you log in and get a 'working' X, or is it also hung?)
2 is console multiuser mode
3 is like 2 but also runs up some services like networking
4 ??
5 is normal X startup (probably the default)
If you can get 2 or 3 working, login and try startx to see if you get a good X environment running.
If that works then try telinit 5.
Start off first with 2 as it does not run alot of services.

You will want to check your logs to see if anything looks out of place.
 
Old 06-07-2009, 08:20 PM   #5
dcroxton
Member
 
Registered: Apr 2004
Distribution: Ubuntu Jaunty
Posts: 74

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by roy_lt_69 View Post
In the grub boot menu you should have an option for a different linux.
It might be rescue, debug, single user, or console.
But if not you can edit (temporarily for that boot) the default boot choice and add 2 or 3
on the kernel line to get a console boot (see /etc/inittab).


If you can get 2 or 3 working, login and try startx to see if you get a good X environment running.
If that works then try telinit 5.
Start off first with 2 as it does not run alot of services.

You will want to check your logs to see if anything looks out of place.
I've tried booting into a lower level, but no matter what I type on the kernel line (1, 2, 3, whatever), it always boots into a gui login. Moreover, it does the same thing with a version of Jaunty that I have installed on a separate position. Is something wrong with my grub? Should I try re-installing it?
 
Old 06-07-2009, 08:33 PM   #6
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Quote:
Originally Posted by dcroxton View Post
Is something wrong with my grub? Should I try re-installing it?
If you are getting to the Gnome login screen, then no, it's not grub. I had the same situation when I first upgraded from 6.06 to 8.04.

Reboot your PC. When you see "Grub loading..." press ESC to get to the Grub menu. Select "Recovery mode", then "xfix" from the menu. Once xfix has redetected your hardware and corrected xorg.conf, select "Normal boot".

Hope this helps.
 
Old 06-07-2009, 09:29 PM   #7
saagar
Member
 
Registered: Jul 2008
Location: Chennai, India
Distribution: RHEL5, Ubuntu
Posts: 191

Rep: Reputation: 37
To make level 3 your default run level

1.vi /etc/inittab
2.change the line
id:5:initdefault:
to
id:3:initdefault:
3.reboot
---------------
 
Old 06-07-2009, 10:27 PM   #8
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Unfortunately runlevels in Ubuntu don't seem to have the same functionality as in (some) other distros. Not behind an Ubuntu box at the moment to test it.

@topictsarter:
If the answer in post #6 does not help, you can try to cycle through resolutions with <ctrl><alt><+> and <ctrl><alt><->.
Further I think that you can issue an gdm stop from a console, but not 100% sure
 
Old 06-18-2009, 08:05 PM   #9
dcroxton
Member
 
Registered: Apr 2004
Distribution: Ubuntu Jaunty
Posts: 74

Original Poster
Rep: Reputation: 16
To get into a different runlevel in Ubuntu, it appears you have to add "single" at the end of the kernel line -- runlevel numbers don't help. You would think that, if they were going to do things differently from everyone else, they could at least advertise the fact prominently.
 
Old 06-18-2009, 11:20 PM   #10
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
That gets you probably in single user mode which has limited capabilities (not tested but e.g. no networking, no services except the bare minimum). So it's not the same as e.g. runlevel 3 in other distros.

Although I use Ubuntu and it never gives me problems, those changes are what I hate about it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Logging From Background shadypalm88 Programming 6 01-20-2015 02:14 PM
Blank screen when logging out 9nine9 Linux - Desktop 10 12-19-2007 12:13 AM
Blank screen after logging off from KDE dizzi Slackware 15 05-31-2007 08:32 PM
PC Hangs with blank background after Login JepN13 Linux - Newbie 8 02-14-2006 11:50 AM
Logging Off KDE or Gnome Yields Blank Screen philipogletree Debian 1 01-06-2006 04:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration