LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-11-2002, 03:41 PM   #1
cstehle
LQ Newbie
 
Registered: Feb 2002
Location: New Jersey
Posts: 8

Rep: Reputation: 0
Blank screen - screen saver ???


When my system sits idle for about 10 minutes, the screen blanks out and my web server is not accessable. I have read numerous theads that indicate xset and setterm commands, such as: xset s off, setterm s noblank s 0, I've even tried staying in text mode rather than enter kdm, yet nothing does the trick. Help

There's gotta be something simple that I'm missing?

Thanks in Advance,
Chris
 
Old 03-11-2002, 05:21 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,988
Blog Entries: 54

Rep: Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743
xset s noblank
xset s 0 0

works for me.
 
Old 03-12-2002, 12:35 PM   #3
cstehle
LQ Newbie
 
Registered: Feb 2002
Location: New Jersey
Posts: 8

Original Poster
Rep: Reputation: 0
Still a no-go

I've tryed the above settings but still the blank sleep mode. I also tried disabling the dpms (power settings). Any ideas, could it be a video card setting?

Looking a the xset info: blanking is set to no, timout is 0, cycle is 0, and allow exposures is set to no (I tried yes too). I also tried with the screen saver turned both on and off.
 
Old 03-12-2002, 12:52 PM   #4
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
This sounds like a bigger problem than setterm that just deals with output to your monitor, this seems like you have apmd set to put your whole machine to sleep after a certain idle time. Does this only happen to the webserver, or do all other daemon services cack out too? Also, what distro?

Luck,

Finegan
 
Old 03-12-2002, 01:14 PM   #5
cstehle
LQ Newbie
 
Registered: Feb 2002
Location: New Jersey
Posts: 8

Original Poster
Rep: Reputation: 0
It appears that you are correct, smb is also down. It's redhat 7.2.
 
Old 03-12-2002, 01:49 PM   #6
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
Its got to be something having to do with putting your machine to sleep. My guess is apmd, but I don't know much about these daemons as I've never had a problem with them.

If you:

ps aux | grep apmd

and then kill the Pid of that bugger (assuming it doesn't restart... RH does wiggy things), and the machine makes it past 10 minutes at idle then that was it.

Although, honestly I never usually suggest this, but there's probably some cute gui tool in whatever X desktop you're using that could stop it... or:

Reboot the machine, go into BIOS and disable all the cute power management feature that might be it.

Cheers,

Finegan
 
Old 03-12-2002, 01:57 PM   #7
cstehle
LQ Newbie
 
Registered: Feb 2002
Location: New Jersey
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for the input, I disabled the APM in the BIOS, if this dosen't work I'll try the other stuff you suggested.


Thanks Again,
Chris
 
Old 03-12-2002, 02:47 PM   #8
cstehle
LQ Newbie
 
Registered: Feb 2002
Location: New Jersey
Posts: 8

Original Poster
Rep: Reputation: 0
Thumbs up

Finegan -- you are the man! This has been driving me up the wall.

Disabling APM in the BIOS seems to have done the trick. It's been up for about an hour.

Thanks Again,
Chris
 
Old 03-13-2002, 09:44 PM   #9
justiceisblind
Member
 
Registered: Jan 2002
Location: Stevens Point, WI
Distribution: Mandrake 10.0 (P4 2.8 w/ HT, Radeon 9700 Pro, 80 GB/120GB HDDs)
Posts: 242

Rep: Reputation: 30
Another way you can disable APM is in the kernel itself... if you have the kernel sources installed and run a configure on them it asks about power management and whether to enable it or disable it... (at least under slack...), and that should REALLY do the trick if nothing else works...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9200 SE screen flicker in screen saver gargamel Slackware 12 07-09-2005 04:10 PM
screen saver goes off and screen goes black Doug.Gentry Suse/Novell 2 03-26-2005 05:08 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 12:50 PM
Blank screen after initial install screen? CRCool75 Linux - Newbie 2 11-16-2004 09:32 PM
Blank screen saver in 10.0? culturejam Mandriva 6 09-26-2004 08:09 PM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration