LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2014, 06:56 AM   #1
tousif
Member
 
Registered: Sep 2013
Location: Baroda, GJ, India
Distribution: Linux Ubuntu 14.04 LTS - Trusty
Posts: 95
Blog Entries: 1

Rep: Reputation: Disabled
blank screen on start up


Hi everyone,

after recent upgrade from wheezy to jessie, i'm unable to start xserver everuthing runs as terminal how to solve this, any help would be great

i've tried
PHP Code:
Xorg -configure 
but it fails to configure

i'm new bee so keep ot easy to me thanks
 
Old 11-05-2014, 07:45 AM   #2
Soadyheid
Senior Member
 
Registered: Aug 2010
Location: Near Edinburgh, Scotland
Distribution: Cinnamon Mint 17.3 and 18 at present.
Posts: 1,192

Rep: Reputation: 204Reputation: 204Reputation: 204
Type
Code:
$ startx
in a terminal and you should get some error information as to why the Xserver doesn't start.

Play Bonny!

 
Old 11-07-2014, 02:35 AM   #3
tousif
Member
 
Registered: Sep 2013
Location: Baroda, GJ, India
Distribution: Linux Ubuntu 14.04 LTS - Trusty
Posts: 95
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Soadyheid View Post
Type
Code:
$ startx
in a terminal and you should get some error information as to why the Xserver doesn't start.

Play Bonny!

Yup i like to add little more details,

i've 2 kernel installed,

1)Kernal 3.16.6-pae - installed after upgration to jessie
2)kernel 3.2.63-pae - already installed by wheezy

so when i use kernel 3.16.5, xserver shows following error while startx,it's not full error but few last part of it.
Code:
modprobe: error:.../libkmod/libkmod-module.c:816 kmod_module_insert_module(1) couid not find module by name='nvidia_currunt'

modprobe: error: could not insert 'nvdia_currunt'

fatal server error: (EE) no screens found(EE)

please consult the X.org foundation support

please chek the log file etc etc......

server teriminated with error (1).closing log file

xinit: giving up
xinit: unable to connect to x server: connection refused
xinit: server error
i've to reboot pc to post this with kernel 3.2.63......so the log file is different and i'll try to post full error message as soon as possible.

thanks for the responce
 
Old 11-08-2014, 06:57 AM   #4
fatmac
Senior Member
 
Registered: Sep 2011
Location: Surrey/Hants Border, UK
Distribution: BSD & Linux - As long as they are Lightweight
Posts: 1,704

Rep: Reputation: Disabled
Check for the missing module.
Quote:
modprobe: error: could not insert 'nvdia_currunt'
(That looks like a typo.)
 
Old 11-08-2014, 08:22 AM   #5
tousif
Member
 
Registered: Sep 2013
Location: Baroda, GJ, India
Distribution: Linux Ubuntu 14.04 LTS - Trusty
Posts: 95
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by fatmac View Post
Check for the missing module.

(That looks like a typo.)
idk how to do that how to do it?
 
Old 11-08-2014, 12:50 PM   #6
LFS-Fighter
LQ Newbie
 
Registered: Nov 2014
Posts: 5

Rep: Reputation: Disabled
find / -type f -exec grep nvidia_currunt /dev/null {} \; 2>/dev/null

drink some tea...

check the result
 
Old 11-08-2014, 01:59 PM   #7
DarrenDrapkin
Member
 
Registered: Aug 2014
Distribution: Slackware x86 64 current
Posts: 55

Rep: Reputation: Disabled
It is entirely possable that having 2 kernels installed on the same machine is what is causing you gyp. Make sure that your bootloader is only loading one when you power up.
 
Old 11-08-2014, 08:30 PM   #8
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,305

Rep: Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720
How exactly did you install the NVIDIA drivers?
In you situation I would be tempted to press Ctrl+Alt+F2*, log in as root and install nvidia-dkms then reboot**.

*Or F1 or any other F below 7, if you like, but I prefer 2 in case they go the Fedora route of putting X on the first tty.

**not strictly necessary but it will both stop any processes which may cause issues and let you know whether the fix will persist after a reboot.
 
Old 11-08-2014, 11:54 PM   #9
tousif
Member
 
Registered: Sep 2013
Location: Baroda, GJ, India
Distribution: Linux Ubuntu 14.04 LTS - Trusty
Posts: 95
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by LFS-Fighter View Post
find / -type f -exec grep nvidia_currunt /dev/null {} \; 2>/dev/null

drink some tea...

check the result
thanks for the tea i had it and believe me it was awesome .

i was googling and found few solution, i found linux-header for kernel 3.16 was missing hence i intalled it via synaptic and on next reboot everything is running fine now.
 
Old 11-08-2014, 11:59 PM   #10
tousif
Member
 
Registered: Sep 2013
Location: Baroda, GJ, India
Distribution: Linux Ubuntu 14.04 LTS - Trusty
Posts: 95
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by DarrenDrapkin View Post
It is entirely possable that having 2 kernels installed on the same machine is what is causing you gyp. Make sure that your bootloader is only loading one when you power up.
yeah bootloader is loading one kernel at a time, privious it was 3.2.xxx and now it's 3.16.xxx. kernel headers was missing for 3.16.xxx hence i installed it and now everything is fine.

thanks for the responce
 
Old 11-09-2014, 12:07 AM   #11
tousif
Member
 
Registered: Sep 2013
Location: Baroda, GJ, India
Distribution: Linux Ubuntu 14.04 LTS - Trusty
Posts: 95
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
How exactly did you install the NVIDIA drivers?
In you situation I would be tempted to press Ctrl+Alt+F2*, log in as root and install nvidia-dkms then reboot**.

*Or F1 or any other F below 7, if you like, but I prefer 2 in case they go the Fedora route of putting X on the first tty.

**not strictly necessary but it will both stop any processes which may cause issues and let you know whether the fix will persist after a reboot.
actually i performed only upgrade via terminal, and migrated from wheezy to jessie, and everything is automatic i did nothing manually, installed nvidia driver now is 340.xxx.

i tried to use "nouveau" driver and logged in via lightdm or gnome classic, but no success, hence i googled and read some ask ubuntu forums, and few debian forums,and after few terminal commands found kernel headers missing so i installed it and everything is running fine now.

yup ctrl+alt+F1 to F7 i tried them and for debian jessie i found ctrl+alt+F7 working. now i can login and play games and do my work.

thank youvery much for your responce.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
If I type 'xinit' alone to start X, I just get a blank screen and can't exit dividingbyzero Linux - Desktop 1 01-27-2009 05:26 AM
ubuntu install, then blank screen on start up JD Madrox Linux - Desktop 1 11-29-2007 02:14 AM
Blank screen upon start up - 7.10 Server molimo140 Ubuntu 2 11-29-2007 02:10 AM
Screen Becomes Blank When X-windows start danishmr Linux - Software 1 12-10-2004 03:19 AM
unable to start x -- blank screen--slackware 9.1 markpelletier Linux - Software 6 11-19-2003 10:56 AM


All times are GMT -5. The time now is 06:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration