LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Black screen on boot (http://www.linuxquestions.org/questions/linux-newbie-8/black-screen-on-boot-278160/)

Michael Davont 01-15-2005 04:02 PM

Black screen on boot
 
please help i finally got linux installed but now it goes to a black screen everytime i try to boot before it gets to the section to enter your screen name i do not know what to do please help......... I installed Fedora core 3

XavierP 01-15-2005 04:48 PM

It sounds like a graphics card/driver problem. Hit ctrl-alt-Fn (where n is one of your function keys) and switch to a text screen. You will then be able to log in as root and run dmesg to see at what point it has failed.

Michael Davont 01-16-2005 06:49 PM

thank you but that did not help it goes to a black screen directly after
enabling swap [OK] then goes black the only one that says fail is
startup smartd [failed] or something like that i have a compaq presario with an intel celeron pentium 4 processor and 128mb ram and a dell monitor please help as i need to get my computer operational for my college papers a.s.a.p.

also i installed the gnome descktop whether that could be the problem i dont know should i try one of the other desktops that it offers?

Linux~Powered 01-16-2005 07:02 PM

What distribution and bootloader are you using? It's probably a framebuffer problem. If you're running LILO try to edit the...

# VESA framebuffer console @ 800x600x64k
vga = normal <---- edit to normal

Michael Davont 01-16-2005 07:04 PM

i am using Fedora core 3 and the Grub bootl loader as it is all i have cuse it is allready on the fedora disk

Brian1 01-16-2005 07:14 PM

In your /boot/grub/grub.conf at the end of the kernel line it says quiet and something else starting with r****. Delete both items and save.

You can also do this at boot time by hitting the e key for edit and edit the line. Hit b to boot. This does not save it but it lets you experiment before making a permentent change.

Brian1
" Google the Linux way @ http://www.google.com/linux "

Michael Davont 01-16-2005 07:57 PM

thank you brian but now the problem is it will go all that wey until it says local host login i will put what i set to be my login name during the configuration then it will say pwd but it wont let me type at that point then will go to a black screen once again what should i do now and how do you save that change so that i dont have to change it everytime.

Michael Davont 01-17-2005 03:29 PM

Can any body tell me how i may go about geting enternet on my Comp??? I am using dial up

Brian1 01-17-2005 05:27 PM

It should not stop there unless it did before. It should start your gdm or kdm depending which one is setup. GDM is the default unless you change it in /etc/inittab. You can type your username and password there if you want but that is your number 1 tty which is also linked to the gui part on number 7.

Let me try to explain this. When you have your gui up either kde or gnome or whatever it is linked to tty1. To see example of this when your in the gui (which is Alt-Ctrl-F7) hit Alt-Ctrl-F1. This brings you to tty1 ( terminal login ). If you hit Alt-Ctrl-F2 that brings you to tty2 which you can login to and even start another gui which would be at Alt-Ctrl-F8. To get back to the gui hit Alt-Ctrl-F7.

Now it sounds like X is having a problem starting properly or is slow. When you see the terminal at boot it should automatically start the gui login manager. Mine only takes about 1 second and notebook about 2 seconds, but I am loading a few things before it starts also.

You will not see any characters when typing the password. It is default for safety. You should be able to enter it and hit enter. When you get to this point and logged in and the gui still does not start after say 2 minutes type ' kdm ' and see what happens. Let me know if something happens. I will include a few lines from my /etc/inittab file that shows the login manager kdm and the tty's setup. Yours should be the same except for the last line. If I remember it starts something /etc/X11/xdm or something. I myself perfer the kde version called kdm.

Here is the last part of my /etc/inittab file that starts KDM instaed of GDM.
Code:


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:5:respawn:/usr/bin/kdm -nodaemon


Been a long time since I did dial-up and for that that it would be with stuff on linux 4 or 5 years ago. I did have it setup to automatically dial on demand when either it or one of my network machines called out to the internet. Work pretty good except for Windows. I had to configure it to not except calls it made to the internet doing it stupid little check ins to MicroSoft.

If I could be of anymore help just ask.
Brian1
" Google the Linux way @ http://www.google.com/linux "

doblocruiser 01-25-2005 04:29 PM

You can start FC3 without the blackscreen! Disable the following:

edit /etc/sysconfig/init ->

# Turn on graphical boot
GRAPHICAL=no


By default that rule is set to YES!

Regards,
doblocruiser

jschiwal 01-25-2005 04:35 PM

There is a generic video driver that you may try using instead. Under the "Device" section of your XF86config file, change the video driver to "vesa". This may help narrow down where the problem is.

Section "Device"
...
Driver "vesa"


All times are GMT -5. The time now is 07:16 AM.