LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2014, 02:46 AM   #1
nutoubuntu
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Rep: Reputation: Disabled
Black screen, blinking cursor, 'asking for cache data failed';after Ubuntu update


Hi all,
New to linux, ubuntu, and this forum.
I have enjoyed ubuntu for the past few months, but after my last update installation ubuntu would boot to a black screen and blinking cursor. If I let it sit for a while it would give the following:
12.3456789 sd 6:0:0:0 [sdb] assuming drive cache: write through
.............................asking for cache data failed
It would then repeat the lines above but the numbers would get higher.
It would never boot.

I tried a live backtrack and knoppix usbs, and when trying to access my ubuntu files I get:
THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on:
"Access Your Private Data"

or

From the command line, run:
ecryptfs-mount-private

---
Running the above in a terminal gave me this:ERROR: Encrypted private directory is not setup properly

I would ideally want to solve this problem and boot back into ubuntu, but if not, I really want to get my files off the hard drive so I can save them before I wipe and reinstall(yes, I should have backed up)

I have tried to edit the grub with nomodeset and rmmod the ums_realtek, and a few other things I have found with google. None have worked so far.

Any suggestions on how to get my files back or even fix this?

Thanks a million from a newbie.
 
Old 01-16-2014, 02:58 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Are you able to run Ubuntu in rescue mode from grub?
 
Old 01-16-2014, 03:00 AM   #3
qrange
Member
 
Registered: Jul 2006
Location: Belgrade, Yugoslavia
Distribution: Debian stable, amd64
Posts: 805

Rep: Reputation: 32
I'd try to fsck the partitions from LiveCD/USB. would be a good idea to make a complete backup with dd first.
 
Old 01-16-2014, 03:01 AM   #4
nutoubuntu
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Yes I am.
I used the rescue mode to get to the terminal to run the fsck. I was just blindly following another forum post I read, but it was not successful.

Last edited by nutoubuntu; 01-16-2014 at 03:05 AM. Reason: expanded
 
Old 01-16-2014, 02:34 PM   #5
nutoubuntu
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
additional

I let the computer run all night in an attempt to boot, it gave the same 'asking for cache data failed, but it ran through hundreds and hundreds of lines.
The numbers increased with each error report, the first was 55.xxxxxxx I believe, and this morning it was at about 9000.xxxxxxx, it gave a new identical report every minute or so but the numbers would increase anywhere from a few to a few hundred with each report..
 
Old 01-18-2014, 02:50 AM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
What was the error?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem booting 11.10, black screen and blinking cursor after login raven1978 Ubuntu 19 06-07-2012 07:09 PM
Ubuntu 10.10 black screen and blinking cursor ! apanimesh061 Linux - Software 1 09-20-2011 04:17 PM
[SOLVED] Linux Mint 7 bootup stalling with black screen & single blinking cursor. bejiitas_wrath Linux - Newbie 1 07-02-2010 05:58 AM
Black screen with blinking cursor immediately after installing Ubuntu 8.10 lazy_bones1987 Linux - Newbie 9 11-30-2008 11:19 AM
Black screen with blinking cursor mookini Linux - Newbie 4 09-25-2006 10:31 AM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration