LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2006, 09:45 PM   #1
AnonymousX
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Rep: Reputation: 0
Question Black borders and wrong monitor frequency on SuSE Linux 10.0


Well , I see 3-4cm black borders around my screen
I use 17" Monitor and my default display should be 800x600

For Windows XP , Im using 800x600 , 32bit colors , And when i check my monitor frequency , it will be :

37.9KHZ
61HZ

But when I boot to SuSE Linux 10.0 with KDE 3.5.1 ( It doesn't happen in GRUB and SuSE when it loads stuff up ) I see these black borders and i can't set frequency to default Windows setting , Frequencies are double... They're :

69.1KHZ
108HZ

( My monitor model is DPC DELTA H-700 )

Is there a way to force it's frequency and delete those black borders and make it 800x600 fullscreen ? frequency stuff makes my eyes bleed too :|
( It displays properly in Knoppix 4.2 CD )

Oh , and another question , I installed all fonts in Fonts section but i cant find Helvetica , I need this font.

Thanks for helping !
I'm Linux

Last edited by AnonymousX; 03-12-2006 at 09:52 PM.
 
Old 03-12-2006, 10:03 PM   #2
devavictrix
Member
 
Registered: Jan 2006
Posts: 70

Rep: Reputation: Disabled
I think you might have to mess with your x config file.

If you use xorg it is in etc/x11/xorg.conf
 
Old 03-12-2006, 10:09 PM   #3
AnonymousX
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Original Poster
Rep: Reputation: 0
So what section I have to edit to force it to specified frequency ? And if I force those frequencies , Will it change me to fullscreen ? ( No black borders at all )

*Yes , I use xorg.

Last edited by AnonymousX; 03-12-2006 at 10:15 PM.
 
Old 03-12-2006, 10:16 PM   #4
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi AnnonymousX, you have to edit the file /etc/X11/xorg.conf with a text editor (vim, nano, gedit), you have to do this as root.

Once there, find the following section (This is the section for my system):

Quote:
Section "Monitor"
Identifier "Monitor0"
DisplaySize 352 264
HorizSync 30-96
VertRefresh 50-160
Option "DPMS"
There you have to put your monitor specs. Once done that, you have to restart X, just type Ctrl+Alt+Backspace.

Remember to do a backup of this file before changing it.
 
Old 03-12-2006, 10:56 PM   #5
AnonymousX
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Original Poster
Rep: Reputation: 0
err... need help now , I edited the file and now X server wont start anymore :\ it says error screen not found or something after i login into my acc , not root acc , and type startx , and restarting pc wont solve the prob - I did the backup already , How i delete edited xorg.conf and rename xorg.conf_bak to xorg.conf in Knoppix ? ( Knoppix 4.2 CD ) It says I have no permission or something , Im running konqueror thru the shell with root acc :\ and im confused about /mnt/ , /dev/ Please help ! Thanks !

Last edited by AnonymousX; 03-12-2006 at 11:48 PM.
 
Old 03-12-2006, 11:14 PM   #6
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Let me see if I understand, when you try to boot in SuSE you couldn't start X. And then you use Knoppix 4.2 as a Live CD to access your system.

If this is the situation. To delete the file /etc/X11/xorg.conf of SuSE, you have to mount the SuSE root partition. Type the following in a console in Knoppix:

Quote:
su
Password: (enter root password)
# mkdir /mnt/suse
# mount /dev/hda1 /mnt/suse
# rm /mnt/suse/etc/X11/xorg.conf
# mv /mnt/suse/etc/X11/xorg.conf_bak /mnt/suse/etc/X11/xorg.conf
Note. I'm assuming that the SuSE root partition is /dev/hda1, change to the correct partition in your system.

Hope I understand you.
 
Old 03-12-2006, 11:27 PM   #7
AnonymousX
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Damnit ! Now it messed up even more ! xorg.conf , xorg.conf_bak are gone ! omg.
 
Old 03-12-2006, 11:36 PM   #8
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
This is just the learning process in Linux, don't worry too much about it.

Try the following:

Boot in your SuSE system, it'll start the boot process, but will fail in start X, at this point SuSE will put you in a console where you have to log in. If you just have a black screen press Ctrl+Alt+F1 and login as root.

Now you can use the SaX2, the SuSE Advanced X-configuration, just type:

Quote:
sax2
follow the instructions carefully, and then sax2 will write a new xorg.conf file for you.

In case sax2 fails, you can also use:

Quote:
xorgconfig
 
Old 03-12-2006, 11:39 PM   #9
AnonymousX
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Original Poster
Rep: Reputation: 0
I did everything from your #6 post and it works now ! thanks. Good that i had xorg.conf~ ( Backup file ) :P

But im not sure if its latest configured file or old one coz i remember that i disabled backup on save or something in KWrite long time ago... :\

Oh , and about Helvetica font , Where can I find it ?

Last edited by AnonymousX; 03-12-2006 at 11:46 PM.
 
Old 03-12-2006, 11:49 PM   #10
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Glad that worked. You can verify if you have the old one by booting in SuSE and check if you have the same problem.

Anyway, in SuSE you have two options when you try to configure your system:

- Using SuSE configuration tools, most of then have a GUI, in this case you have to use sax2, or

- Edit by yourself the config files, using a text editor.

You can try first using the SuSE tools if you don't want to complicate yourself.
 
Old 03-14-2006, 06:05 AM   #11
AnonymousX
LQ Newbie
 
Registered: Mar 2006
Posts: 12

Original Poster
Rep: Reputation: 0
For horizontal , vertical freq in xorg.conf , If i want to force them , I have to put something down like 38 - 38 ? I think I put only 38 last time , so that's why X wont load ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor Frequency problem when starting with SuSE Live CD limboonlee SUSE / openSUSE 3 05-11-2005 11:48 AM
help - lcd screen running at wrong frequency eppebianco Linux - Laptop and Netbook 0 03-30-2005 08:42 PM
wrong cpu frequency dresnu Mandriva 12 03-08-2005 06:11 PM
Monitor Frequency manuagri Linux - Hardware 3 02-28-2005 06:11 AM
Monitor is black when booted to Linux. wcovelli Linux - Newbie 6 11-22-2004 02:15 PM


All times are GMT -5. The time now is 06:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration