LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-11-2004, 03:41 PM   #1
iammike
Member
 
Registered: Aug 2004
Location: Virginia
Distribution: Ubuntu
Posts: 38

Rep: Reputation: 15
Bittorrent GUI Problem


Ok, I've had this running on Mandrake 10 before but now I'm running Mandrake 10.1. I installed both libraries that are needed along with the BT RPM....I then install the BT GUI RPM. This process worked for me before, twice, on Mandrake 10 but now, when something like FireFox tries to run it, nothing happens. I've also tried removing the packages and reinstalling them all but came to the same result.

I went to a console and ran the program as myself and as root and I get the same results every time.

Code:
Traceback (most recent call last):
  File "./btdownloadgui.py", line 13, in ?
    from wxPython.wx import *
  File "/usr/lib/python2.3/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib/wxPython/lib/libwx_gtk2u-2.4.so.0: undefined symbol: _gtk_accel_group_detach
You guys have any ideas how to get this to work, I have to have Bittorrent on my system.

.....and yes, I'm a self proclaimed
 
Old 08-14-2004, 11:03 PM   #2
iammike
Member
 
Registered: Aug 2004
Location: Virginia
Distribution: Ubuntu
Posts: 38

Original Poster
Rep: Reputation: 15
Nobody has any ideas? I really need BT to work but I really don't know what that error means.

EDIT: Ok, I went and downloaded the newest versions of BitTorrent, wxPython and Python but now I'm getting this error.

Code:
Traceback (most recent call last):
  File "./btdownloadgui.py", line 262, in run
    app = btWxApp(0, params)
  File "./btdownloadgui.py", line 249, in __init__
    wxApp.__init__(self, x)
  File "/usr/lib/python2.3/site-packages/wx/_core.py", line 5227, in __init__
    self._BootstrapApp()
  File "/usr/lib/python2.3/site-packages/wx/_core.py", line 4915, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "./btdownloadgui.py", line 253, in OnInit
    d = DownloadInfoFrame(doneflag)
  File "./btdownloadgui.py", line 108, in __init__
    colSizer.Add(50, 50, 0, wxEXPAND)
  File "/usr/lib/python2.3/site-packages/wx/_core.py", line 8950, in Add
    return _core_.Sizer_Add(*args, **kwargs)
TypeError: wxWindow, wxSizer, wxSize, or (w,h) expected for item

Last edited by iammike; 08-15-2004 at 12:34 AM.
 
Old 08-15-2004, 01:05 AM   #3
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
Dont know how to fix this but you could try a different downloader.

Azureas is a java bittorrent downloader for linux.

It is a java program so you will also need to download SUN's JRE (java runtime environment) to run it.
 
Old 08-15-2004, 03:26 AM   #4
Eule
LQ Newbie
 
Registered: Aug 2004
Posts: 19

Rep: Reputation: 0
hi iammike

You must install the wxpython. Python only is not enough.

But like jax8 have had sad (???). Azureus is better. I use ist too and havn't any problems.


Edit: sorry . I did't read your second post. I Think you should compile wxpython for your system, because these RPMs are as far as i know all beta releases.

Last edited by Eule; 08-15-2004 at 03:32 AM.
 
Old 08-15-2004, 03:34 AM   #5
Eule
LQ Newbie
 
Registered: Aug 2004
Posts: 19

Rep: Reputation: 0
... and you must install the wxpythonGTK RPMs.
 
Old 08-15-2004, 10:13 AM   #6
iammike
Member
 
Registered: Aug 2004
Location: Virginia
Distribution: Ubuntu
Posts: 38

Original Poster
Rep: Reputation: 15
I do have the wxpythonGTX RPM's installed as well, I've tried just about everything and well....I guess youcould say I keep walking into the same brick wall.

I can try that JAVA one but from what I can read, you have to start itmanually from the command prompt, I'd just like something I can click, tell it where to save and move on with life. What's really frustrating is that I've had this BT client working before but after I had to reinstall the system, it just won't work.

***My one major complaint about Linux....program installation is a pain in the butt***
 
Old 01-01-2005, 07:40 PM   #7
pickarooney
Member
 
Registered: Aug 2003
Distribution: (X)ubuntu Maverick
Posts: 152

Rep: Reputation: 15
this just started happenign me today after I updated to libglib and libgtk2 - 2.4.9
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
BitTorrent GUI not working saravkrish Fedora 10 08-09-2005 07:06 PM
Bittorrent gui not installing bcf2 Linux - Software 4 05-29-2005 02:15 AM
bittorrent web gui RandomLinuxNewb Linux - Software 0 08-22-2004 10:59 PM
bittorrent-gui: how to limit upload speed? greno Linux - Software 1 05-18-2004 03:53 PM
Bittorrent gui problems xanas3712 Slackware 4 05-14-2004 01:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration