LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-23-2013, 05:12 PM   #1
lou2215
LQ Newbie
 
Registered: Nov 2013
Posts: 4

Rep: Reputation: Disabled
Binding NIS Client not working


I am getting the error ypbindproc_domain: domain not bound when trying to bind my client to my NIS server

domain=it340
my server = 192.168.1.185 [also running dns, and dhcp, and nfs]

server can run ypwhich etc: output for that is localhost.

i have set domain it340 server 192.168.1.185 in my yp.conf for my client, but I am completely unable to bind to it. firewall is turned off

Any possible suggestions on how I can get this to work?
 
Old 11-25-2013, 01:15 PM   #2
netnix99
Member
 
Registered: Jun 2011
Distribution: redhat, CentOS, OpenBSD
Posts: 298

Rep: Reputation: 98
Do you have the file /var/yp/securenets? If so, have you added the IP of the client to it? You can also put a network statement in this file if you prefer, but it is more secure to list the client PC's that are allowed to bind to the the NIS domain.

HTH...

Last edited by netnix99; 11-25-2013 at 03:57 PM.
 
Old 11-25-2013, 02:19 PM   #3
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,654

Rep: Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255
What does ypwhich report on the client having problems?
 
Old 11-25-2013, 10:43 PM   #4
lou2215
LQ Newbie
 
Registered: Nov 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
I wound up having my server bound to something maybe itself, and the client was unable to bind, thanks for everyone's posts though! They all helped!

Can mark this as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nis Client On Centos not working with Suse Server . But works with Suse Nis Client jibinforu Linux - Server 2 07-23-2009 09:44 PM
Nis Client On Centos not working with Suse Server . But works with Suse Nis Client jibinforu Linux - Networking 1 07-13-2009 06:51 AM
RHEL 4 client in VMware not binding to NIS server. panini.kompella Linux - Newbie 0 03-17-2008 05:10 AM
RHEL 4 client in VMware not binding to NIS server. Ping works fine and NIS server wo panini.kompella Linux - Server 1 03-17-2008 12:06 AM
NIS: yppasswd not working on client machines ice_hockey Linux - Networking 1 06-07-2005 01:21 AM


All times are GMT -5. The time now is 08:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration