LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2004, 02:20 PM   #1
cucolin@
Member
 
Registered: Nov 2003
Location: USA
Distribution: Ubuntu, Fedora
Posts: 415

Rep: Reputation: 31
Angry /bin/grub-install not working


Hi friends, I was told to use the command: /sbin/grub-install in order to install grub on my MBR. I told to log into resue mode. Is it necessary to log into rescue mode to accomplish this? How do you do it? When I type the command above it tells me that "install_device not specified. The I type /sbin/grub-install /dev/hd0 it tells me "Not found or not a block device". What should I do? I don't want to keep using a floppy disk to boot linux(Red Hat 8). I have a dual boot system with WinMe.

This is my grub.conf file:

#boot=/dev/hd0,0
default=0
timeout=10
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-14)
root (hd0,4)
kernel /boot/vmlinuz-2.4.18-14)
initrd /boo/initrd-2.4.18-14.img
title WinMe
rootnoverify (hd0,0)
chainloader +1

Been trying to solve this problem for weeks.

Thanks
 
Old 02-06-2004, 02:23 PM   #2
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
should be:

/sbin/grub-install /dev/hda
 
Old 02-06-2004, 02:45 PM   #3
cucolin@
Member
 
Registered: Nov 2003
Location: USA
Distribution: Ubuntu, Fedora
Posts: 415

Original Poster
Rep: Reputation: 31
thank you very much!

You are the best, thank you very much! where have you been all this time?

Thank very much again!

Now I'm going to enjoy my new machine......Thanks again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub error 17, and wont reinstall using grub-install! chiefreborn Linux - General 6 06-06-2007 10:29 AM
.sh.bin install? JoeUser11 Linux - Newbie 3 01-22-2005 09:42 AM
/usr/bin/less not working Mikko Slackware 1 11-11-2004 05:25 PM
grub-install isnt working utsav_verma Linux - Newbie 10 07-21-2004 01:56 PM
why did bash 2.05b install delete /bin/bash & "/bin/sh -> bash"? johnpipe Linux - Software 2 06-06-2004 06:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration