LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-17-2004, 08:21 AM   #1
Big Dog XII
LQ Newbie
 
Registered: May 2004
Location: /UK/ENG/
Distribution: Gentoo
Posts: 7

Rep: Reputation: 0
Big "X" Cursor in Middle of Desktop


Hi,

I've been poking around the web and haven't seen this discribed anywhere else.

I have recently built a new PC (AMD Anthlon Processor) and installed RH9. After I downloaded a new savage Video Driver (for the on-board graphics) every thing seems to working ok. However, there is a large "X" cursor on desktop (on top of all apps).

Has anyone got any ideas? Might there be a problem with the XFree86 config file?
 
Old 05-17-2004, 11:14 AM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Just off hand it sounds like the old mouse cursor from early Linux. Does it move when you move the mouse? Perhaps a screen shot will give a better idea.
 
Old 05-17-2004, 11:33 AM   #3
Big Dog XII
LQ Newbie
 
Registered: May 2004
Location: /UK/ENG/
Distribution: Gentoo
Posts: 7

Original Poster
Rep: Reputation: 0
The mouse isn't effected. It does look like the the X mouse cursor, but this appears in addition to the normal mouse cursor.

Everything use works fine. I have upgraded everything (except the kernal) using up2date.

I will post a screen shot on the web, when I get home and figure out how to create one.

Thanks
 
Old 05-17-2004, 11:36 AM   #4
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Post the contents of /etc/X11/XF86Config-4
 
Old 05-17-2004, 02:08 PM   #5
Big Dog XII
LQ Newbie
 
Registered: May 2004
Location: /UK/ENG/
Distribution: Gentoo
Posts: 7

Original Poster
Rep: Reputation: 0
Just for laughs, I upgraded my kernel this evening to 2.4.20-31.9.

The "X" appeared when I rebooted (as always, it appears after I enter my login
and password, during the startup screen). I took the screen shot, as
requested, but the "X" didn't look like it appeared in the image. I went to
double check, so i opened the image in Nautilis and as soon as the image
loaded, the "X" went away!

When I logged off and relogged in , the "X" was back, but viewing a picture does remove it.

---------------------------------------------------------
Here is /etc/X11/XFree86Config


# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"Section "InputDevice"

Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell M780"
DisplaySize 320 240
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavage KM133"
VideoRam 32768
Option "UseBIOS" "off"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
"640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


EndSection
 
Old 05-17-2004, 02:26 PM   #6
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
This part looks a little funny:
---------------------------------------
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection
---------------------------------------

I'm just a newbie, but I'm suspicious of the line:

InputDevice "DevInputMice" "AlwaysCore"

Try commenting out that line to:

# InputDevice "DevInputMice" "AlwaysCore"

The previous line with "Mouse0" and "CorePointer" should be the normal line for configuring the pointer with a PS/2 mouse. I have no clue what the "DevInputMice"/"AlwaysCore" line is supposed to do. It sounds like it could be something which puts that "X" shaped pointer on the screen, though.
 
Old 05-17-2004, 04:57 PM   #7
Big Dog XII
LQ Newbie
 
Registered: May 2004
Location: /UK/ENG/
Distribution: Gentoo
Posts: 7

Original Poster
Rep: Reputation: 0
I commented out the InputDevice "DevInputMice" "AlwaysCore" line, but no change.
 
Old 05-17-2004, 05:19 PM   #8
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Oh well, I'm out of ideas, then. Anyone else? You might try posting this question in JustLinux, or other places.
 
Old 05-17-2004, 05:37 PM   #9
Big Dog XII
LQ Newbie
 
Registered: May 2004
Location: /UK/ENG/
Distribution: Gentoo
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks Issac. I do apprciate all your assistance.

Do you know where I can find the error log for XFree86? Maybe it will have a clue.
 
Old 05-17-2004, 06:13 PM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
It should be in /var/log. And as long as you're rooting around in logs, check your messages file and syslog.
 
Old 05-18-2004, 02:34 AM   #11
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Quote:
Originally posted by Big Dog XII


Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Note you have 2 entries for a mouse. Do you have 2 mice attached? I would suggest rem'ing the second InputDevice and see if that resolves the problem.

Quote:
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection
I am also curious about the double definitions here unless this is a RH thing but XFree86 should be the same in all distros. In my Config-4 the ServerLayout is;
InputDevice "Mouse0"
and the Corepointer is defined as an option
but in yours
InputDevice "Mouse0" "CorePointer"

My Mouse InputDevice is;

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "BaudRate" "1200"
Option "Resolution" "2000"
 
Old 05-18-2004, 08:12 AM   #12
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
In my /etc/X11/XF86Config-4, there are InputDevice sections for PS/2, serial, and USB mice (Knoppix hard drive install). This causes no problem; the only devices which are actually used by the X server are what's listed in the ServerLayout section.

It was convenient to have all three of those InputDevice sections around, because it meant that all I needed to do when I added a serial mouse was to add a line to the ServerLayout section.
 
Old 09-02-2006, 05:57 PM   #13
Marek_AGH
LQ Newbie
 
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
Lightbulb I had the same problem and I know the solution

I had the same problem and I found the solution on one of the linux forums.
You have to add one line in this part of XF86Config-4 file:

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavage KM133"
VideoRam 32768
Option "UseBIOS" "off"

Option "hw_cursor" "false"

EndSection

then reload the xserver - just do the instructions mentioned in the head of your XF86Config-4 file

Reboot your machine and be a happy user of Linux system without that awful "X" on the middle of the screen.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 04:07 PM
Odd Problem KDE doesn't work with "big desktop" xanas3712 Slackware 0 09-22-2004 12:05 AM
Dual boot Xp/Mandrake 10, "Big Error" need help jmr0311 Mandriva 3 07-05-2004 01:30 PM
"Big Desktop" fgrlx Incanus Linux - Hardware 2 10-02-2003 11:31 PM
Hiding the desktop and the "system tray" of KDE Desktop... alkebulan Programming 2 07-04-2003 05:10 PM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration