LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2007, 08:44 AM   #1
dotancohen
Member
 
Registered: Dec 2004
Location: Haifa
Distribution: Fedora Core 4, Kubuntu
Posts: 235

Rep: Reputation: 32
Beryl not affecting KDE


On my Dell laptop (ATI x1400 video card) I have installed FC6. I then installed beryl as per the instructions at:
http://wiki.beryl-project.org/wiki/Install/Fedora_Core

I added the script to start it when I log in:
[dotancohen@localhost ~]$ cd .kde/Autostart/
[dotancohen@localhost Autostart]$ ls -l
total 8
-rwxrwxr-x 1 dotancohen dotancohen 27 ינו 26 12:46 beryl.sh
[dotancohen@localhost Autostart]$ cat beryl.sh
#! /bin/bash
beryl-manager
[dotancohen@localhost Autostart]$

However, it doesn't do anything! KDE is exactly as it was before. No
wobbly windows, etc. I've lookin in beryl-settings but I don't see
anything that would prevent it from functioning. What should I check?
We're having company come over this evening and I'd like for them to
see what Fedora is, with eye candy. Thanks.

Dotan Cohen

http://what-is-what.com/what_is/malware.html
http://lyricslist.com/lyrics/artist_.../388/orgy.html
 
Old 01-26-2007, 12:16 PM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Before you go automating it, make sure that if you manually run (when X is running, you're logged in to KDE)
Code:
beryl-manager
you get Beryl running and see all the eye-candy. Only after this try automating it. This is for a simple reason: if you can't manually run it, you know the problem is somewhere in running Beryl, or if you can manually run it, you know that if the automated launch doesn't work, the problem is in the automation, not in running Beryl itself.

You did install the KDE-"version" of Beryl, didn't you (as I believe there are different versions for KDE and Gnome)?

I also noticed myself that even if I had Beryl automatically starting when I log into KDE, it started but not completely; I still had to manually run beryl-manager to get the window decorations on (for example without it the windows didn't have the bar at the top with the three boxes on the right and window caption on the left). No idea why this was, but actually I don't care; even with ATI's Radeon 9200 card and 3d drivers, good fps, Beryl was slow when trying to scroll pages on a browser, for example. It was fast enough on other aspects, but slow web page scrolling was a pain in the ass
 
Old 01-26-2007, 06:25 PM   #3
sumguy231
Member
 
Registered: Apr 2004
Location: North America
Distribution: Kubuntu 7.04 - Feisty Fawn
Posts: 296

Rep: Reputation: 30
Quote:
You did install the KDE-"version" of Beryl, didn't you (as I believe there are different versions for KDE and Gnome)?
There's only one version of Beryl, but there's a window decorator called Aquamarine for it which uses your existing KDE window theme instead of an Emerald theme. Beryl runs fine on KDE without it, however.
 
Old 01-26-2007, 06:47 PM   #4
dotancohen
Member
 
Registered: Dec 2004
Location: Haifa
Distribution: Fedora Core 4, Kubuntu
Posts: 235

Original Poster
Rep: Reputation: 32
I did in fact install the kde version of beryl:
# yum install beryl-kde

Now, beryl-manager crashes KDE, as does glxinfo. What can I do?
 
Old 01-26-2007, 07:29 PM   #5
sumguy231
Member
 
Registered: Apr 2004
Location: North America
Distribution: Kubuntu 7.04 - Feisty Fawn
Posts: 296

Rep: Reputation: 30
I stand corrected? Perhaps that's a Fedora Core thing, there's no such package for Kubuntu or mentioned on the Beryl website.
 
Old 01-29-2007, 01:28 AM   #6
dotancohen
Member
 
Registered: Dec 2004
Location: Haifa
Distribution: Fedora Core 4, Kubuntu
Posts: 235

Original Poster
Rep: Reputation: 32
It does seem to be a Fedora thing.

Still, I cannot start beryl-manager without having X crash. Please, what can I check to diagnos?

Dotan Cohen

http://dotancohen.com/howto/netscape_bat_email.php
http://what-is-what.com/what_is/eula.html
 
Old 01-29-2007, 02:13 AM   #7
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
I stand corrected? Perhaps that's a Fedora Core thing, there's no such package for Kubuntu or mentioned on the Beryl website.
It is a Fedora package, sorry I didn't mention that explicitly. Anyway, for me it worked great (Radeon 9200 +open source drivers, Core 6, installed beryl about a week ago). Can you see any messages if you start your KDE first without Beryl, then launch a terminal and start
Code:
beryl-manager
from there? Any (error or warning) output could be of help. Also your /var/log/Xorg.0.log might contain something interesting about the crash if it has something to do with X and not just KDE.
 
Old 02-05-2007, 02:19 PM   #8
dotancohen
Member
 
Registered: Dec 2004
Location: Haifa
Distribution: Fedora Core 4, Kubuntu
Posts: 235

Original Poster
Rep: Reputation: 32
I don't see anything, but if you can take a look maybe you'll see something:
http://dotancohen.com/Xorg.0.log

My last actions were crashing X by opening beryl-manager twice: once in KDE, and again in Gnome.

Dotan Cohen

http://what-is-what.com/what_is/web_browser.html
http://lyricslist.com/lyrics/lyrics/...st_hits_i.html
 
Old 02-05-2007, 05:18 PM   #9
Indiestory
Member
 
Registered: Aug 2006
Location: Aberdeen, Scotland
Distribution: OpenBSD
Posts: 164
Blog Entries: 1

Rep: Reputation: 30
Code:
(EE) AIGLX: Screen 0 is not DRI capable
(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
I think that might just be your error, its the only thing i can see in the log, (is it normal to use fb and vesa?)Im not sure if that is an error or a switch into xgl? dont really know what im on about though

Im setting beryl right now on debian sid, havent got this far yet though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
beryl window decorations in kde manwichmakesameal Linux - Desktop 1 01-07-2007 06:34 PM
Beryl, KDE and Sabayon 3.2 chakkerz Linux - General 1 12-19-2006 07:10 AM
NVIDIA + Debian Sid + KDE 3.5 + GLX + Beryl = RUNS GREAT ! megaprog Debian 11 12-03-2006 10:01 AM
915 resolution affecting windows xp mnk123 Linux - Laptop and Netbook 1 09-24-2006 02:56 PM
chmod and chown affecting whole directories linuxmandrake Linux - Newbie 1 10-08-2005 08:04 PM


All times are GMT -5. The time now is 06:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration