LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2007, 11:39 PM   #1
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Rep: Reputation: 15
beryl missing lib


Hi, i have bin trying to install beryl on my hp zd7000 laptop running slackware 11. I think i have everything installed but when i try to start x xauth complains about some librarys missing(libXau.so.6 and libX11.so.6). when i do locate for the libs they are there, i just dont know how to make x find them (I assume thats teh issue). I have a feeling that this is a simple fix having to do with a path i dont know about.

anyway, all help is appreciated.
thank you
 
Old 05-18-2007, 12:44 AM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,899

Rep: Reputation: 68
1. Are the paths to the libraries mentioned in /etc/ld.so.conf ? If not - add them and run ldconfig .
2. Aren't you using 64-bit distribution version while trying to install something 32-bit without some 32-bit libraries installed?

Try 'file <path>/libXau.so.6' (or what the real not-symlink filename is). Try the same with xauth. Maybe they differ in 32/64 respect. If so, you will need to install 32-bit libraries, I don't know how they are called in slackware.
 
Old 05-18-2007, 01:44 AM   #3
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Original Poster
Rep: Reputation: 15
64bit? i dont believe i am using any 64 bit software... then again i have bin wrong before.

id.so.conf was the ticket, thank you for your help.

thing is now that i have x started i cant seem to start beryl-manager, it locks everything up, when i try beryl-settings or beryl setting s simple it says theres no module for berylsettings. when i try locate, it finds berylsettings .a .so and .la, do i just need to add this path to the same file as before(id.so.conf)?
 
Old 05-18-2007, 01:49 AM   #4
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,899

Rep: Reputation: 68
I think yes. Frankly, adding directories writable only by root to the end of ld.so.conf list rarely breaks anything that works.
 
Old 05-18-2007, 01:58 AM   #5
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Original Poster
Rep: Reputation: 15
that dosent seem to have done the trick, i am still getting the same error.
 
Old 05-18-2007, 06:10 AM   #6
lurko
Member
 
Registered: Jun 2006
Location: Ontario, Canada
Distribution: Debian
Posts: 448

Rep: Reputation: 35
I can't offer a solution to this problem, but I will suggest forgetting about Beryl as it's essentially a dead project now - not worth troubleshooting at this point imho. If you must try it right now, I'd grab Compiz 0.5.0 instead, and the extras package linked in this Compiz ML post also, for the ported Beryl plugins/additions that were in working order when that tarball was whipped up.

Alternatively, you can grab the current git version of Compiz, and the current 'CompComm' progress(though I'm not sure how easy the latter will be, I think the various plugins are still a bit scattered around - there are some handy scripts for grabbing/building on their site I believe, but maybe they're on the mailing list, dunno) - I've read that there are some recent improvements and the current work-in-progress is running better than 0.5.0 (or at least it's got new stuff/enhancements and it's not horribly unstable).

The other alternative is to wait a while longer (months? hopefully not many) for the next actual release of Compiz that will feature 'Compiz Community' plugins/etc.

Everything is up in the air at the moment with these projects, but there ought to be some visible merge results soon enough.

edit
sorry for not actually helping with your issue - the Beryl forum at http://www.opencompositing.org/ might have some insight for you. Or rather the Beryl junkies there might.

Last edited by lurko; 05-18-2007 at 06:14 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Beryl 0.2.0 and missing title bars avallach Linux - Software 6 03-20-2007 10:44 AM
Installed beryl, but get an error message; ' glx_ext_texture_from_pixmap' is missing sleekmason Linux - Software 3 02-14-2007 02:26 AM
Missing lib satimis Fedora 19 08-28-2006 04:52 PM
Missing lib files! stonehurstX11 Mandriva 9 12-15-2003 05:09 PM
Missing lib mikedh Linux - General 2 04-25-2001 11:06 AM


All times are GMT -5. The time now is 06:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration