LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-16-2007, 05:04 AM   #1
mykaitch
Member
 
Registered: Feb 2007
Posts: 30

Rep: Reputation: 15
Be gentle, its my first time


Ok. After a long struggle that involved putting my GeForce6600 in the dustbin and fitting my old ATI ragepro I have a console I can see and I am running Debian Etch. So now what ?
First I see there is no C compiler, I'll leave that for now.
There must be a file somewhere that is some kind of boot script. If I could edit that I could tell it I have an ATI card and then maybe X would run ?
Where, god how I have searched, is the install log ?
Where is the boot file/script whatever it is called ?
Please, I know NOTHING so please spell out what I need to do. I did a command that I got from a forum cd~<user> and I have no idea where I ended up, but its ok now.
I MUST use Linux for my next app because my final target is a Sony PS3, running Linux so I have no choice - and anyway, what a great skill to learn. HELP
 
Old 02-16-2007, 05:10 AM   #2
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
what happens when you run this command:
Code:
startx
PS: it wouldn't be a bad idea to start with Ubuntu instead of pure Debian...

Last edited by win32sux; 02-16-2007 at 05:11 AM.
 
Old 02-16-2007, 05:19 AM   #3
mykaitch
Member
 
Registered: Feb 2007
Posts: 30

Original Poster
Rep: Reputation: 15
startx

I get a shed load of info telling me Fatal Server Error: no screens found. What I know is that at boot 'something' expects an NIVDIA card which never worked anyway, so I think I have to somehow rebulid something so that it can use the ATI card. I know that one day I will be able to go back to the GeForce but thats not an issue right now.
 
Old 02-16-2007, 05:22 AM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
OK--we'll be gentle

First, you need to give us details: e.g. what are the hardware specs--does that ragepro have a part #, etc.

Second, it's better to tackle one problem at a time (and put that in the thread title). Let's go with the video driver.

Did the installer detect your card? What options were you given

All the configuration files, startup scripts, etc. are in /etc. For the video setup, you need "xorg.conf". The full path is probably /etc/X11/xorg.conf. For info on the content of this file, type "man xorg.conf"

Look for 3 sections in xorg.conf:
Screen lists the monitor and device to be used
Monitor give details on the monitor
Device gives details on the video card

In the device section, the name of the driver should probably be either ati or radeon.

So---give us the hardware details, what you find in xorg.conf, and also go to the ATI website and see what they say about a Linux driver for your card.

Have faith.......and patience!!
 
Old 02-16-2007, 05:38 AM   #5
mykaitch
Member
 
Registered: Feb 2007
Posts: 30

Original Poster
Rep: Reputation: 15
no x server

Some progress. You will find I am a tryer!
I have found the log files etc by reading that 'shed load of info'.
I used vi to read the log and I can see that the only card it wants to install is the one I removed, the GeForce6600. I had to bin it because the video was all scrambled as if there was a video ram fault (there isnt, fine withy that other OS).
So, it would be nice to get X running with the ATI rage pro.
Wow! This Forum realy does help. I have the file you asked for, used vi to view it ( no such thing as print or type in Linux then?), and it says the device is nVidiai.......GeGForce 6600
Driver "nv",
Generic Monitor

Must walk then run, but I need to change this for ATI yes?
 
Old 02-16-2007, 05:44 AM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
ATI website
Find out the driver for your card (probably "ati" or "radeon")
Search your machine to see if the driver is already there:
find /lib/modules -name "radeon*" (or ati)

edit xorg.conf to specify the correct driver

BTW, you need to erase some of that Windows/DOS knowledge. Linux is different.
 
Old 02-16-2007, 05:48 AM   #7
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
also, keep in mind that debian lets you re-configure X (as root) with:
Code:
dpkg-reconfigure xserver-xfree86
Code:
dpkg-reconfigure xserver-xorg
depending on whether you have xfree86 or xorg...

Last edited by win32sux; 02-16-2007 at 05:51 AM.
 
Old 02-16-2007, 06:11 AM   #8
mykaitch
Member
 
Registered: Feb 2007
Posts: 30

Original Poster
Rep: Reputation: 15
x server neebie

keep in mind that debian lets you re-configure X (as root) with:
Code:
dpkg-reconfigure xserver-xfree86
Code:
dpkg-reconfigure xserver-xorg
depending on whether you have xfree86 or xorg...[/QUOTE]

OK. I understand what this does. I dont understand why ? How does this help ? I am a neebie - I am chuffed that I have just found the log and config files, yesterday I was over the moon that I had a console. But, still big thanks for help cos I am nearly there I think.
 
Old 02-16-2007, 06:33 AM   #9
mykaitch
Member
 
Registered: Feb 2007
Posts: 30

Original Poster
Rep: Reputation: 15
no x server

Ok guys, so far you have been brillisnt, nearly done now.
I have a 3D Rage II+ PCI and it seems that there are no Linux drivers for this.
In /lib/modules there is nothing.

If I put the GeForce6600 back in I get no video etc so no console.I did get the Linux driver for this card so if you guys could walk me through the driver install then I could swap the cards back and it should all work ?
 
Old 02-16-2007, 06:49 AM   #10
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
Quote:
Originally Posted by mykaitch
OK. I understand what this does. I dont understand why ? How does this help ?
it gives you the option of specifiying the right driver and stuff for your card...

Quote:
Originally Posted by mykaitch
I have a 3D Rage II+ PCI and it seems that there are no Linux drivers for this.
that would be weird... when you do the dpkg-reconfigure you should get an option for a generic ati 2D driver...

Quote:
If I put the GeForce6600 back in I get no video etc so no console.I did get the Linux driver for this card so if you guys could walk me through the driver install then I could swap the cards back and it should all work ?
well if you downloaded the driver from nvidia.com it's just a matter of executing the file like:
Code:
chmod +x NVIDIA-Linux-x86-1.0-9746-pkg1.run

./NVIDIA-Linux-x86-1.0-9746-pkg1.run
but it should work in 2D even without those drivers (using the free "nv" one)...

you're likely to get more help if you post your xorg.conf along with the logfile...

Last edited by win32sux; 02-16-2007 at 07:21 AM.
 
Old 02-16-2007, 08:03 AM   #11
mykaitch
Member
 
Registered: Feb 2007
Posts: 30

Original Poster
Rep: Reputation: 15
xserver

You guys are the best!!!
I now have xserver with my ATI card.
I told you I was new. When I saw that code I did not understand what is was for so I ignored it. Well, I just logged on as root, typed it in, followed what happened on screen and now I have a desktop. As a point of interest, at one stage there is a sort of black and white dot background and when that is visible there is lots of flicker ( a bit like noise on video), but the actual desktop is fine !!!
The beers are on me guys. BIG thanks. Now is time to learn from a book like my friend Manuel.

BTW IF...you run knoppix with GeForce6600 you will observe that the mouse seems to work but there is no pointer. To fix this type
'knoppix xmodule=vesa' at the boot prompt. Hope that helps somebody.

One day I will install that 6600 card againm but not yet.
Once my PSŁ arrives I can have fun porting Linux to it but for now, again, THANKYOU ALL.
 
Old 02-16-2007, 10:48 AM   #12
kwidner
LQ Newbie
 
Registered: Feb 2007
Distribution: SuSE 10.2
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by mykaitch
I have the file you asked for, used vi to view it ( no such thing as print or type in Linux then?)
If you are looking for something like "type" the equivalent would be "cat" in Linux.
vi also has a read only mode, 'vi -R filename' or an easier way - 'view filename'.

If you want to send something straight to the printer use 'lpr filename' or 'lpr -P printerName filename'

-Kevin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where does RH8 daily set system time to hardware clock time smartnorman Red Hat 1 05-24-2006 03:42 PM
FC5 light blue stripes all over the desktop from time to time SofNine Fedora 8 05-10-2006 09:48 PM
Doub about `net time set` and daylight saving time Thakowbbery Linux - Software 0 10-17-2005 06:23 AM
The obligatory "New user here, please be gentle" Post ;o) othan1 LinuxQuestions.org Member Intro 2 09-10-2004 03:00 AM
no signal when starting xorg for the 1st time (but the second time works fine) bungalowbill Linux - Software 0 06-04-2004 10:56 AM


All times are GMT -5. The time now is 05:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration