LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-15-2008, 08:45 PM   #1
Rotwang
Member
 
Registered: Jan 2004
Distribution: CentOS
Posts: 281

Rep: Reputation: 30
Basic partitioning question about ext3


So here's how I partitioned my disk, is this ok?

Device Boot Start End Blocks Id System
/dev/sdb1 1 25 200781 83 Linux
/dev/sdb2 26 2458 19543072+ 83 Linux
/dev/sdb3 2459 17048 117194175 83 Linux
/dev/sdb4 17049 36483 156111637+ 5 Extended
/dev/sdb5 17049 36483 156111606 83 Linux

None of the partitions are formatted, and the tutorial I read on formatting drives says to then press "t" in fdisk and tell it which filesystem I want. So I chose "85", which is ext3 ("Linux Extended" is ext3 right??).

Command (m for help): t
Partition number (1-5): 3
Hex code (type L to list codes): 85
You cannot change a partition into an extended one or vice versa
Delete it first.

What am I doing wrong here?

I also tried formating that parition with:

/sbin/mkfs -t ext3 /dev/sdb3

And then in /etc/fstab I have:

/dev/sdb3 /mnt/300.120 ext2 user,rw,exec,auto,umask=0 0 0

But when I tried to mount it, it said:

# mount /mnt/120meg/
mount: wrong fs type, bad option, bad superblock on /dev/sdb3,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Let me know if you want me to do the dmesg thing, I have a feeling you're already seeing something I'm doing wrong here..

thanks
 
Old 11-15-2008, 09:08 PM   #2
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Looks like 85 is an extended partition (ie, a container for logical partitions). Leave it as 83 and format it to what you want.

You may be better using a graphical partitioner like gparted (you can download a live CD which is really useful)
 
Old 11-15-2008, 09:14 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,650

Rep: Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092
Quote:
Originally Posted by Rotwang View Post
None of the partitions are formatted, and the tutorial I read on formatting drives says to then press "t" in fdisk and tell it which filesystem I want. So I chose "85", which is ext3 ("Linux Extended" is ext3 right??).
The tutorial (for fdisk presumably) is wrong. Don't confuse partitions with filesystems. You certainly don't want to make that partition x'85' - all Linux partitions should be type x'83' except the swap which generally ought to be x'82'.
Then just mkfs on whichever to make (format) a filesystem on that partition.
 
Old 11-15-2008, 09:23 PM   #4
Rotwang
Member
 
Registered: Jan 2004
Distribution: CentOS
Posts: 281

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by syg00 View Post
The tutorial (for fdisk presumably) is wrong. Don't confuse partitions with filesystems. You certainly don't want to make that partition x'85' - all Linux partitions should be type x'83' except the swap which generally ought to be x'82'.
Then just mkfs on whichever to make (format) a filesystem on that partition.

Thanks but, wait, in that case, then why didn't my mkfs work? I still can't mount.

Is me fstab line wrong maybe?
 
Old 11-15-2008, 09:26 PM   #5
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You need to make that partition type 83 again first. Then mkfs
 
Old 11-15-2008, 09:26 PM   #6
Rotwang
Member
 
Registered: Jan 2004
Distribution: CentOS
Posts: 281

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by billymayday View Post
You may be better using a graphical partitioner like gparted (you can download a live CD which is really useful)
I tried that first, actually, but I had this problem:

http://lists.freshrpms.net/pipermail...ry/012060.html

I got gparted to start using /usr/sbin/gparted &, but in the context menu for Format to-> all the options are disabled, greyed out.

So I went to fdisk instead.
 
Old 11-15-2008, 09:26 PM   #7
Rotwang
Member
 
Registered: Jan 2004
Distribution: CentOS
Posts: 281

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by billymayday View Post
You need to make that partition type 83 again first. Then mkfs
Just tried that, didn't help. Same error when mounting.

# dmesg | tail
SCSI device sdb: 586114704 512-byte hdwr sectors (300091 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
sdb: sdb1 sdb2 sdb3 sdb4 < sdb5 >
SCSI device sdb: 586114704 512-byte hdwr sectors (300091 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
sdb: sdb1 sdb2 sdb3 sdb4 < sdb5 >
 
Old 11-15-2008, 09:30 PM   #8
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
You created an ext3 file system on /dev/sda3 ... then you told mount that is was an ext2 file system.

You should change your fstab entry to ext3
 
Old 11-15-2008, 09:33 PM   #9
Rotwang
Member
 
Registered: Jan 2004
Distribution: CentOS
Posts: 281

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by dxqcanada View Post
You created an ext3 file system on /dev/sda3 ... then you told mount that is was an ext2 file system.

You should change your fstab entry to ext3
Sorry that was one of my fix attempts. I just tried ext3, same error when mounting:

/dev/sdb3 /mnt/300.120 ext3 user,rw,exec,auto,umask=0 0 0

Btw I know this drive is physically OK, because what I was doing here was wiping it, to partition it differently...
 
Old 11-15-2008, 09:33 PM   #10
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You should be able to mount ext3 as 2 (it ignores journaling).

Try a manual mount

mount /dev/sdb3 /mnt/300.120
 
Old 11-15-2008, 09:34 PM   #11
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,650

Rep: Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092Reputation: 2092
Are you getting any messages back from mkfs ?. If not, it ain't happening - try it as root.
 
Old 11-15-2008, 09:39 PM   #12
Rotwang
Member
 
Registered: Jan 2004
Distribution: CentOS
Posts: 281

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by billymayday View Post
You should be able to mount ext3 as 2 (it ignores journaling).

Try a manual mount
Worked, woo!! thanks billymayday

Now what's wrong with my fstab line, hmm...
 
Old 11-15-2008, 09:46 PM   #13
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I don't think I've ever used umask in a mount, but does it need 3 octal digits?
 
Old 11-15-2008, 09:48 PM   #14
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Actually, looking at man mount, does ext3 allow umask on mount? Doesn't seem to.
 
Old 11-15-2008, 09:52 PM   #15
Rotwang
Member
 
Registered: Jan 2004
Distribution: CentOS
Posts: 281

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by billymayday View Post
Actually, looking at man mount, does ext3 allow umask on mount? Doesn't seem to.
You were right, I took out the umask and it worked,

/dev/sdb3 /mnt/300.120 ext3 user,rw,exec,auto 0 0

thanks again billymayday
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shrinking HD Capacity when Partitioning with debian CD installer (Basic Install) zakidad Debian 0 08-08-2006 09:17 AM
Basic questions about partitioning and multiple OSs okok Linux - Newbie 5 04-24-2006 08:31 AM
Ext3 & tune2fs tweaking question for ext3 experts wrc1944 Linux - General 8 12-11-2005 07:45 AM
PARTITIONING an existing ext3 / Running two Redhat distributions addisono Linux - Software 1 10-24-2005 05:48 PM
very basic question Louisa Linux - Newbie 4 08-31-2003 02:05 PM


All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration