LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-21-2010, 04:49 PM   #1
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Rep: Reputation: 3
.bashrc ubuntu Eee easy peasy the specifics of an alias?


I successfully edited the .bashrc file to get ruby version manager (rvm) working. Now I would like to turn that setting into an alias so that if i type the word 'ruby' into the terminal it not only goes to the rvm settup but also defaults to my webdev folder which is in my user home directory and also exicutes a command that will open up gedit ready to be used as the text editor for editing the .rb files. Can this be done i would settle for some added code for the 'if then' statement: so far it looks like this:

if [[ -n "$PS1" ]]; then
HISTCONTROL=ignoredups:ignorespace
fi
[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"

origanally it looked like this:

[ -z "$PS1" ] && return
HISTCONTROL=ignoredups:ignorespace

Its at the top of the .bashrc file after the opening #comments
What i need is for when i click on the terminal icon i can put one word in which is 'ruby' and a session will open up to use 'rvm' right inside my 'webdev' folder. Is this possivble? and if so how too?

by the looks of what is in the manual i can make an alias to cause the session to transfer to the folder which i normally have to do by putting in 'cd /home/gregory/webdev/tutes'; and should be able to put in an alias to do this by typing in ruby or rb, but can an alias be set up in the .bashrc file; that leaves things as is in the default setup in ubuntu easy peasy; unless I type in ruuby or rb into the terminal when it starts up. This netbook is used for making an experimental setup for a production webdevelopment system so defaulting to a 'rvm' session inside the 'webdev' directory is quite ok. If it is best to just do that well that is what i will do. So what do i put there?

alias -p rb=cd /home/gregory/webdev/tutes

is that the right way to use alias in the .bashrc file? and if so is this the only thing i need to add there? My code would then read:

if [[ -n "$PS1" ]]; then
HISTCONTROL=ignoredups:ignorespace
fi
[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"
alias -p rb=cd /home/gregory/webdev/tutes

I don't want to mess with the default setup on this system too much and think things could get out of hand if i am not careful. So am cautious about doing anything at this stage. I wonder if it is possibel thought to setup that whole 'if then' statement as an 'alias'. I read a few referances to alias and looked in the manual like any good newby should but am needing your help please. getting out of the MSwindows mind set and into the linux logic is not so easy but is a great experience (free at last!!!). Thanks for your help.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 10-21-2010, 05:17 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Code:
alias ruby='sh something; cd somewhere; gedit'
 
Old 10-21-2010, 06:11 PM   #3
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
thanks Tinkster
I tried this

alias rb='sh [[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"; cd /home/gregory/webdev/tutes; gedit'

and got this (though gedit did initiate and opened up ready to use). There was no acknowledgement that i was in the desired folder and directory however. What's the problem(s) here? this is what i see in the terminal after entering the alias rb.

gregory@gregory-laptop:~$ rb
sh: Can't open [[

I tried things like taking away the square brackets, taking away the sh and also taking away both the [[ and the sh. but none of these work so far.
 
Old 10-21-2010, 10:36 PM   #4
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
I resolved this but not the way i thought it should work
alias only seems to take one object per alias and also gedit stops bash from functioning properly without closing it down so am looking to create a shortcut key combination to open it.

I resloved it by making some aliases that navigate me to the files in the webdev directory i set up in my home directory.

alias pp='cd /home/gregory/webdev' #ls gets me a list of all folders and files inside of it

alias pp0='cd /home/gregory/webdev/hydrasite-pp0'
alias pp1='cd /home/gregory/webdev/plzzasite-pp1'
alias pp2='cd /home/gregory/webdev/tropicExp-pp2'
etc.......

this way i can do get to the webdev directory easily with 'pp'
then do 'ls' and get a list with the shortcuts to any project sites i am working on
it means if i forget the shortcut key to any project i want to do some work on its right there in the list with the name of the site its like an extension to the name.

Once i set up the aliases it's easy
1. ctrl-alt-t (hit enter) # and there is the terminal open onscreen
2. pp [typed into the terminal(hit enter)] # navigates to webdev directory
3. ls [typed into the terminal(hit enter)] # gives me a list of all my web projects
4. pp0 or pp1 etc [typed into the terminal(hit enter)] # I'm inside any directory chosenfrom that list.

If anyone needs to know how to get to edit the bashrc. file then in a terminal just type in 'sudo gedit .bashrc' and it should come up into your screen in the text editing app ready for you to edit it. Gedit may not be on all linux systems but it is the default on the gnome desktop and has a wide range of functionality with loads and loads of pluggins. Any systems that don't have it will have vi or another one so just change the middle of the 3 words in the command to vi or emacs or whatever should do it but don't really know as have not had the experience with them yet and find gedit an awsome tool for any scripting or test editing jobs.
 
Old 10-22-2010, 11:34 AM   #5
sag47
Senior Member
 
Registered: Sep 2009
Location: Orange County, CA
Distribution: Kubuntu x64, Raspbian, CentOS
Posts: 1,845
Blog Entries: 36

Rep: Reputation: 453Reputation: 453Reputation: 453Reputation: 453Reputation: 453
Quote:
Originally Posted by cre84j View Post
I resolved this but not the way i thought it should work
alias only seems to take one object per alias and also gedit stops bash from functioning properly without closing it down so am looking to create a shortcut key combination to open it.
That doesn't sound right. On my easypeasy eeepc900 I have the following alias....
Code:
alias clean='echo -n "Really clean this directory?";
        ready yorn;
        if test "$yorn" = "y"; then
            rm -f \#* *~ .*~ *.bak .*.bak *.tmp .*.tmp core a.out;
            echo "Cleaned.";
        else
            echo "Not cleaned.";
        fi'
I have many aliases like that incorporating for loops for compressing Firefox's SQLLite3 databases and the list goes on. I actually think it's the ssh command which may be creating the stick in your side on that alias. I don't know much about ruby but I may be able to figure something else out. Over the next couple of days I'll check out the command.

Can you type in sequence in code tags the exact command you want alias to do. E.g.
Code:
command 1
command 2
command 3
This will make it easier for me to figure out what we can do. If it comes down to it you can also create a shell script and alias that. Also you should put your custom aliases in .bash_aliases because .bashrc references it by default (unless you edited .bashrc and removed that part of the script).

Last edited by sag47; 10-22-2010 at 11:41 AM.
 
Old 10-23-2010, 09:51 PM   #6
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
thanks for that reply
Sag47

I worked on a workaround after not being able to set up a complex alias script and without the knowhow it was difficult to make progress. All i could do in the end was make some shortcuts to my directories be which are beyond my home directory further down the tree. they work fine and speed things up a great deal. I also found how too create the shortcuts to intialise the various app's i use such as gedit and also firefox tomboy and Scite so everything is quick and don't have to do endless mouse clicks to start get my workspace set up now. The thing is I need to be able to know how to make more complex aliases.

I really apreciate your suggestion here and have something to think about but not understanding exactly what you mean about those commands

ruby works through the bash terminal. the way i set it up in the bashrc file opens up a ruby session in the terminal when i initiate the terminal app. It's like an extentsion to bash and all the bash commands are there to be used or so it seems.

this is what is in .bashrc emediately after the opening comments

if [[ -n "$PS1" ]]; then
HISTCONTROL=ignoredups:ignorespace
fi
[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" # This loads RVM into shell
alias oo='cd /home/gregory/webdev/tutes'
alias pp='cd /home/gregory/webdev'
alias jj='cd /home/gregory/webdev/snippets
alias pp0='cd /home/gregory/webdev/newproj-pp0'
alias pp1='cd /home/gregory/webdev/nextproj-pp1'
alias kk='cd ~'

the rest of the file i left how it was and got the if statement from the ruby version manager site and also the load command for rvm shell session on the end of it.

I tried converting the other suggested alias snippets that were given here but nothing worked with my level of knowhow except when i used one object per alias. So came to the conclusion that it must be because aliases are limited to one small task per alias. I used gconf-editor for the shortcut key setups for each app i need by default each day and got them working well. Also with the aliases it's easy to get into whatever file i need to get to to do an 'ls' and be able to see all the files in it to get them into whatever IDE or text editor i am using. My thought's were before started that i should be able to set things up or open up a session in ruby or rvm via an alias command rather than defaulting to always be in a ruby session. And also thought that the other suggestion given by Tinkster of

alias ruby='sh something; cd somewhere; gedit'

there are 3 objects in this but after trying to make something of a command out of it only gedit initiated anything and it put the bash curser into no mans land and stopped bash from finctioning untill i closed down gedit again and found it was best to set all those sort of shortcuts to app's up via gconf-editor. The workaround i ended up with is really good it works well but still need to know a lot more about configuring systems so any more on this would be a great help.
 
Old 10-23-2010, 11:36 PM   #7
sag47
Senior Member
 
Registered: Sep 2009
Location: Orange County, CA
Distribution: Kubuntu x64, Raspbian, CentOS
Posts: 1,845
Blog Entries: 36

Rep: Reputation: 453Reputation: 453Reputation: 453Reputation: 453Reputation: 453
Hmmm...
Try this alias... it should work if this works in your .bashrc.
Code:
alias ruby='if [[ -n "$PS1" ]]; then
HISTCONTROL=ignoredups:ignorespace
fi
[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"'
Exactly like that. Type ruby to execute it.

As for gedit not allowing you to use your bash terminal you should look up bash process control. You can start gedit in the background.
Code:
gedit &
and still be able to use that terminal.

Also if you run
Code:
gedit
And then press Ctrl+Z it will pause gedit in your jobs. Then you can run
Code:
jobs #there should only be 1 but I'm showing you this for learning sake
bg 1
Gedit should now continue in the background and you can use your terminal again.

The commands associated with process control which would most interest you would be: ps, kill, jobs, bg, fg. Reading the man pages will clarify them but I gave you some small examples for starters.

That's all I can say for now because I've gotta be underwater tomorrow. Ask more and I'll tell more if you're interested in learning further. Google always helps.
 
Old 10-24-2010, 03:40 AM   #8
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
sag47 I have great news but it happened through me making a mistake and not (#) commenting out a line of code in the .bashrc file when i put that alias you gave me to try into the scritp.

alias ruby='if [[ -n "$PS1" ]]; then
HISTCONTROL=ignoredups:ignorespace
fi
[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"'

something was amiss and got an exception i looked back and saw that i had missed a comment (#) sign in the bash script in the code i left there in case it did not work and had to try a few things. Well it seemed to make more sense to leave the 'if' statement there seperate and only make the '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"' into an alias so did that and noticed what i missed in the comment or lack there of. Well when i fixed it suddenly things worked in the ruby app that did not before 'interactive ruby shell (irb)' is now working when it was not before as something was blocking it (its set up system wide so is not in with the 'ruby version manager' app) Now i have set up an alias like this:

alias ruby='[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"'

and it seems to have fixed the problem with irb not working or at least not with the line numbers (it's only really for testing snippets of code and functions etc). the way it works with the numbering is a real key because if you make a mistake the exception is given with a discription and comment and the line number so now that the app readline is working properly its a big plus. And all through a mistake in my coding; well thats the real cool part it happened by accident and trying something and well wouldn't have tried it without your suggestion so thanks. Incidentally the line numbering in irb was the next thing i had to get fixed and now it is done and I have the ability to turn ruby on and off. That alias

alias ruby='[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"'

it works and turns the session into a ruby shell session when i type in ruby and hit enter. I have one more thing to get right but should not be too hard now. Thanks again that was a great help and am going to look into those referances you gave me about process control. have a great time under water and all the best for the rest of weekend.
 
Old 10-24-2010, 05:01 AM   #9
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
Sag47
hope your still around because the original problem still exists: Not with the alias or lack of it. It's some weird anomally going on and now this has highlighted it. This is what happens without the alias: alias ruby='[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"'

gregory@gregory-laptop:~$ irb
Readline was unable to be required, if you need completion or history install readline then reinstall the ruby.
You may follow 'rvm notes' for dependencies and/or read the docs page http://rvm.beginrescueend.com/packages/readline/ . Be sure you 'rvm remove X ; rvm install X' to re-compile your ruby with readline support after obtaining the readline libraries.
ruby-1.8.6-p399 > ^R
gregory@gregory-laptop:~$ pp
gregory@gregory-laptop:~/webdev$ ruby tester.rb
Payday in 5 days.
gregory@gregory-laptop:~/webdev$ rvm | head -nl
head: l: invalid number of lines
gregory@gregory-laptop:~/webdev$


And this is what happens with it

gregory@gregory-laptop:~$ irb
irb(main):001:0> gregory@gregory-laptop:~$
gregory@gregory-laptop:~$ rvm list
No command 'rvm' found, but there are 19 similar ones
rvm: command not found
gregory@gregory-laptop:~$ ruby
gregory@gregory-laptop:~$ rvm list

rvm rubies

ruby-1.9.2-p0 [ i386 ]
ruby-1.8.6-p399 [ i386 ]
jruby-1.9.2-head [ linux-i386-java ]
ruby-1.9.1-p378 [ i386 ]

gregory@gregory-laptop:~$ rvm list default

Default Ruby (for new shells)

ruby-1.8.6-p399 [ i386 ]

gregory@gregory-laptop:~$ rvm | head -n1

gregory@gregory-laptop:~$ pp
gregory@gregory-laptop:~/webdev$ ruby tester.rb
gregory@gregory-laptop:~/webdev$

it may be a bit complicated
to see but basically irb works with both but without the line numbers in the first one which is with '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" as a normal line of code and not as an alias. The problem with this first one is that ruby does work but the test for it working: 'rvm | head -nl' does not.
In the second case and that is with it as an alias and not as a plain line of code it starts a ruby session but does not work although the ruby version manager does work and shows everything that is supposed to show except when it comes to using the ruby interpreter itself. Ruby doesn't work but when the bashrc is coded right but it does when it is coded wrong or that is the way it seems and in both cases irb works which makes things really weird because it works without the line numbers in one case but ruby doesn't work at all when it does work with the line numbers.

I think I may only get the answer to this at the #rvm channel at github. Well its an interesting journey. I haven't fixed the main problem yet but at least it is more obvious what the main problem is now. It seems to be in the setup of the package or configuration setup on the system outside of the .bashrc. Well i can't be 100% sure of that but it is starting to look that way. And it could be a bit of both and is likely the rvm itself that is causing the problem.
 
Old 10-24-2010, 06:46 PM   #10
sag47
Senior Member
 
Registered: Sep 2009
Location: Orange County, CA
Distribution: Kubuntu x64, Raspbian, CentOS
Posts: 1,845
Blog Entries: 36

Rep: Reputation: 453Reputation: 453Reputation: 453Reputation: 453Reputation: 453
Quote:
Originally Posted by cre84j View Post
Sag47
hope your still around because the original problem still exists: Not with the alias or lack of it. It's some weird anomally going on and now this has highlighted it. This is what happens without the alias: alias ruby='[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"'

gregory@gregory-laptop:~$ irb
Readline was unable to be required, if you need completion or history install readline then reinstall the ruby.
You may follow 'rvm notes' for dependencies and/or read the docs page http://rvm.beginrescueend.com/packages/readline/ . Be sure you 'rvm remove X ; rvm install X' to re-compile your ruby with readline support after obtaining the readline libraries.
ruby-1.8.6-p399 > ^R
gregory@gregory-laptop:~$ pp
gregory@gregory-laptop:~/webdev$ ruby tester.rb
Payday in 5 days.
gregory@gregory-laptop:~/webdev$ rvm | head -nl
head: l: invalid number of lines
gregory@gregory-laptop:~/webdev$
First
Please format your post so that I don't have to think too hard when looking at a large post. Please put console code and error output within code tags, quotes in quote tags, and any other formatting which would enable me to more quickly decipher your problem so that I (or any LQ member) can respond appropriately. You can see all these formatting options by clicking "Go Advanced" when creating a post.

Second
l (as in lower case L) is not part of the head command. Man head. You probably want to test the first line of output which would be...
Code:
rvm | head -n1
If you're having a hard time differentiating 1 from l (lower case L) then you might want to change the font your shell uses. I'm not sure what you're trying to do here but... if you're testing to ensure rvm is loaded correctly (click here to see source link) then the command you should run is:
Code:
type rvm | head -n1
type is a command (they don't simply mean to type rvm...etc)

Third
Before we start digging into rvm any deeper please tell me if you have the prerequisites for rvm. Here, I'll give you a quick bash script which will quickly tell you if you are missing any.
Code:
#!/bin/bash
for x in bash awk sed grep which ls cp tar curl gunzip bunzip2 git subversion;do
  if [ -z "`whereis $x | cut -d: -f2`" ];then
    echo "Error: $x not found";
  fi
done
Put that in a script called prereq.sh and execute it by:
Code:
chmod 755 ./prereq.sh
./prereq.sh
If you do not see output from running the script then it means all of the commands exist on your system so you're good.

Also run:
Code:
bash --version
and make sure you're running bash 3.2 or greater.

Fourth
Your irb command lists a solution to resolve the readline dependency to fix it.
http://rvm.beginrescueend.com/packages/readline/

Have you followed those steps?

I've never used ruby this is just google searching and reading. A lot of this is basic shell understanding. You may want to look up bash shell howto and maybe review the command list in the LQ wiki. If you're not sure about a command then use the man pages.

Last edited by sag47; 10-24-2010 at 07:12 PM.
 
Old 10-24-2010, 10:44 PM   #11
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
thanks again sag47

Thank you for giving your time to answer this problem sag47 you really have been a God send.

I now have it resolved though with a slight work around
this was the problem as you said:

Code:
type rvm | head -n1
once i execute it the desired outcome appears in the bash window:

Code:
gregory@gregory-laptop:~$ type rvm | head -n1
rvm is a function
the workaround is simple to execute (though i will try and load rvm up differently soon so that it is set with readline on installation of the software). This is the workaround:

Code:
<ctrl>+<alt>+t
it opens up a new terminal without the alias being used:

Code:
alias rvman0='[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"'
and so irb works with the line numbers:

Code:
gregory@gregory-laptop:~$ irb
irb(main):001:0>
but in another session so i can still keep working with ruby and the version manager in the other terminal.

The main problem with ruby is that in it's design strategy it is carefully geared for the long term user and so newbies run into difficulties because it is also developed very fast with significant changes from version to version. Hence the need for a version manager because many of the tutes or most or almost all are made for older versions like 1.8.4: the big problem though is that 1.8.4 is now obsolete so no one can get it now even with the version manager. I have 3 really good books one is exceptionally well written to teach coding for newbies including regex usage but unable to get past ch6 + 7 without more knowledge and experience.

thanks again this is resolved now and got confidence that linux works and is usable even with difficult issues and problems to work through.
 
2 members found this post helpful.
Old 10-25-2010, 05:59 PM   #12
sag47
Senior Member
 
Registered: Sep 2009
Location: Orange County, CA
Distribution: Kubuntu x64, Raspbian, CentOS
Posts: 1,845
Blog Entries: 36

Rep: Reputation: 453Reputation: 453Reputation: 453Reputation: 453Reputation: 453
I'm sure once you learn the syntax of the ruby language it will be similar across all ruby versions. The only thing which will probably change across versions is the API documentation.

For that I just found a site which lists comprehensive API documentation across all versions of ruby.

http://ruby-doc.org/

I would use that as your main page for learning ruby.
 
1 members found this post helpful.
Old 10-27-2010, 06:20 AM   #13
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
Outcome summery in the pipeline

Hi sag47 and anyone viewing this thread
i thought it would be a good idea to write some a clear post here of my exact outcome with this problem and how i resolved it but first want to get it clear and have something really special happening now through a short script and 2 aliases which combine to launch any type of file into their default application and all I need to do is type this into the terminal and hit enter:

Code:
lau nch hat.gif &
this would bring it right up into a graphics app like gimp

and providing i am in the directory where the file is it will launch the file right into the application. ready to be edited or whatever needs to be done. I owe a large debt to sag47 for taking the time to help me along here so thought the best way to do that would be to pass on what i have learned here. first thought want to get it clear and concise.

the 'lau' part of the command calls the script application file which can be in any directory in the user path (and has the script that matches the file with the application). The 'nch' part of the command has the path to the file and the rest is a the file itself 'hat.gif' and the ampersand or whatever it is & which makes sure the bash is freed up and the application with the file in it is running in the background. I hope to get it all together and do this within the next few days.
 
Old 10-31-2010, 10:55 PM   #14
cre84j
Member
 
Registered: Oct 2010
Posts: 40

Original Poster
Rep: Reputation: 3
Well i said i would put the outcome of my resolve of the original problem here in a few days but the scrip i am working on needs a multidimensional array for it to be able to launch any file type that is targeted into its matching application. I have it working with a small number of files one file per application but for it to work with multiple file extensions to each application like for the office suite word processor there is 6 different formats that i am likely to use in it and maybe 7 or with gimp 20 or so. Well i need to get it working with multidimensional arrays for it to be worth a mention here so will find the answer to this before posting a complete resolve as soon as possble though i have worked on scripts in a new language before for 2 weeks or more so it may not be for a while but here's hoping.

all the best with your search: the Linux Format magazine special edition is worth a look if you are new to Linux and really want to extend yourself try: http://www.linuxformat.com/

It's issue twenty three that you should look for.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] .bashrc editing the rc file Eee ubuntu 9.04 easy peasy cre84j Linux - Laptop and Netbook 5 10-20-2010 01:04 AM
[SOLVED] 3D programs on EEE PC 901 under Easy Peasy seem to run with unaccelerated video 10110111 Ubuntu 2 09-14-2009 01:39 PM
LXer: Easy Peasy Linux (Ubuntu Eee) 1.5 Released LXer Syndicated Linux News 0 09-08-2009 09:10 PM
setting up an 02 3g modem with a asus eeepc running easy-peasy (ubuntu) jonbvgood Linux - Hardware 2 05-19-2009 06:05 AM
wireless issue easy peasy ubuntu remix jc_anthro Linux - Laptop and Netbook 2 05-03-2009 10:31 PM


All times are GMT -5. The time now is 03:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration