LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2014, 06:16 AM   #1
adak
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Rep: Reputation: Disabled
bash: line: 2: exec: sftp-server: not found


I am obviously a newbie.. just starting out.

I have a file (single) that I am trying to transfer from my windows machine to a virtual machine.

I have the Putty softwares (PSFTP).

How do I set up my linux machine for this?

Andy...

to date: I have two machines (one a linode personal), and another for work..
 
Old 01-23-2014, 06:25 AM   #2
lpwevers
Member
 
Registered: Apr 2005
Location: The Netherlands
Distribution: SuSE, CentOS
Posts: 121

Rep: Reputation: 20
Hi Andy,

Assuming that you have sshd setup on your Linux machine and the full PuTTY package installed, try this on you windows machine:
1. Open a command prompt
2. cd to the directory where your file is
3. "c:\Program Files (x86)\putty\pscp.exe" <yourfile> <yourname@linux:/home/yourname>

Louis
 
Old 01-23-2014, 07:12 AM   #3
adak
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
more messages

Louis..

Thanks for the reply..
I tried the action on my windows machine from a command prompt

looked like this..
Code:
C:\> "c:\Program Files\putty\pscp.exe" myFileName usrname@hostoflinuxbox: /usr/myFileName
I gt back a reply of 'More than one remote source not supported'..

Andy...
 
Old 01-23-2014, 07:36 AM   #4
lpwevers
Member
 
Registered: Apr 2005
Location: The Netherlands
Distribution: SuSE, CentOS
Posts: 121

Rep: Reputation: 20
Andy,

There should not be a space between the : and the target directory. So
Code:
C:\> "c:\Program Files\putty\pscp.exe" myFileName usrname@hostoflinuxbox:/usr/myFileName
should do the trick.

Louis

Quote:
Originally Posted by adak View Post
Louis..

Thanks for the reply..
I tried the action on my windows machine from a command prompt

looked like this..
Code:
C:\> "c:\Program Files\putty\pscp.exe" myFileName usrname@hostoflinuxbox: /usr/myFileName
I gt back a reply of 'More than one remote source not supported'..

Andy...
 
Old 01-23-2014, 08:51 AM   #5
adak
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thanks to Louis..

Well...

I got the file moved. Thanks for the help and hope things are treating you well.

Problem was
1. a stray space in my command
2. a permission problem on my destination folder.

Solution was to use the information given above and put it into the root directory of my user name..

Code:
C:>"C:\Program Files\PuTTY\pscp.exe" myfilename myusername@xx.xx.xx:
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
exec: sftp-server: not found gajananh999 Linux - Software 1 10-10-2012 07:43 AM
Bash exec: 63: id: not found when users log in into jail Carroarmato0 Linux - Server 6 08-16-2009 06:32 AM
Error while doing on-line update: no server found SuSE_Lamer SUSE / openSUSE 2 12-14-2005 03:17 AM
Files truncated by sftp/sftp-server at 65kb gato Linux - Networking 1 12-18-2003 11:29 AM


All times are GMT -5. The time now is 09:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration