LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-08-2011, 06:48 PM   #1
rach_here
LQ Newbie
 
Registered: Sep 2011
Posts: 2

Rep: Reputation: Disabled
-bash: /home/rb27/.bash_profile: Permission denied


Hi,
I have looked through the threads and tried changing permissions like some threads suggest. But the error still exists.In fact it gives me a different error every time I log in.

Could not chdir to home directory /home/rbp45: Permission denied

here is a snippet of what I get when I use the command ls -al
drwxr-xr-x 16 root root 0 Sep 8 18:28 .
drwxr-xr-x 23 root root 4096 Feb 5 2011 ..
d????????? ? ? ? ? ? ajd74
d????????? ? ? ? ? ? ban45
d????????? ? ? ? ? ? rb27

I cannot log in as root since the permission is denied
I dont know what to do ?Please help me
 
Old 09-08-2011, 06:53 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
If you can't become root then you may need to obtain console access and enter single user runlevel.
 
Old 09-08-2011, 07:00 PM   #3
rach_here
LQ Newbie
 
Registered: Sep 2011
Posts: 2

Original Poster
Rep: Reputation: Disabled
can you please guide me through how to do it
 
Old 09-08-2011, 08:25 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
Try ctrl-alt-f1 or ctrl-alt-f2.
Please tell us which distro & version you have.
 
Old 09-08-2011, 08:28 PM   #5
Karl Godt
Member
 
Registered: Mar 2010
Location: Kiel , Germany
Distribution: once:SuSE6.2,Debian3.1, aurox9.2+3,Mandrake?,DSL? then:W7st,WVHB, #!8.10.02,PUPPY4.3.1 now:Macpup
Posts: 314

Rep: Reputation: 45
normaly there is a failsafe boot option in the boot menu at larger distros . This should boot into single user-mode .

To boot manually there you need to enter the syntax of /boot/grub/menu.lst or /boot/grub/grub.cfg

like

kernel /boot/vmlinuz root=/dev/sda1 S init=/bin/bash
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 'Could not chdir to home directory /home/[user]: Permission denied' arashi256 Linux - Newbie 25 11-11-2011 10:29 AM
.bash_profile: Permission denied knockout_artist Linux - Newbie 7 10-31-2007 03:34 PM
Permission denied to execute anything under /home ErrorBound Linux - Software 8 07-26-2006 10:21 AM
permission denied to home directory ekdya Debian 3 11-08-2005 05:24 PM
moved home: permission denied mtb Linux - Software 4 12-17-2003 07:09 AM


All times are GMT -5. The time now is 02:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration