LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-02-2012, 02:56 AM   #1
nnjond
Member
 
Registered: Feb 2007
Distribution: Ubuntu 10.04
Posts: 281

Rep: Reputation: 31
Bash command needed?


Hi,

Can't shift this problem with a reboot; Any advice please?

Another application seems to be using the package system at this time. You must close all other package managers before you will be able to install or remove any packages.
 
Old 03-02-2012, 03:08 AM   #2
Nermal
Member
 
Registered: Jan 2009
Distribution: Debian
Posts: 59
Blog Entries: 2

Rep: Reputation: 6
ok, I'm guessing it's Ubuntu.

The Update checker may be running. So leave it 10 mins and try again.

Update checker I think users apt-get in the back ground so try:

Code:
ps -e | grep apt
then you could kill that off so that you can run it manually.
 
Old 03-02-2012, 03:20 AM   #3
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Apparently you are trying to update/upgrade using 'a' command / package manager application while some 'other' command / package manager application already has a lock on the package system. Find out which one using the ps command and shut it down. It would be easier to provide a more direct and complete answer if you provide more information about what exactly are you doing, and more important on what distro / version of Linux.

Kind regards,

Eric
 
Old 03-02-2012, 05:42 AM   #4
nnjond
Member
 
Registered: Feb 2007
Distribution: Ubuntu 10.04
Posts: 281

Original Poster
Rep: Reputation: 31
Thanks for your help.

Kubuntu 11.10

I'm informed of updates, but receive the above message when I try to install them.

Top returns the below, but I dont know how or what to "k"

Code:
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND  
 2259 nnjond    20   0  228m  78m  18m S 14.5  8.3   0:47.07 chromium-
 2209 nnjond    20   0  208m  75m  16m S  6.0  8.1   0:06.17 chromium-
 1160 root      20   0  114m  44m  16m S  1.3  4.8   0:51.96 Xorg     
 1987 nnjond    20   0  109m  21m  17m S  1.3  2.3   0:11.58 konsole  
 2203 nnjond    20   0  163m  34m  17m S  1.3  3.7   0:04.16 chromium-
 1454 nnjond    20   0  338m  33m  14m S  0.7  3.5   0:23.80 plasma-de
 2061 nnjond    20   0  479m  74m  26m S  0.7  7.9   0:17.25 chromium-
 2146 nnjond    20   0  145m  19m  12m S  0.7  2.1   0:00.40 chromium-
 1315 root      20   0  6320  260  184 S  0.3  0.0   0:01.01 udisks-da
 1429 nnjond    20   0  163m  11m 7012 S  0.3  1.2   0:16.86 kwin     
 1534 nnjond    39  19 45936 6852 1148 S  0.3  0.7   0:05.41 virtuoso-
 1543 nnjond    20   0 63840 2712 2304 S  0.3  0.3   0:00.25 kaccess  
 2043 nnjond    20   0  2820 1064  848 R  0.3  0.1   0:04.74 top      
 2197 nnjond    20   0  222m  85m  20m S  0.3  9.2   0:09.69 chromium-
 2215 nnjond    20   0  287m 150m  19m S  0.3 16.0   0:40.84 chromium-
    1 root      20   0  3320  764  368 S  0.0  0.1   0:00.53 init     
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.00 kthreadd 
    3 root      20   0     0    0    0 S  0.0  0.0   0:00.59 ksoftirqd
    6 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration
    7 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 cpuset   
    8 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 khelper  
    9 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 netns    
   10 root      20   0     0    0    0 S  0.0  0.0   0:00.03 sync_supe
   11 root      20   0     0    0    0 S  0.0  0.0   0:00.00 bdi-defau
   12 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 kintegrit
   13 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 kblockd  
   14 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 ata_sff  
   15 root      20   0     0    0    0 S  0.0  0.0   0:00.03 khubd    
   16 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 md       
   19 root      20   0     0    0    0 S  0.0  0.0   0:00.00 khungtask
   20 root      20   0     0    0    0 S  0.0  0.0   0:02.06 kswapd0  
   21 root      25   5     0    0    0 S  0.0  0.0   0:00.00 ksmd     
   22 root      39  19     0    0    0 S  0.0  0.0   0:00.00 khugepage
   23 root      20   0     0    0    0 S  0.0  0.0   0:00.00 fsnotify_
   24 root      20   0     0    0    0 S  0.0  0.0   0:00.00 ecryptfs-
   25 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 crypto   
   33 root       0 -20     0    0    0 S  0.0  0.0   0:00.00 kthrotld 
  156 root      20   0     0    0    0 S  0.0  0.0   0:00.52 scsi_eh_0
  164 root      20   0     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_1
  168 root      20   0     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_2
  181 root      20   0     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_3
  184 root      20   0     0    0    0 S  0.0  0.0
 
Old 03-02-2012, 06:38 AM   #5
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Rep: Reputation: 103Reputation: 103
Lightbulb

Try --

Code:
fuser -v filename being used

this will show you a list of the PID & command so you can

Code:
kill -9 PID
Hope this helps
 
Old 03-02-2012, 06:58 AM   #6
nnjond
Member
 
Registered: Feb 2007
Distribution: Ubuntu 10.04
Posts: 281

Original Poster
Rep: Reputation: 31
Thanks.

I don't what file name is being used?
 
Old 03-02-2012, 02:41 PM   #7
nnjond
Member
 
Registered: Feb 2007
Distribution: Ubuntu 10.04
Posts: 281

Original Poster
Rep: Reputation: 31
Solved

udo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bash command needed ninjafairy Programming 1 05-17-2011 02:45 PM
[SOLVED] bash command help needed HarryBoy Linux - Newbie 2 12-03-2010 12:24 PM
Bash command needed to remove failed install nnjond Linux - Newbie 1 05-12-2010 07:54 AM
[SOLVED] Using a long Bash command including single quotes and pipes in a Bash script antcore Linux - General 9 07-22-2009 12:10 PM


All times are GMT -5. The time now is 01:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration