LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-05-2012, 01:24 AM   #1
pratkal9
LQ Newbie
 
Registered: Oct 2012
Posts: 6

Rep: Reputation: Disabled
Bad ram or normal?


hello

well i am new to linux and h/w so i could be completely wrong sorry to mods if i posted the topic in wrong section

ok what is happening is my ram is getting full by cache ( which is normal i am aware of it ) but when my ram is kind of full the data get transferred to swap ( while 90% of my ram is used by cache ) after a while ( take around 6-10 hrs ) both cache and swap is full resulting in poor performance . In one rare case performance drop as bad as 100+ load . Now is it normal for linux to use swap even if ram is free??

how can i check if this is not hardware fault ( i.e ram ) . note this is a live server so i can't even think to use memtest86+ which require me to reboot the system .
 
Old 10-05-2012, 01:33 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,582
Blog Entries: 2

Rep: Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037
If it would be bad RAM you would see application crashes and kernel panics, not the behavior you describe. I would rather think that this is a bug or a misconfiguration.
 
Old 10-05-2012, 01:36 AM   #3
pratkal9
LQ Newbie
 
Registered: Oct 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
If it would be bad RAM you would see application crashes and kernel panics, not the behavior you describe. I would rather think that this is a bug or a misconfiguration.

ok can you give me some quick tips to save me from this issue???

this is a cpanel server on cloud linux
 
Old 10-05-2012, 01:49 AM   #4
pratkal9
LQ Newbie
 
Registered: Oct 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
total used free shared buffers cached
Mem: 11858 11780 77 0 405 7769
-/+ buffers/cache: 3605 8253
Swap: 4102 110 3991


as you can see cached is using all the ram and now start using swap

uptime output

08:50:09 up 17:50, 1 user, load average: 33.04, 14.34, 9.20

Last edited by pratkal9; 10-05-2012 at 01:51 AM.
 
Old 10-05-2012, 05:40 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,582
Blog Entries: 2

Rep: Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037
I can see nothing wrong with that picture at that time, the kernel just has swapped out 110MB stale memory, which I wouldn't worry about after 17h uptime. Does it get more overtime? It would be helpful to see a sequence of free outputs over time, maybe you set up a cronjob to log the memory usage every two hours, so that we can see a trend.
 
Old 10-05-2012, 09:35 AM   #6
henrycoffin
Member
 
Registered: Dec 2006
Distribution: RHEL Debian
Posts: 42

Rep: Reputation: 15
Is your load average always that high??? Can you post output from vmstat?
 
Old 10-05-2012, 11:33 AM   #7
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
It's normal for a Linux system to run with the RAM fully utilized. But, if you feel the desktop is unresponsive, & you want the system to swap less, you can adjust swappiness...

At a terminal run;
cat /proc/sys/vm/swappiness

It'll probably return 60, meaning 60% likelihood of swapping, generally.

To change it temporarily (to 5% likely to swap, in this instance);
sudo sysctl vm.swappiness=5

To change it permanently;
sudo gedit /etc/sysctl.conf
or
sudo kate /etc/sysctl.conf
or
sudo nano /etc/sysctl.conf

... and either modify or add the line
vm.swappiness=5

(again, for 5% likelihood of using swap)

****************

Also, If you are using KDE (especially on a version older than 4.8), one source of system slowdown can be nepomuk/syringi/akonadi server running,... Attempting to index all your files for social media connections.

You can deactivate nepomuk and stringi easily by going to the KDE settings utility and look for (and run) the search the search function as well as session settings, and look for nepomuk, and deactivate them (and in the session settings, to stop the service and also deselect it from loading).

Last edited by JaseP; 10-05-2012 at 11:35 AM.
 
Old 10-05-2012, 03:47 PM   #8
jefro
Guru
 
Registered: Mar 2008
Posts: 11,416

Rep: Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398
Some applications will use swap even if you don't want it to and some will not even clear it.

Your issue still seems to be a bad driver or bad program that is taking up space. Normal use should remain constant and not raise with time. Guess it could be some user issue logging on and never off or such but that has been mostly fixed long ago I'd think.

Last edited by jefro; 10-05-2012 at 03:48 PM.
 
Old 10-05-2012, 10:20 PM   #9
speck
Member
 
Registered: Nov 2001
Location: California
Distribution: Slackware 14.1
Posts: 271

Rep: Reputation: 54
Your RAM usage is fine, you're only using 3.6 GB out of 12 GB. Your load average is quite high though.
 
Old 10-06-2012, 11:25 AM   #10
jefro
Guru
 
Registered: Mar 2008
Posts: 11,416

Rep: Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398
Is it raising with time?
 
Old 10-06-2012, 01:20 PM   #11
samadm
LQ Newbie
 
Registered: Oct 2012
Posts: 3

Rep: Reputation: Disabled
Drop the caches "echo 3 > /proc/sys/vm/drop_caches". verify the performance of application as it might not be releasing memory back properly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer will not restore from hibernate, just does a normal boot. But suspend to ram is working. richard Linux - Software 1 03-29-2011 09:20 AM
trying to get sharp fonts on Fedora 10 x86_64 -- normal good, bold bad Carnivale Linux - Desktop 2 07-06-2009 11:20 PM
Is 2G RAM all used really Normal? FredJones Linux - Server 2 08-06-2008 02:50 PM
Running mysqld as normal user... bad? uopjohnson Linux - Security 4 11-07-2006 04:41 PM
RAM go BAD? warheros Linux - Hardware 2 08-05-2003 10:30 PM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration