LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-03-2004, 10:33 PM   #1
0perat0r
Member
 
Registered: Jul 2004
Location: New Jersey, US
Distribution: Red Hat Linux WS version 3
Posts: 126

Rep: Reputation: 15
bad install


I just tried to install the rpm for vnc4.0 on one of my Linux systems. Halfway throught the install, it asked for one of the RH install disks. I had it in the cd-rom dirve, but when I clisked "ok" the install did not continue. Needless to say, vnc does not work on this machine. When I tried to uninstall the package, Linux said that it was not installed. When I tried to just reinstall the package, Linux said that it was already installed. Is there a way to get RH to stop seeing the install of this package? Perhaps some file(s) need to be removed....? I appreciate any help.

Thanks
 
Old 09-04-2004, 01:33 AM   #2
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Rep: Reputation: 30
checkout 'rpm --help', if I remember well, it is the '--force' flag you need to add to remove it. Then you'll probably be able to reinstall it again.
Also don't forget that it is possible that the cdrom has to be mounted, before you press continue.

succes,
elluva
 
Old 09-04-2004, 07:48 PM   #3
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
rpm -iv --force pkgname
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad Signatures on install galliar Mandriva 6 02-15-2005 05:30 PM
Bad Install eggoz Linux - Newbie 6 01-01-2005 01:46 PM
bad install glw Linux - Newbie 14 02-16-2004 03:01 AM
tomcat install gone bad joe_stevensen Debian 1 07-22-2003 04:29 PM
Can't install - bad compiler??? Korshun Linux - Software 9 08-18-2002 12:39 AM


All times are GMT -5. The time now is 03:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration