LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Bad Displayed Fonts (http://www.linuxquestions.org/questions/linux-newbie-8/bad-displayed-fonts-116598/)

Obscure 11-16-2003 04:58 AM

Bad Displayed Fonts
 
I use Slack 9.0 / 2.4.21 with Dropline gnome and all my fonts were OK since I've upgraded my XFree86 file as a person told me on dri drivers mailinglist..
I need to do this to use last version of dri.radeon drivers...

The problem I think is shown in the X log file:

Code:

Could not init font path element /usr/X11R6/lib/X11/fonts/local/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/:unscaled, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/TrueTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
AUDIT: Thu Nov 13 19:13:22 2003: 691 X: client 5 rejected from local host


Some1 has a suggestion to resolve my problem??
TnxVM

Azmeen 11-17-2003 12:20 AM

The X extensions (modules) that initialize the fonts are not being loaded.

Make sure the following are in /etc/X11/XF86Config to initialize the
scalable fonts, and then restart your X server.

Code:

...
Section "Files"
...
        ModulePath  "/usr/X11R6/lib/modules"
...
        FontPath    "/usr/X11R6/lib/X11/fonts/Speedo/"
        FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath    "/usr/X11R6/lib/X11/fonts/CID/"
...
EndSection
...
Section "Module"
...
        Load  "freetype"
        Load  "type1"
        Load  "speedo"
...
EndSection
...


Obscure 11-17-2003 09:16 AM

Tnx For yr Time....

All is loaded into Xf86config file:
Code:


Section "Module"

# This loads the DBE extension module.

    Load        "dbe"          # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"  # don't initialise the DGA extension
    EndSubSection

# This loads the Type1 and FreeType font modules
    Load        "type1"
    Load        "speedo"
    Load        "freetype"
    Load        "xtt"

# This loads the GLX module
    Load      "glx"
# This loads the DRI module
    Load      "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

    RgbPath        "/usr/X11R6/lib/X11/rgb"

    FontPath  "/usr/X11R6/lib/X11/fonts/local/"
    FontPath  "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath  "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath  "/usr/X11R6/lib/X11/fonts/TrueTF/"
#    FontPath  "/usr/X11R6/lib/X11/fonts/freefont/"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/"

# The module search path.  The default path is shown here.

#    ModulePath "/usr/X11R6/lib/modules"

EndSection

I've noticed that not only the fonts but also the icons are bad displayed too...
Everything on my desktop seems to have a big alias...
Tnx for your help

Obscure 11-17-2003 02:26 PM

I have resolved my problem UPGRADING the Slack9.0 xfree package with the Slack 9.1 pkg

xfree-4-3-0-i386-2 ---> xfree-4.3.0-i486-5
xfree-devel-4.3.0-i386-2 ----> xfree-devel-4.3.0-i486-3

Now all works correctly
Tnx to all


All times are GMT -5. The time now is 12:55 AM.