LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-01-2013, 04:12 PM   #1
ne.andersson
LQ Newbie
 
Registered: Jun 2013
Posts: 2

Rep: Reputation: Disabled
Backtrack 5 R3 and TL-WN722N V1.1 compatibility issues


Hi guys.

First off I would like to say that this is my first post on this forum and I am a total newbie on both linux and backtrack.

And please Im Norwegian so english is not my first language.

Im running a native Backtrack 5 R3 out of a HP Elitebook 2530p combined with a TL-WN722N V1.1 USB wireless network card.

I did some reading on different sites that this USB adapter was suppose to be working out of the box with BT 5 R3 before I ordered it.

So this is what im trying to do, I have a router at home by the model Dir-655 with WPS pin enabled on it and I want to use reaver to crack the PIN/WPA password.

This is what I have done so far and the problems im receiving.

Checking my interfaces.
Code:
root@bt:~# airmon-ng


Interface	Chipset		Driver

wlan1		Atheros AR9271	ath9k - [phy1]
wlan0		Intel 5100	iwlwifi - [phy0]
Going into monitor mode.
Code:
root@bt:~# airmon-ng start wlan1


Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID	Name
1724	dhclient3
1725	dhclient3
2141	wpa_supplicant
2149	dhclient
2172	dhclient
Process with PID 1725 (dhclient3) is running on interface wlan0
Process with PID 2141 (wpa_supplicant) is running on interface wlan0
Process with PID 2172 (dhclient) is running on interface wlan0


Interface	Chipset		Driver

wlan1		Atheros AR9271	ath9k - [phy1]
				(monitor mode enabled on mon0)
wlan0		Intel 5100	iwlwifi - [phy0]
Running wash to find compatible routers. (mine is on the bottom Andersson WIFI)
Code:
root@bt:~# wash -i mon0

Wash v1.4 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

BSSID                  Channel       RSSI       WPS Version       WPS Locked        ESSID
---------------------------------------------------------------------------------------------------------------
34:21:09:00:18:30       1            -92        1.0               No                Crme de la kdd
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
00:18:E7:F8:DF:3D       3            -84        1.0               No                Saxen
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
00:24:01:F1:7E:57       7            -91        1.0               No                100m-skogen
00:18:E7:F5:06:4A       8            -88        1.0               No                Aneli
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
00:26:5A:B5:46:0B      13            -41        1.0               No                Andersson WIFI
Running reaver
Code:
root@bt:~# reaver -i mon0 -b 00:26:5A:B5:46:0B -vv

Reaver v1.4 WiFi Protected Setup Attack Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

[?] Restore previous session for 00:26:5A:B5:46:0B? [n/Y] y
[+] Restored previous session
[+] Waiting for beacon from 00:26:5A:B5:46:0B
[+] Switching mon0 to channel 13
[+] Associated with 00:26:5A:B5:46:0B (ESSID: Andersson WIFI)
[+] Trying pin 11115670
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Received M1 message
[+] Sending M2 message
[+] Received M3 message
[+] Sending M4 message
[+] Received WSC NACK
[+] Sending WSC NACK
[+] Trying pin 22225672
[+] Sending EAPOL START request
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] Trying pin 22225672
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Received M1 message
[+] Sending M2 message
[+] Received M3 message
[+] Sending M4 message
[+] Received M3 message
[+] Sending WSC NACK
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] Trying pin 22225672
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Received M1 message
[+] Sending M2 message
[+] Received M3 message
[+] Sending M4 message
[+] Received WSC NACK
[+] Sending WSC NACK
[+] Trying pin 33335674
[+] Sending EAPOL START request
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] Trying pin 33335674
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Received M1 message
[+] Sending M2 message
[+] Received M3 message
[+] Sending M4 message
[+] Received WSC NACK
[+] Sending WSC NACK
[+] 0.05% complete @ 2013-06-01 22:03:53 (5 seconds/pin)
[+] Trying pin 44445676
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Received M1 message
[+] Sending M2 message
[+] Received M3 message
[+] Sending M4 message
[+] Received WSC NACK
[+] Sending WSC NACK
^C
[+] Session saved.
As you can see it is actually trying new PINs and everything but after a while it gets so bad that it just stops, as you see below it has just hung it self up and stoped running.
Code:
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] 0.48% complete @ 2013-06-01 22:06:51 (2 seconds/pin)
[+] Trying pin 00425674
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[!] WARNING: Receive timeout occurred
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x02), re-trying last pin
[+] Trying pin 00425674
[+] Sending EAPOL START request
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] Trying pin 00425674
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] Trying pin 00425674
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[!] WARNING: Receive timeout occurred
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x02), re-trying last pin
And yes I have tried this on different routers and never had any better luck.
I have not installed any drivers/firmware.

Can someone please help me out here?

Thanks guys!
 
Old 06-02-2013, 07:05 AM   #2
ne.andersson
LQ Newbie
 
Registered: Jun 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
This is the way it looks often when it hangs it self up, then I just have to start the command all over again.

I would really appreciate it if someone could help me out here.

Code:
[+] Sending WSC NACK
[+] 5.73% complete @ 2013-06-02 13:01:29 (3 seconds/pin)
[+] Trying pin 06205676
[+] Sending EAPOL START request
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] Trying pin 06205676
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Received M1 message
[+] Sending M2 message
[+] Received M3 message
[+] Sending M4 message
[+] Received WSC NACK
[+] Sending WSC NACK
[+] Trying pin 06215675
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x03), re-trying last pin
[+] Trying pin 06215675
[+] Sending EAPOL START request
[!] WARNING: Receive timeout occurred
[+] Sending EAPOL START request
[!] WARNING: Receive timeout occurred
[+] Sending EAPOL START request
[!] WARNING: Receive timeout occurred
[+] Sending EAPOL START request
^C
[+] Session saved.
 
Old 12-05-2013, 07:55 PM   #3
jappyjo
LQ Newbie
 
Registered: Dec 2013
Posts: 1

Rep: Reputation: Disabled
wait a bit longer

After u try a certain number of incorrect pins, ur router will stop accepting new pins for a certain amount of time. The amount of time varies depending on the type of router. Reaver will continue to try to communicate with the router until this time period has passed. Once it has, reaver will start trying new pins again. It looks like u just need to wait a bit for the router lockout period to end. As I recall, it took about 5 mins on my cisco router. Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Backtrack 5 r3 Trouble connecting to the internet with TP-link TL-WN722N USB card. TomGauss Linux - Wireless Networking 3 03-11-2013 11:32 PM
Drivers for TL-WN722N (Backtrack 5) leetxor Linux - Newbie 6 12-13-2011 05:58 PM
backtrack 3 & usb adapter TL-WN722N arslan4201 Linux - Newbie 1 06-13-2011 02:05 AM
Backtrack interface issues strk20 Linux - Newbie 8 04-24-2011 03:08 AM
Compatibility of backtrack 4 with Vmware to decide for the best wireless usb adapter! h3atmach1n3 Linux - Wireless Networking 3 05-29-2010 05:35 AM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration