LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-03-2010, 08:22 AM   #1
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Rep: Reputation: 17
AWN on LinuxMint 8


Hi,

I installed AWN from the package manager in LinuxMint 8 Helena and it seems to have successfully installed. However, when I load it, there was no default theme that came with it or anything - it was just blank - no wallpapers, no themes..... (pls see attached image).
Then I got down to installing the Mac4Lin theme, 'cos my main aim is to get the dock. I followed the instructions at http://ubuntuguide.net/install-mac-o...ntu-9-10karmic
Installation completed successfully and the visual look resembles that of a mac in terms of scroll bars and buttons, etc., but there is still no dock and no wallpaper. I even go to AWN and there is nothing in the Themes.
Attached Images
File Type: gif awn.gif (21.9 KB, 7 views)
 
Old 03-03-2010, 09:33 AM   #2
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
From the AWN theme manager, did you click "Add" and select the file Mac4Lin_AWN_v1.0.tgz as the guide said?
 
1 members found this post helpful.
Old 03-03-2010, 11:02 AM   #3
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Original Poster
Rep: Reputation: 17
Thanks Reed9. did as you said and now I see Mac4Lin_AWN_v1.0RCS in the themes, but my desktop still does not show the dock or the appropriate wallpaper associated with the theme.
 
Old 03-03-2010, 11:14 AM   #4
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Hmm, well, AWN wouldn't set the wallpaper. You would need to go through GNOME's normal wallpaper thing for that, I assume.

You're saying when you start AWN, it doesn't launch?

Try starting it from the terminal and post any error message. Should just be
Code:
avant-window-navigator
to start.
 
Old 03-03-2010, 11:28 AM   #5
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Original Poster
Rep: Reputation: 17
immediately after my last post, I rebooted the system to see if it would help but now I have an even bigger problem. after the system rebooted and I reached the desktop, the panel at the bottom of the screen is missing and there's no way I can even launch any programs or even the terminal.
AWN could load properly without any problem, but it was the dock that wasn't loading.
 
Old 03-03-2010, 11:39 AM   #6
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Type ALT+F2 to open a run dialogue. From that you can re-launch the panel or a terminal.

The panel should be called gnome-panel and the terminal, gnome-terminal.
 
Old 03-03-2010, 11:47 AM   #7
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Original Poster
Rep: Reputation: 17
ALT+F2 is not doing anything
 
Old 03-03-2010, 12:15 PM   #8
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Hmm, odd. Alright, try CTRL+ALT+F1. This should drop you to a console login.

There is probably a fancy way using gconf to change your settings, but I'm not familiar enough with GNOME to tell you how. The simple method is to delete the GNOME config files and restart the session. This should revert everything back to the defaults.

Code:
rm -r ~/.gnome ~/.gnome2 ~/.gconf
Restart the session
Code:
sudo /etc/init.d/gdm restart
 
Old 03-03-2010, 12:17 PM   #9
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by reed9 View Post
Hmm, well, AWN wouldn't set the wallpaper. You would need to go through GNOME's normal wallpaper thing for that, I assume.

You're saying when you start AWN, it doesn't launch?

Try starting it from the terminal and post any error message. Should just be
Code:
avant-window-navigator
to start.
I managed to get to the terminal by right-clicking on th desktop and selecting "Open in Terminal" and then did avant-window-navigator
and this is the result:
Quote:
~/Desktop $ avant-window-navigator

(awn-applets-migration:2833): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `AwnConfigClient'
curves_symmetry unset, setting now
curviness unset, setting now
Warning: Screen isn't composited. Please run compiz (-fusion) or another compositing manager.
 
Old 03-03-2010, 12:34 PM   #10
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
Ok, I was looking through the guide you said you used, and it has you remove the gnome-panel.

So from the terminal, type
Code:
gconf-editor
Go to /desktop/gnome/session again, and you should be able to re-enable the panel. For now, I would set the panel to just be at the top, and put a menu applet on there, so you have easy access to your programs while you work on getting AWN going.

The error is because you need window compositing for AWN to work properly. If you go to appearance preferences, there is a Visual Effects tab where you can turn on Compiz. You do need a video card capable of hardware acceleration, though, and have it set up correctly. Most intel cards will have this working out of the box, some older ATI cards as well. For newer ATI cards and Nvidia cards, you need their proprietary drivers installed.
 
Old 03-03-2010, 01:26 PM   #11
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by reed9 View Post
Ok, I was looking through the guide you said you used, and it has you remove the gnome-panel.

So from the terminal, type
Code:
gconf-editor
Go to /desktop/gnome/session again, and you should be able to re-enable the panel. For now, I would set the panel to just be at the top, and put a menu applet on there, so you have easy access to your programs while you work on getting AWN going.

The error is because you need window compositing for AWN to work properly. If you go to appearance preferences, there is a Visual Effects tab where you can turn on Compiz. You do need a video card capable of hardware acceleration, though, and have it set up correctly. Most intel cards will have this working out of the box, some older ATI cards as well. For newer ATI cards and Nvidia cards, you need their proprietary drivers installed.
I managed to reach the configuration editor as you said and I can see the panel is already there (pls see image). How do I get it to display?
Attached Images
File Type: gif configeditor.gif (38.2 KB, 4 views)
 
Old 03-03-2010, 02:08 PM   #12
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
From the terminal, type
Code:
gnome-panel &
Does it show back up?
 
1 members found this post helpful.
Old 03-03-2010, 02:13 PM   #13
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by reed9 View Post
From the terminal, type
Code:
gnome-panel &
Does it show back up?
thanks so much. it's back
 
Old 03-03-2010, 02:28 PM   #14
fkasmani
Member
 
Registered: Dec 2007
Posts: 177

Original Poster
Rep: Reputation: 17
i managed to get the dock to display. went to Control Center >> Desktop Configuration Tools >> Gnome Compositing and i enabled Gnome Compositing there.
 
Old 03-03-2010, 02:36 PM   #15
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 142Reputation: 142
I would assume the panel will disappear again when you reboot. It seems to have somehow been removed the wherever GNOME normally autostarts it from. I don't think it uses the normal autostart thing, but perhaps. You can add it there at the least.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Awn EllisDee Ubuntu 0 12-19-2009 09:34 AM
Gnome with awn danielkir Linux - Newbie 1 11-27-2008 08:12 AM
How do you add shortcuts to AWN? k1ngdv Linux - Software 1 04-24-2008 06:19 PM
AWN Setting Question Mr. Swillis Linux - Software 1 03-24-2008 03:14 PM
LXer: Awn: 0.1 + 0.1 = ? LXer Syndicated Linux News 0 10-08-2007 02:50 AM


All times are GMT -5. The time now is 08:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration