LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2007, 12:02 PM   #1
jaen
LQ Newbie
 
Registered: May 2007
Posts: 11

Rep: Reputation: 0
avi-xmms


I have downloaded an AVI plugin for XMMS from www.xmms.org.
It turned out that when I typed ./configure, after a while the console reports the following:

The glib-config script installed by GLIB could not be found. If GLIB was installed in PREFIX, make sure PREFIX/bin is in your path, or set the GLIB_CONFIG environment variable to the full path ti glib-config.
configure: error: GLIB >= 1.2.2 not installed - please install first

After that, I downloaded glib-2.10.3.tar.bz2 from http://www.gtk.org. Well, it turns out that after I installed it, the problem still persists.
 
Old 05-20-2007, 01:24 AM   #2
Sonneteer
Member
 
Registered: May 2006
Location: Canada
Distribution: Slackware 13.37; Ubuntu 12.04
Posts: 81
Blog Entries: 5

Rep: Reputation: 15
glib-config is probably on your system somewhere, ./configure just doesn't know where. So try "locate glib-config", or use some other search tool to find it. Then use a command like "export GLIB_CONFIG=/full/path/to/glib-config" before running ./configure
 
Old 05-20-2007, 08:43 PM   #3
jaen
LQ Newbie
 
Registered: May 2007
Posts: 11

Original Poster
Rep: Reputation: 0
Well, I tried both ways searching glib-config and none of them brought results.
 
Old 05-21-2007, 01:24 PM   #4
Sonneteer
Member
 
Registered: May 2006
Location: Canada
Distribution: Slackware 13.37; Ubuntu 12.04
Posts: 81
Blog Entries: 5

Rep: Reputation: 15
I just had another look at my system, glib-config came with glib-1.2.10 but not glib2-2.12.9.
So it looks like this plugin is depending on glib 1.2.x and not glib 2.x.x. So you'll need to find and install version 1.
 
Old 05-21-2007, 07:29 PM   #5
jaen
LQ Newbie
 
Registered: May 2007
Posts: 11

Original Poster
Rep: Reputation: 0
Well, I followed the instructions you just gave me and in a way it worked out. But now it says:

*** 'glib-config --version' returned 1.2.2, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in installing avi-xmms on 64 bit cranium2004 Programming 0 02-18-2006 12:52 AM
avi-xmms help!!!!!! TheShemeta Linux - Software 2 11-09-2003 02:15 PM
AVI-XMMS Not Working roccoman Linux - General 1 12-12-2002 02:54 AM
problem installing avi-xmms-1.2.3 valueduser Linux - Software 5 09-04-2002 03:24 PM
xmms avi captgoodnight Linux - General 5 02-19-2002 03:28 PM


All times are GMT -5. The time now is 10:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration