LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2003, 11:03 AM   #1
crowl
LQ Newbie
 
Registered: Oct 2003
Posts: 25

Rep: Reputation: 0
autostart vncserver


I have search this board and also google for automatically start vncserver at startup. Have found a lot of problems and also solutions. However, it doesn't work on my maschine.

I have a fresh install of RedHat9. Using the gui setup guide. I have choose server install and have add X, gnome and other things I need. For my testing, I have done all tings as root!

All work fine. Runlevel is 3 (init 3). If i start vncserver by tpying 'vncserver' the service start and remote access work fine.

Now, I want to start vncserver each time redhat is starting. Thats the problem.

My steps:
- startx
- in the gui I go to System Settings -> Server Settings -> Services
- Editing Runlevel 3, activate vncserver
- At /etc/rc.d/init.d/ the vncserver file exists
- also at /etc/rc.d/rc3.d the file S91vncserver exists

During startup, is says vncserver starting ... OK
But the vncserver isn't started :-(

The vncserver logfile contains only data form my last manually start.

Another idea (found on google) was this:
- go to /etc/init.d
- create 'vncstart' file and add the text "vncserver"
- chmod a+x vncstart
- goto /etc/init.d/rc3.d
- ln -s /etc/init.d/vncstart S30vncstart

- go to /etc/init.d
- create 'vncstop' file
- add text "cvsserver -kill:1"
- chmod a+x vncstop
- goto /etc/init.d/rc3.d
- ln -s /etc/init.d/vncstop K30vncstop

Also without luck :-(

I'm new to linux, but I think it is really nice. Lot of things work fine, but vncserver doesn't like me.

I hope someone can assistance me. Thanks a lot in advance.
 
Old 10-09-2003, 09:25 PM   #2
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
first of all, perhaps it would be simpler to star at runlevel 5 for x and switch to a console, then put in /etc/rc.local the command to start vncserver, rc.loal is loaded after all the other startup scripts
 
Old 10-10-2003, 05:50 AM   #3
crowl
LQ Newbie
 
Registered: Oct 2003
Posts: 25

Original Poster
Rep: Reputation: 0
without luck

my rc.local contains only the two lines (and also comments):
touch /var/lock/subsys/local
vncserver

vncserver doesn't start. I have here three machines where I have trying to run vncserver automatically. Suddenly, manually start work always fine, automatic fail.

Any ideas?

I can't find any error messages. Where I have to take a look? As I mentioned, in the vncserver log file there is only the log date from the last manual start.

thx for help.
 
Old 10-10-2003, 09:34 AM   #4
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
hmm, i just noticed, you have redhat, try running 'setup' at the cnsole
select 'system services'
and see if vncserver is an option, if so, checking it should allow vnc to start automatically
 
Old 10-10-2003, 10:11 AM   #5
crowl
LQ Newbie
 
Registered: Oct 2003
Posts: 25

Original Poster
Rep: Reputation: 0
frieza,

thank you for your assistance.

Is there any difference between

Quote:
My steps:
- startx
- in the gui I go to System Settings -> Server Settings -> Services
- Editing Runlevel 3, activate vncserver
- At /etc/rc.d/init.d/ the vncserver file exists
- also at /etc/rc.d/rc3.d the file S91vncserver exists
and
Quote:
hmm, i just noticed, you have redhat, try running 'setup' at the cnsole
select 'system services'
and see if vncserver is an option, if so, checking it should allow vnc to start automatically


I tried it, but no luck on my side.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
about vncserver Ammad Linux - General 4 07-27-2005 07:33 PM
install and autostart vncserver mephisto_ee *BSD 0 07-02-2005 11:57 PM
Robust vncserver startup file (rc.vncserver) arobinson74 Slackware 4 05-14-2005 06:33 AM
Vncserver metasoma Linux - Software 4 10-28-2003 03:12 PM
VNCServer jcornel7 Linux - Newbie 1 02-17-2003 01:33 PM


All times are GMT -5. The time now is 08:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration