LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-22-2016, 07:48 AM   #1
P. eleazar
LQ Newbie
 
Registered: Jun 2016
Posts: 3

Rep: Reputation: Disabled
autoreconf failed with exit status 1. How an I fix this error?


Hellow!

I am trying to install a program by cloning it with git. I am running in an Ubuntu 14.04.4 LTS. I get the source code correctly with "git clone" but autoreconf fails giving the following error:

xray@silvia-desktop:~/Software/Gitsrc/simput$ autoreconf --install --verbose
autoreconf2.50: Entering directory `.'
autoreconf2.50: configure.ac: not using Gettext
autoreconf2.50: running: aclocal
autoreconf2.50: configure.ac: tracing
autoreconf2.50: configure.ac: adding subdirectory extlib/cfitsio to autoreconf
autoreconf2.50: Entering directory `extlib/cfitsio'
autoreconf2.50: configure.in: not using Gettext
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
autoreconf2.50: configure.in: tracing
autoreconf2.50: configure.in: not using Libtool
autoreconf2.50: running: /usr/bin/autoconf
configure.in:175: AC_PROG_CPP was called before AC_PROG_CC
autoconf: Undefined macros:
configure.in:11:AC_CONFIG_SRCDIR([fitscore.c])
configure.in:178: AC_MSG_NOTICE(cfitsio: == Fortran compiler search has been overridden)
configure.in:179: AC_MSG_NOTICE(cfitsio: == Cfitsio will be built without Fortran wrapper support)
configure.in:186: AC_MSG_NOTICE(cfitsio: == Adding wrapper support for GNU Fortran by default)
configure.in:226:AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[void d( int , double) ]])],[PROTO=yes],[PROTO=no])dnl
configure.in:248: AC_LANG_PUSH([C])
configure.in:249: AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],[c_has_option=yes],[c_has_option=no])
configure.in:250: AC_MSG_RESULT($c_has_option)
configure.in:251: AC_LANG_POP([])
configure.in:278: AC_LANG_PUSH([C])
configure.in:279: AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],[c_has_option=yes],[c_has_option=no])
configure.in:280: AC_MSG_RESULT($c_has_option)
configure.in:281: AC_LANG_POP([])
configure.in:288: AC_DEFINE(_LARGEFILE_SOURCE)
configure.in:289: AC_DEFINE(_FILE_OFFSET_BITS,64)
configure.in:304: AC_DEFINE(_LARGEFILE_SOURCE)
configure.in:305: AC_DEFINE(_FILE_OFFSET_BITS,64)
configure.in:309: AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include <stdio.h>],
configure.in:311: AC_DEFINE(_LARGEFILE_SOURCE)
configure.in:312: AC_DEFINE(_FILE_OFFSET_BITS,64)
configure.in:313: AC_MSG_RESULT(yes)
configure.in:314: ],[AC_MSG_RESULT(no)])
configure.in:323: AC_DEFINE(_LARGEFILE_SOURCE)
configure.in:324: AC_DEFINE(_FILE_OFFSET_BITS,64)
configure.in:454:AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>
configure.in:458:AC_DEFINE(HAVE_FTRUNCATE)
configure.in:459:AC_MSG_RESULT("yes")
configure.in:460:],[AC_MSG_RESULT("no") ])
configure.in:467:AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdlib.h>
configure.in:471:AC_DEFINE(HAVE_LONGLONG)
configure.in:472:AC_MSG_RESULT("yes")
configure.in:473:],[AC_MSG_RESULT("no") ])
configure.in:488:AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <sys/ipc.h>
configure.in:497:AC_DEFINE(HAVE_SHMEM_SERVICES)
configure.in:499:AC_MSG_RESULT("yes")
configure.in:500:],[AC_MSG_RESULT("no") ])
configure.in:509:AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/fcntl.h>
configure.in:513:AC_DEFINE(HAVE_FLOCK_T)
configure.in:514:AC_MSG_RESULT("yes")
configure.in:515:],[AC_MSG_RESULT("no") ])
configure.in:519: AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/flock.h>
configure.in:523: AC_DEFINE(HAVE_FLOCK_T)
configure.in:524: AC_MSG_RESULT("yes")
configure.in:525: ],[AC_MSG_RESULT("no") ])
configure.in:534:AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/ipc.h>
configure.in:53: AC_DEFINE(BUILD_HERA)
configure.in:540:AC_DEFINE(HAVE_UNION_SEMUN)
configure.in:541:AC_MSG_RESULT("yes")
configure.in:542:],[AC_MSG_RESULT("no") ])
configure.in:552: AC_DEFINE(HAVE_NET_SERVICES)
configure.in:561: AC_DEFINE(_REENTRANT)
configure.in:566:AC_CONFIG_FILES([Makefile])
configure.in:568:AC_CONFIG_FILES([cfitsio.pc])
configure.in:572:AC_MSG_RESULT([])
configure.in:573:AC_MSG_RESULT([ Congratulations, Makefile update was successful.])
configure.in:574:AC_MSG_RESULT([ You may want to run "make" now.])
configure.in:575:AC_MSG_RESULT([])
configure.in:64: AC_DEFINE(GSIFTP_FLAVOUR,1,[Define Globus Toolkit architecture])
configure.in:79: AC_DEFINE(HAVE_GSIFTP,1,[Define if you want Globus Toolkit gsiftp protocol support])
configure.in:93: AC_DEFINE(HAVE_BZIP2,1,[Define if you want bzip2 read support])
configure.in:98: AC_DEFINE(HAVE_BZIP2,1,[Define if you want bzip2 read support])
autoreconf2.50: /usr/bin/autoconf failed with exit status: 1

I have been searching for this in several websites. I found that the problem may be related to an old version of libtool, or to not having it installed, but I have already check this and my libtool package is up to date. I aso have autotools updated.

An interesting point is that I have tryed to install it in a Debian I have installed in other computer in a virtual machine, and I get the same error, so it seems to be something related to an error I am committing maybe in system general configuration...

I have been discussing with a mate thas has no problem in the installation, and get this output when doing outoreconf:

lenovo:~/tmp/simput> autoreconf --install --verbose
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal
autoreconf: configure.ac: tracing
autoreconf: configure.ac: adding subdirectory extlib/cfitsio to autoreconf
autoreconf: Entering directory `extlib/cfitsio'
autoreconf: configure.in: not using Gettext
aclocal: warning: autoconf input should be named 'configure.ac', not
'configure.in'
autoreconf: configure.in: tracing

Why this does not work in my case? Any idea?

Thanks a lot!
 
Old 06-22-2016, 08:12 AM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 5,388

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Link to git repo?
 
Old 06-22-2016, 10:33 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,281

Rep: Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164
$ git clone https://github.com/Kitware/simput
$ cd simput/ ... and please read the file README.md :
"$ npm install -g simput"


Besides that, there are no autotools files : I.e. no 'autoreconf' can be run.
'autoreconf' can be used when files like configure.ac, acinclude.m4 are present.


-
 
Old 06-22-2016, 10:43 AM   #4
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 5,388

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
I see a bunch of javascript files, autotools has nothing to do with it.
It seems you need the npm program
https://www.npmjs.com/package/npm

Last edited by keefaz; 06-22-2016 at 10:45 AM.
 
Old 06-22-2016, 12:25 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,015

Rep: Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454Reputation: 2454
i take it you did NOT read the file "README"
also the documentation ON the git page !!!
the install instructions ARE RIGHT THERE IN YOUR FACE !!!
https://github.com/Kitware/simput
just scroll down a bit to where it says in BIG BOLD LETTERS
-- Installation --
 
Old 06-30-2016, 05:51 AM   #6
P. eleazar
LQ Newbie
 
Registered: Jun 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
Hello!

I think you have presuppose more things than convenient, which maybe is my fault for not giving the link to git repo...

It is actually not https://github.com/Kitware/simput but git clone http://www.sternwarte.uni-erlangen.d...ic/simput.git/ You can see the installation instructions here:

http://www.sternwarte.uni-erlangen.d...simulation.php

Any other idea?

Thank you.
 
Old 06-30-2016, 10:56 AM   #7
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 5,388

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
There is nothing to work with autoconf tools in http://www.sternwarte.uni-erlangen.d...ic/simput.git/

No Makefile.am, no configure.ac... there aren't even any file to compile there

Edit, ah it's there:

http://www.sternwarte.uni-erlangen.d...put.git;a=tree

Last edited by keefaz; 06-30-2016 at 11:03 AM.
 
Old 06-30-2016, 11:08 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,281

Rep: Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164
Re #6.

There is a new "Ready to use" version, issued today : simput-2.1.2.tar.gz → no autoreconf !
See http://www.sternwarte.uni-erlangen.d...simulation.php
>> http://www.sternwarte.uni-erlangen.d...t-2.1.2.tar.gz

Building simput-2.1.2 :
Code:
tar xvf simput-2.1.2.tar.gz
cd simput-2.1.2/
./configure
make
sudo make install
 
Old 07-21-2016, 10:38 AM   #9
P. eleazar
LQ Newbie
 
Registered: Jun 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thank you.

I got the new version from there. But I still get the same error whetn trying to do autoreconf. This is really the problem I want to fix becouse new versions are usually updated just in the git repot. So I need to fix this for future updates.

Someone pointed me that the autoconf version using seems to be 2.50 while version required may be higher. Actually, I see that in configure.ac file is written AC_PREREQ([2.59]) and when I do

$ autoconf --version

I get this:

autoconf (GNU Autoconf) 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+/Autoconf: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by David J. MacKenzie and Akim Demaille.
---
Autoconf 2.50 chosen by Debian wrapper script.
For information and tuning advice see autoconf(1).

It seems that even autoconf is up to date, not the newest version is selected by he wrapper... I don't know if this could be the problem or not. Any idea?

Thank you in advance.
 
Old 07-21-2016, 10:53 AM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,281

Rep: Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164Reputation: 3164
Re #9.

Please read post #8 : → no autoreconf ! means do not run autoreconf.


I.e. 'autoreconf' is used only if you have no file 'configure'.

tar xvf simput-2.1.2.tar.gz
cd simput-2.1.2/
./configure
make
sudo make install

-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] RPM: error: %post(jboss-eap6-test-6.0.1-14.noarch) scriptlet failed, exit status 1 thomas2004ch Linux - Software 4 08-31-2013 12:16 PM
scriptlet failed, exit status 1 tissam89 Linux - Newbie 7 04-10-2013 03:49 AM
Crunchbang 10; can't fix broken packages (error exit status 1) HappyTheCat Linux - Newbie 7 11-02-2012 07:26 PM
[SOLVED] cron errors: failed with exit status 1 mike11 Linux - Newbie 4 12-12-2011 09:43 PM
error: command 'gcc' failed with exit status 1 yuri16 Linux - Software 1 04-21-2009 01:27 AM


All times are GMT -5. The time now is 08:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration