LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2003, 04:29 PM   #16
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47

Indeed, the problem may be the umask. Set it to 777 rather than 222 and see if that helps.
 
Old 02-01-2003, 06:41 PM   #17
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
umask 777 will leave them with absolutely no rights. a umask of 777 is equal to a chmod 000

So, if you mean a umask=000 then that'd be equal to a chmod 777 (which is probably more likely what you mean).

Cool
 
Old 02-02-2003, 04:55 AM   #18
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
Thumbs up

I've tried with a mix of your tips and I get it work !

/dev/hdc1 /mnt/data ntfs umask=000,defaults 1 0

I used that line ... now I'm not sure about the security of this settings ... for me it's good that any user can read the partition ... of course noone could write

how about this ?
 
Old 02-02-2003, 05:05 AM   #19
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Should be fine, however, I think you should change that last 1 to a zero.

The umask of 000 will work fine since NTFS is unwriteable anyway (for arguments sake I'll say that you could enable write, but normally it's off for safety).

Cool
 
Old 02-02-2003, 05:10 AM   #20
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
did it thanks a lot !
 
Old 02-02-2003, 05:11 AM   #21
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You're welcome, I am glad you got it working!
 
Old 02-02-2003, 05:50 AM   #22
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
I was wondering when someone was going to mention "umask=000".
lynch
 
Old 02-02-2003, 06:06 AM   #23
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Lynch, why? Why does it have to be a umask of 000 when all one needs is execution and read permissions (umask=000)? Just curious, I know write isn't necessarily a bad thing for this instance since NTFS doesn't allow it anyway, but I still am curious as to why? Thanks

Cool
 
Old 02-02-2003, 07:04 AM   #24
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Thanks MasterC, didn't realise umasks were inverted like that...
 
Old 02-02-2003, 07:19 AM   #25
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You're welcome Any ideas on my above question? I'm quite confused on it...

Cool
 
Old 02-02-2003, 07:59 AM   #26
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
in kernel config:
Code:
[*] prompt for development and/or bla bla bla...
opens up:
Code:
[*]NTFS write support (DANGEROUS)
and umask 000 means anyone can read/write,
umask 007 means owner and group can read/write, everyone else no touchie.
 
Old 02-02-2003, 09:21 AM   #27
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Quote:
...Any ideas on my above question? I'm quite confused on it...
Oh,so am I.
It's just how I've always got it to work for me.Actually,I just add "umask=0"to the fstab line and leave it at that.
Sorry I dont have a good answer.
lynch
 
Old 02-02-2003, 12:47 PM   #28
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by Darin
in kernel config:
Code:
[*] prompt for development and/or bla bla bla...
opens up:
Code:
[*]NTFS write support (DANGEROUS)
and umask 000 means anyone can read/write,
umask 007 means owner and group can read/write, everyone else no touchie.
Thank Darin, but my question more applies to why a read/execute priviledge doesn't allow reading if the write bit isn't set as well.

Cool
 
Old 07-04-2003, 12:42 PM   #29
candyman123
Member
 
Registered: Jul 2003
Posts: 46

Rep: Reputation: 15
umask problem

I know this is really old...but I think I found the problem as to why "umask 222" didn't work.

I haven't looked into why it works...but it does

/dev/hdd3 /home/tom/storage2 ntfs auto,umask=0222 0 0

That works perfect. Everyone gets read and execute access.

When I did it with just 222, I had major problems. The user has read, the group and everyone else has none.

Whaddya think?

Last edited by candyman123; 12-30-2008 at 12:37 AM.
 
Old 07-19-2003, 02:05 PM   #30
mike-hell
LQ Newbie
 
Registered: Jul 2003
Posts: 4

Rep: Reputation: 0
ok wierd sense of linux still sucking and sticking with freebsd
problem: can not mount ntfs in redhat 9
sygnosis: when tried to create in fstab (/dev/hda1 /win ntfs umask=007,gid=201,defaults 1 0 )
error: mount: fs type ntfs not supported by kernel
(all i want to do is mount my gf's winxp partition to my linux to get files off it and burn on cd)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
automount Solaris home directories onto RedHat ghouliajoolia Linux - General 3 09-07-2004 07:20 AM
Automount Network NTFS drive--Slackware a1flecke Linux - Newbie 2 05-03-2004 08:33 PM
Setting up Automount on Redhat 9 miqorz Red Hat 6 03-23-2004 07:24 PM
Redhat 9 CD Automount 1jamie Linux - Software 2 08-28-2003 03:20 PM
How to automount my C drive (FAT32) every time I login Redhat futurist Linux - General 2 03-17-2003 03:17 PM


All times are GMT -5. The time now is 12:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration