LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-31-2003, 08:17 AM   #1
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Rep: Reputation: 15
automount NTFS in Redhat 8.0


Hi there,

this is my first post I know a little bit about linux, but I've been searching for a strong community and now I've found it !

I've got a NTFS partition that I want to access to in linux (Read Only, of course). I installed NTFS support (Redhat 8.0 using 2.4.18-19 kernel) and I can mount it via shell. When I try to make my partition auto-mounting by adding the proper line in /etc/fstab, I can't read mounted partition with the standard user. If I go root, I can read. How to resolve this ? Thanks and keep Linux working
 
Old 01-31-2003, 08:37 AM   #2
GJoz
Member
 
Registered: Jan 2003
Distribution: Redhat 9.0 Shrike
Posts: 37

Rep: Reputation: 15
hi
search at redhat for windows partiton
you need to edit fstab file,and it says there what to add
take care
 
Old 01-31-2003, 08:39 AM   #3
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Can you post up here your /etc/fstab file so we can see what your entry looks like?

Cool
 
Old 01-31-2003, 08:43 AM   #4
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
/dev/hdc1 /mnt/data ntfs umask=222,users,auto 0 0


I tried this by a approximate reading on this forum ... it works under root but not under my user

thanks
 
Old 01-31-2003, 08:48 AM   #5
GJoz
Member
 
Registered: Jan 2003
Distribution: Redhat 9.0 Shrike
Posts: 37

Rep: Reputation: 15
thanks
i'll try that
cause mouting doesnt work for me
http://www.linuxquestions.org/questi...threadid=43494
i use /dev/hda1 /mnt/windows vfat auto,owner,users 0 0
i'll try yours
thanks,i hope it will work
 
Old 01-31-2003, 09:19 AM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
manub, just so you know I haven't left. I am just confused. Try this instead:
/dev/hdc1 /mnt/data ntfs defaults,auto,user,users,owner,umask=222,ro 0 0

What this is going to is basically overlap alot of options. However, they don't conflict (AFAIK) so you should be fine. See if that will work for you.

After editing the file, umount the drive, then run:
mount -a

...

Post up the errors if you have any. This one seems a bit odd to me.

What does ls -l /mnt/data give you anyway?

Cool
 
Old 01-31-2003, 01:32 PM   #7
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
I've tried with your set, but I always get the same error:

ls -l /mnt/data
ls: /mnt/data: Permission denied

I log as a user, open a terminal window, go su, edit fstab, umount -a, mount -a, try to ls succesfully, back to normal user, try to ls and got this
 
Old 02-01-2003, 02:51 AM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Try just mounting up the partition with the normal user (assuming it's not already mounted) try:
mount /mnt/data

As a normal user. What errors do you get?

Cool
 
Old 02-01-2003, 03:07 AM   #9
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
I unmounted the partition as root, then go back to normal user and did this:

mount /dev/hdc1 /mnt/data
mount: only root can do that

 
Old 02-01-2003, 03:10 AM   #10
GJoz
Member
 
Registered: Jan 2003
Distribution: Redhat 9.0 Shrike
Posts: 37

Rep: Reputation: 15
ok
edit /etc/fstab
and use this:
/dev/hdc1 /mnt/data ntfs auto,owner,users 0 0
then save and restart
it will work
 
Old 02-01-2003, 03:18 AM   #11
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
it doesn't work

always permission denied

I'm getting so much confused
 
Old 02-01-2003, 03:21 AM   #12
GJoz
Member
 
Registered: Jan 2003
Distribution: Redhat 9.0 Shrike
Posts: 37

Rep: Reputation: 15
hmmmmm
at startup,you are not logged in(when loading things)
you log in only after that
so it should work
it works for me,i tested it
 
Old 02-01-2003, 07:09 AM   #13
manub
Member
 
Registered: Jan 2003
Location: Naples, Italy
Distribution: Redhat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
sorry but I don't understand what you're talking about ... I've got graphical login ... and I think I'm always logging in after all has loaded
 
Old 02-01-2003, 07:11 AM   #14
GJoz
Member
 
Registered: Jan 2003
Distribution: Redhat 9.0 Shrike
Posts: 37

Rep: Reputation: 15
oh
if you use text loader,you can see the error,and if it works or not,....
cause you log in after things are loaded,so it should work
 
Old 02-01-2003, 11:08 AM   #15
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
Here is my fstab line for NTFS:
Code:
/dev/sda1   /win   ntfs   umask=007,gid=201,defaults   1  0
umask 007 means owner and group get rwx permission and everyone else gets no access. gid=201 sets the group owner to group 201 which isn't a pre defined group.

as root edit /etc/group and add this line, be VERY careful of mistyping:
Code:
lusers::201:myacct,myroomie,newdude
broken down this is:
*lusers = group name, use whatever you want
*TWO colons
*201 = group id, it doesn't have to be 201 but has to be the same as what you used for gid= in fstab. If 201 is taken, pick any number over 200 to be safe.
*ONE colon
*myacct,myroomie,newdude = list all users who you want to give access to in a comma seperated format with no spaces.

It works on my box.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
automount Solaris home directories onto RedHat ghouliajoolia Linux - General 3 09-07-2004 07:20 AM
Automount Network NTFS drive--Slackware a1flecke Linux - Newbie 2 05-03-2004 08:33 PM
Setting up Automount on Redhat 9 miqorz Red Hat 6 03-23-2004 07:24 PM
Redhat 9 CD Automount 1jamie Linux - Software 2 08-28-2003 03:20 PM
How to automount my C drive (FAT32) every time I login Redhat futurist Linux - General 2 03-17-2003 03:17 PM


All times are GMT -5. The time now is 10:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration