LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-06-2004, 08:13 AM   #1
Eradicator
Member
 
Registered: Sep 2003
Posts: 44

Rep: Reputation: 15
Automount in Suse 9.1


I am trying to get Suse to automount my F drive under windows. It is mounting all the other drives based on the initial configuration but for some reason it skipped this drive.

I added what I think I needed via the make directory command and then


but it will not automount. If I use this command under root privileges it will mount it:

mount /dev/hdb5 /mnt/hdb5

Here is the output of some appropriate items, sorry for the formatting problem:

I added the line for /dev/hdb5

========


> /dev/hdb3 / reiserfs acl,user_xattr
> 1 1
> /dev/hda1 /windows/C vfat
> users,gid=users,umask=0002,iocharset=utf8 0 0
> /dev/hda5 /windows/D ntfs
> ro,users,gid=users,umask=0002,nls=utf8 0 0
> /dev/hdb2 swap swap pri=42
>
> 0 0
> /dev/hdb5 /windows/F vfat
> defaults,gid=100,umask=000 0 0
> devpts /dev/pts devpts mode=0620,gid=5
>
> 0 0
> proc /proc proc defaults
>
> 0 0
> usbfs /proc/bus/usb usbfs noauto
>
> 0 0
> sysfs /sys sysfs noauto
>
> 0 0
> /dev/cdrecorder /media/cdrecorder subfs
> fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
> /dev/dvdrecorder /media/dvdrecorder subfs
> fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
> /dev/fd0 /media/floppy subfs
> fs=floppyfss,procuid,nodev,nosuid,sync 0 0
>
>
> ===============
>
> linux:/home/computer # fdisk -l
>
> Disk /dev/hda: 120.0 GB, 120034123776 bytes
> 255 heads, 63 sectors/track, 14593 cylinders Units = cylinders of
> 16065 * 512 = 8225280 bytes
>
> Device Boot Start End Blocks Id System
> /dev/hda1 * 1 3824 30716248+ c W95 FAT32
> (LBA)
> /dev/hda2 3825 14592 86493960 f W95 Ext'd
> (LBA)
> /dev/hda5 3825 14592 86493928+ 7 HPFS/NTFS
>
> Disk /dev/hdb: 40.9 GB, 40982151168 bytes
> 16 heads, 63 sectors/track, 79408 cylinders Units = cylinders of 1008
> * 512 = 516096 bytes
>
> Device Boot Start End Blocks Id System
> /dev/hdb1 39701 79385 20000925 f W95 Ext'd
> (LBA)
> /dev/hdb2 1 2049 1032664+ 82 Linux swap
> /dev/hdb3 2050 25001 11567808 83 Linux
> /dev/hdb5 39701 79385 20000893+ b W95 FAT32

>
> Partition table entries are not in disk order linux:/home/computer #

=================

What do you think I am doing wrong? I am new to linux but have considerable windows experience. I have 2 HDs, both split into two partitions. IDE0 (C) is windows (D) is NTFS for video editing, IDE1 had an E and F under windows, I delete E and used that space to instal Suse, F I left to share between Suse and windows.

Thanks for any sugestions.
 
Old 08-06-2004, 10:39 AM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,860

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
"I am trying to get Suse to automount my F drive under windows."

The file that describes what is to mounted at boot is /etc/fstab. You can mount /dev/hdb5 at boot by adding an entry to /etc/fstab.

-----------------------------
Steve Stites
 
Old 08-06-2004, 11:18 AM   #3
Eradicator
Member
 
Registered: Sep 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jailbait
"I am trying to get Suse to automount my F drive under windows."

The file that describes what is to mounted at boot is /etc/fstab. You can mount /dev/hdb5 at boot by adding an entry to /etc/fstab.

-----------------------------
Steve Stites
If you note my post the 1st file text I posted was from my fstab file and have the entry there but it does not seem to work.

This is the line I had added

/dev/hdb5 /windows/F vfat defaults,gid=100,umask=000 0 0

Anyone else?

Last edited by Eradicator; 08-06-2004 at 11:20 AM.
 
Old 08-06-2004, 06:00 PM   #4
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Rep: Reputation: 15
i had the same problem at one point.
heres what i used. it seems to work.
i noticed that the defaults option didn't work very well.

/dev/hda2 /windows/Z vfat gid=users,umask=000 0 0
 
Old 08-06-2004, 11:43 PM   #5
pablowablo
Member
 
Registered: Apr 2004
Posts: 131

Rep: Reputation: 15
What do you mean by auto mount? Do you mean mounting it during boot? or using autofs ? (autofs mounts the device whenever the device is requested, so not during boot)

If you want it to be mounted during boot then try this:

/dev/hdb5 /windows/F vfat auto,gid=100,umask=000 0 0
 
Old 08-09-2004, 09:10 PM   #6
Eradicator
Member
 
Registered: Sep 2003
Posts: 44

Original Poster
Rep: Reputation: 15
I mean I want the drive mounted so I can click on the desktop icon and be able to view it's contents. I tried both suggestion as far as editing the fstab file and neither works.

It tells me that only root can mount a device....I realize I can mount it as root but I want it to be mounted like all the other drives when I log into my KDE desktop.

Thanks
 
Old 08-11-2004, 04:54 AM   #7
Eradicator
Member
 
Registered: Sep 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Can anyone assist here? I will probably give up on Suse and go back to MDK since I never had this kind of issue with MDK. It just seems like there should be something more to do....It seems like a pretty simple thing I am trying to do but it does not work!!!!

I even checked the dev and mnt directories and they seem to be set up properly....I don't get it, if I use the SU command I can become root and then use the mount command from there and it will become visible but I can not get it to be that way at boot.....very frustrating because I never seem to have such problems with Windows....This should not be that big of a deal.....sorry for carrying on
 
Old 08-14-2004, 08:29 PM   #8
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Rep: Reputation: 15
are you actually changing the fstab? you must be root to change it. try using cp to make a copy to somewheere where you have permissons then cp it back as the root. then restart.
 
Old 08-14-2004, 08:34 PM   #9
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Rep: Reputation: 15
maybe also try changing the mtab
 
Old 08-16-2004, 09:21 AM   #10
Eradicator
Member
 
Registered: Sep 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by tardigrade
maybe also try changing the mtab
Thanks, I tried adding a line to mtab that was similar to the one that was already there for the C drive as that is Vfat as well but it still tells me it can not mount that drive when I get to the KDE desktop and try to click on the icon I created. I even tried creating a new icon but it states only root can mount....very annoying

and yes I changed it as root (fstab) suse lets you use conquerer as root and then I browsed to /etc and made the changes....and saved them, if I did not do it this way I would get an error telling me that I do not have auth to change the file

Last edited by Eradicator; 08-16-2004 at 09:30 AM.
 
Old 08-16-2004, 02:39 PM   #11
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Rep: Reputation: 15
im assuming what you entered in the mtab looked something like this. this is just what worked for me

/dev/hda2 /windows/Z vfat rw,gid=100,umask=000 0 0


and my fstab:
/dev/hda2 /windows/Z vfat gid=users,umask=000 0 0

hope you get this figured out!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Does SUSE automount CDROM like mandrake? TigerLinux SUSE / openSUSE 8 10-03-2005 12:53 AM
Config automount in Suse 9.3? songyizhe Linux - Software 0 09-09-2005 12:39 PM
[Suse 9.3] Automount cdrom/dvd failed PatrickV SUSE / openSUSE 1 04-19-2005 04:50 AM
disabling automount suse 9.1? cunokyle Linux - Distributions 0 06-10-2004 12:18 AM
automount floppy, suse 9.0 Horny Toad Linux - Newbie 3 04-22-2004 03:00 PM


All times are GMT -5. The time now is 02:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration