LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2002, 03:57 PM   #1
Donny
LQ Newbie
 
Registered: Oct 2002
Posts: 2

Rep: Reputation: 0
Auto suspend


My Linux system keeps restarting after it has been idle for a while and returns to the login screen. I tried to figure out why it restarts and tried to look everywhere for what is causing it.
I'm using Red Hat/Gnome.
The problem is that I want the jobs activated on the logged-in user to continue running forever.
(a) It is not a power failure as the computer is on a UPS and the UPS log shows that everything is okay.
(b) I looked for TMOUT set somewhere (/etc/profile, SET command) and it does not seem to be set.
(c) I looked in the /var/log/messages and I saw that the first message (when the system "disappeared" was "apm: busy: unable to enter requested state", after researching on that, I think that the system is suspending (?). Does Linux or Gnome automatically suspend when the system is idle? How do I stop that?

Completely lost,
Donny.
 
Old 10-12-2002, 09:53 PM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Some bios have a problem with suspend, maybe disable acpi in kernel or disable suspend in bios

see if SysRq+d causes a reboot
 
Old 10-13-2002, 05:32 AM   #3
Donny
LQ Newbie
 
Registered: Oct 2002
Posts: 2

Original Poster
Rep: Reputation: 0
How do I disable ACPI?

SysRq+d doesn't seem to do anything.

Thanks.
 
Old 10-13-2002, 05:50 AM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
It's in the kernel

you could try turning off apmd

run this command

/etc/rc.d/init.d/apmd stop


to make it stay off when you reboot do this
run this command

setup

then goto system services

and then deselect apmd

save and quit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ACPI & auto shutdown, suspend stevenhasty Slackware 1 12-16-2011 03:51 AM
How do I auto start modules that aren't auto loaded on boot? darkbluedrew Debian 2 09-18-2005 10:10 AM
eth0 Auto Connect, How to auto start on logon cornish Linux - Networking 2 05-09-2005 01:02 PM
auto-completion - how does it work & can my script args auto-complete? BrianK Programming 1 06-11-2004 05:51 PM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 01:26 PM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration