LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-27-2005, 09:55 AM   #1
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Rep: Reputation: 35
Auto mounting drives with write access at startup


Hello

I have just found out that although I can read all partitons, I can only write to the system part. Tried as root.

How can I tell it to mount all drives/parts with full read/write access on startup?

Thanks

Hong
 
Old 02-27-2005, 10:25 AM   #2
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
You need to set them as RW in fstab. For fat32 partitions (windows) you could add "umask=000" to the third column in fstab.
 
Old 02-27-2005, 10:36 AM   #3
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Here is my fstab file:

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hdb2 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hdc1 /mnt/hdc1 ntfs noauto,users,exec,ro,umask=000 0 0
# Added by KNOPPIX
/dev/hdd5 /mnt/hdd5 ntfs noauto,users,exec,ro,umask=000 0 0
# Added by KNOPPIX
/dev/hdb1 none swap defaults 0 0
# Added by KNOPPIX
/dev/hdb3 /mnt/hdb3 ext3 noauto,users,exec 0 0

I'm guessing I change it to:

# Added by KNOPPIX
/dev/hdc1 /mnt/hdc1 ntfs noauto,users,exec,rw,umask=000 0 0
# Added by KNOPPIX
/dev/hdd5 /mnt/hdd5 ntfs noauto,users,exec,rw,umask=000 0 0

Is that right? Also, what about the other 2 below it? I want everything writabel. How would I change those?

Thanks a lot

Hong
 
Old 02-27-2005, 10:52 AM   #4
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
Haven't tried in KNoppix, but this is my fstab entry for a windows partition:

/dev/hda1 /mnt/windows/c vfat defaults,umask=000 0 0

You don't want to write to swap, that's a 'memory' partition for the system.
 
Old 02-27-2005, 10:59 AM   #5
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
well hdc1 is my (ntfs) data partition, and so hdd5. hdb3 is (ext3) empty, but will store data.

hdb1 is my swap it seems.

so, is what i posted correct? out of curiousity, whats the syntax/switches for this?
 
Old 02-27-2005, 11:32 AM   #6
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
Looks OK.
I think you could substitute 'noauto,users,exec,rw' fro 'defaults'

As for the meaning of it all, the first column describes the 'real' location of a device according to the system, the second where it will be mounted. The third, the file system, the fourth mount option. The last has, if I remember correctly, something to do with integrity checks.

For more info on the mount options: man mount
 
Old 02-27-2005, 11:54 AM   #7
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Thanks. I'll post back if there is a problem but it looks simple enough.

Regards

Hong
 
Old 02-27-2005, 12:32 PM   #8
Gkarfield
Member
 
Registered: Jul 2004
Location: Greece
Distribution: FreeBSD 6.2/widows[not 8 legs nor black]
Posts: 123

Rep: Reputation: 15
hm,

can u write on an NTFS drive?

its safe? I don't know. just look for that.

u can add an option in 'mount'
uid=<username>
so that user owns that mount.


bye
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems auto-mounting usb drives in kernel 2.6.13.3 dizzi Slackware 8 10-29-2005 02:41 PM
Mounting fat32 drives with read/write access in Fedora a1ex_007 Red Hat 3 03-23-2005 01:38 PM
Mounting Hard drives at startup Marvel Fedora 4 11-29-2004 04:30 AM
Auto mounting Linux smb share on Windows at startup neranjana Linux - Networking 1 07-02-2004 07:56 PM
Auto-mounting drives at startup MandrakeDave Linux - General 7 09-29-2003 06:19 PM


All times are GMT -5. The time now is 05:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration