LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-30-2003, 09:37 PM   #1
xjphil
Member
 
Registered: Aug 2003
Location: Collierville, TN
Distribution: Red Hat 9.0
Posts: 58

Rep: Reputation: 15
authorization screw up


Ok I think I need help.

I mounted my NTFS Windows hard drive after much difficulty, and while still in root, since I thought I had to be, I copied all my documents over to my home dir.

Then I logged back in as me, and wasn't authorized for any of those files. So I went back in root, and chmod /home/phil to -R 777, hoping it would make all my files accessible. The book explained that this would make all the files from Phil on down accessible, which is what I want. But when I logged back in as phil, it completely bombed. It has a bunch of error X's but no words. I think it even loaded the other (KDE) desktop. There was no bar at the bottom of the screen, it was way screwed up. I haven't tried another user, but I think it will work, just phil is screwed up!

How do I fix this, is there an undo? or a reset to default?

Also I have 2 hard disks , NTFS Win XP and the new on I installed RH9 on. I have the tray to remove the Primary Master Linux drive, and the primary slave is windows. I unplugged the windows completely during the RH 9 install, cuz I didn't trust myself. I ran linux fine for a while, then I went back into windows by rebooting and pulling my linux drive out. When I tried to power off, then on with linux back in, it boots Windows. I heard about windows erasing the MBR, is that what happened? How can I fix it so I don't have to open my computer each time I want to switch, and still be able to copy files between systems?

I thought I had it all set up.

thanks for any help.

phil
 
Old 08-30-2003, 10:20 PM   #2
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi

you need to swap drives at all everytime. if you installl windows first and linux next everything will work just fine unless you reinstall windows again. get a boot disk ( toms boot disk is nice) and boot into the system and check whethe u screwed anything.

you shouldnt run the system as root.

ntfs support for read is reliable. writing is not. use fat 32 or fat partitions for sharing data

regards
rahul sundaram
 
Old 08-30-2003, 10:28 PM   #3
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
I think you've got more problems than file permissions. I don't know of much that will bomb because you gave it full access permission. What kind of errors are you getting? You should definitely try another user to make sure it's not a system wide problem.

If you can't get your phil user fixed, you can store off your data into another directory for backup. Then you can delete the user and the home directory, then readd it. Should be like doing a complete reset.

As far as your booting problem, if you can slave the drives together in your machine, you can set up grub, or bootmagic to give you the choice of which operating system to boot into.

Good Luck,
Doug
 
Old 08-30-2003, 10:44 PM   #4
xjphil
Member
 
Registered: Aug 2003
Location: Collierville, TN
Distribution: Red Hat 9.0
Posts: 58

Original Poster
Rep: Reputation: 15
thanks for the quick reply

as far as the booting windows, I didn't "re-install" windows, but somehow it has taken over. When I installed linux, the win drive was physically disconnected from the computer, and when I plugged it back in after installation, it booted up fine, just after I logged back into windows, and then tried again.

As far as what error messages I am getting, I know they are there, but I can't read any of them, no text, just big red X's that look bad.

ill try the boot disk, the one i created failed just now, so Ill just disconnect the drive again.

thanks again,

phil
 
Old 08-30-2003, 10:58 PM   #5
xjphil
Member
 
Registered: Aug 2003
Location: Collierville, TN
Distribution: Red Hat 9.0
Posts: 58

Original Poster
Rep: Reputation: 15
well the copying files / deleting user / reinstalling user worked like a charm, and all the files are accessible. Thank you, now to work on the MBR!!
 
Old 08-30-2003, 11:39 PM   #6
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
which drive is master?

Which drive do you have set as master?

If you have your windows drive as master, you'll need to install a boot manager like bootmagic to boot the second disk. If your linux drive is your master you should be able to add a line to the /boot/grub/grub.conf file.

Gizmo
 
Old 08-31-2003, 12:34 AM   #7
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
ya

check the grub.conf file and add the necessary option. read man grub.conf for more info or search in google.

run grub-install after that to recover your mbr options


regards
rahul sundaram
 
Old 08-31-2003, 10:13 AM   #8
xjphil
Member
 
Registered: Aug 2003
Location: Collierville, TN
Distribution: Red Hat 9.0
Posts: 58

Original Poster
Rep: Reputation: 15
The linux drive is master, and the windows is slave, and ill try that, I just don't understand why it was changed.

phil
 
Old 08-31-2003, 10:28 AM   #9
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
I think nothing changed.

I think you'll find that the windows drive had the windows loader in its master boot record, and the linux drive has a linux boot loader(Lilo or Grub) in its MBR.
Because you'd only used either OS at once, connected as the primary master disk, they had their boot loader used, as they were in the MBR.

Now you have both drives in, you need to overwrite the windows loader with the linux one, so you have the options of linux or windows when booting the window drive, and thus the windows MBR in this case. The windows loader cant load linux.

Last edited by Proud; 08-31-2003 at 10:34 AM.
 
Old 08-31-2003, 12:08 PM   #10
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
xiphil,

the reason everything is changed is because you installed linux without the system being able to detect the windows installation on the other drive. That's ok, because it's reparable. In your /boot/grub/grub.conf file there are entries which tell the OS how to boot the system, and the physical hard-drive locations needed to boot. My system has the following entry detailing how to boot MS Windows XP:

title XP
rootnoverify (hd0,0)
chainloader +1
You should be able to add a similar line in your grub.conf file like so:

title XP
rootnoverify (hd1,0)
chainloader +1

provided hd1 is the hard drive where windows is loaded. running grub-install with the drives in place should complete the process.
 
Old 08-31-2003, 04:08 PM   #11
xjphil
Member
 
Registered: Aug 2003
Location: Collierville, TN
Distribution: Red Hat 9.0
Posts: 58

Original Poster
Rep: Reputation: 15
ok, that is what i thought happened, the linux system doesn't know the xp is there in the grub thing.

so one question:

you said provided hd 1 is where windows is loaded... I haven't looked at grub to see if it classifies hd's differently, but the dev for my windows drive is dev/hdb2... same thing or different?

so to get it right the first time what should i put in the grub.conf file?

dev/hda1,2,3= linux
dev/hdb1 = some mystical windows partition for system restore that is not accessable
dev/hdb2 = xp

linux drive is primary master, and removable (easily)
xp drive is primary slave, and hard as crap to remove.

It looks like the easiest thing would be to just put the xp drive in the removable tray, since the tray is hot swappable.

maybe ill do that.

thanks again,

phil

Last edited by xjphil; 08-31-2003 at 06:24 PM.
 
Old 08-31-2003, 05:42 PM   #12
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
The best way is always: Windows first primary, linux secondary, linux boot loader in the primary's MBR.

I've only used Lilo, not Grub, sorry. Seach here and the web.
 
Old 08-31-2003, 06:38 PM   #13
gizmogadgetus
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Fedora Core 2
Posts: 71

Rep: Reputation: 15
I think hd1 will work given the description you've put here. Give it a try and see what happens.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Authorization inescapeableus Linux - Networking 10 08-05-2005 02:35 PM
help in user authorization Rex_chaos Programming 2 10-04-2004 04:03 PM
Apache authorization Sherpa Linux - Software 4 04-25-2004 11:38 AM
authorization varunk123456 Linux - Newbie 2 03-31-2004 03:44 PM
Authorization Failed Poskus Fedora 1 02-23-2004 09:08 AM


All times are GMT -5. The time now is 05:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration