LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2015, 05:01 AM   #1
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Rep: Reputation: Disabled
Authentication errors (publickey,gssapi-with-mic,password)


Hi guys,
I have a problem using scp within following verbose statements:

debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Offering public key: /root/.ssh/id_rsa
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Next authentication method: password
user@remote_machine1IP's password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
debug1: Sending command: scp -v httpd_ip_change2.conf. user2@remote_machine2IP:/usr/local/apache/conf
Executing: program /usr/bin/ssh host remote_machine2IP, user user2, command scp -v -t /usr/local/apache/conf
OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Applying options for *
debug1: Connecting to remote_machine2IP [remote_machine2IP] port 44.
debug1: Connection established.
debug1: identity file /home/user1/.ssh/identity type -1
debug1: identity file /home/user1/.ssh/id_rsa type 1
debug1: identity file /home/user1/.ssh/id_dsa type -1
debug1: loaded 3 keys
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'remote_machine2IP' is known and matches the RSA host key.
debug1: Found key in /home/user1/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received


debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/user1/.ssh/identity
debug1: Offering public key: /home/user1/.ssh/id_rsa
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Trying private key: /home/user1/.ssh/id_dsa
debug1: Next authentication method: password
debug1: read_passphrase: can't open /dev/tty: No such device or address
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
Permission denied, please try again.
debug1: read_passphrase: can't open /dev/tty: No such device or address
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
Permission denied, please try again.
debug1: read_passphrase: can't open /dev/tty: No such device or address
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: No more authentication methods to try.
Permission denied (publickey,gssapi-with-mic,password).
lost connection
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
debug1: Transferred: stdin 0, stdout 0, stderr 0 bytes in 0.1 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.0
debug1: Exit status 1

I have been trying to copy files between two remote machines. (RHEL 5.7 on Windows by Mremote).

Thank you !

Last edited by Revenge7; 04-09-2015 at 09:04 AM.
 
Old 04-09-2015, 08:28 AM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Are you trying to copy files between Linux servers or you are trying to copy files from Windows to Linux using WinSCP or something. Which user you are using to for scp. Is it root user? If it is root user then is PermitRootLogin enabled in sshd_config. By default it is set to yes but if it is set to without-password and if your ssh key fails then it won't even prompt to enter password.
 
Old 04-09-2015, 08:34 AM   #3
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
Are you trying to copy files between Linux servers or you are trying to copy files from Windows to Linux using WinSCP or something. Which user you are using to for scp. Is it root user? If it is root user then is PermitRootLogin enabled in sshd_config. By default it is set to yes but if it is set to without-password and if your ssh key fails then it won't even prompt to enter password.
I am trying to copy files between Linux Servers. user1 is sender, and user2 is receiver. scp command is a part of bash shell script, in order to execute it, I am using root, but neither user1 nor user2 is root. PermitRootLogin is stated as no, but changing it to yes does not solve anything.
 
Old 04-09-2015, 08:38 AM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
PermitRootLogin is only applicable when you are using root user to copy otherwise it is irrelevant as in this case. Did you check the permissions of .ssh and authorized_keys files on source and destination. Permission for .ssh directory under /home/user1 should be set to 700 and /home/user1/.ssh/authorized_keys should be set to 600.

Was it working before. What were the recent changes that were made to the systems.
 
Old 04-09-2015, 08:46 AM   #5
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
PermitRootLogin is only applicable when you are using root user to copy otherwise it is irrelevant as in this case. Did you check the permissions of .ssh and authorized_keys files on source and destination. Permission for .ssh directory under /home/user1 should be set to 700 and /home/user1/.ssh/authorized_keys should be set to 600.

Was it working before. What were the recent changes that were made to the systems.
I checked it, .ssh directory's permissions are both 700, and authorized_keys's are 644.I do not know it is working before or not. But, both username and passwords are correct.
 
Old 04-09-2015, 08:49 AM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Are you using keybased authentication or password authentication. If key based authentication then authorized_key file should have permission 600 not 644. Do you get option to put in the password? If yes, then after entering the password it gets terminated?
 
Old 04-09-2015, 09:03 AM   #7
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
Are you using keybased authentication or password authentication. If key based authentication then authorized_key file should have permission 600 not 644. Do you get option to put in the password? If yes, then after entering the password it gets terminated?
Both authentication methods are used. I changed the permission to 600, again there is no difference.

debug1: read_passphrase: can't open /dev/tty: No such device or address
Host key verification failed.
lost connection

Above log part is the problem. I do not get any option for putting into the password (By the way there is directory on both sides called /dev/tty).
 
Old 04-09-2015, 09:08 AM   #8
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Share the output of the following:

1. Command that you are using to copy files.
2. Output of: ls -al /dev/tty
3. Output of: ls -al /home/user1/.ssh from both servers. If on other server user name is user2 then just replace user1 with user2 in the command.
 
Old 04-09-2015, 09:24 AM   #9
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
Share the output of the following:

1. Command that you are using to copy files.
2. Output of: ls -al /dev/tty
3. Output of: ls -al /home/user1/.ssh from both servers. If on other server user name is user2 then just replace user1 with user2 in the command.
1. scp -vvv -P 44 user1@remote_machine1IP:"filename" user2@remote_machine2IP:/usr/local/apache/conf (port 44 is used, not 22).

2. crw-rw-rw- 1 root tty 5, 0 Apr 9 16:14 /dev/tty

3. For user1,

total 28
drwx------ 2 user1 admins 4096 Apr 6 15:20 .
drwx------ 4 user1 admins 4096 Mar 31 16:37 ..
-rw-r--r-- 1 user1 admins 394 Apr 9 16:13 authorized_keys2
-rw------- 1 root root 1743 Apr 6 16:41 id_rsa
-rw-r--r-- 1 root root 392 Apr 6 16:41 id_rsa.pub
-rw-r--r-- 1 user1 admins 393 Apr 6 15:37 known_hosts

user2,

total 28
drwx------ 2 user2 admins 4096 Apr 6 15:18 .
drwx------ 5 user2 admins 4096 Mar 27 17:14 ..
-rw-r--r-- 1 user2 admins 393 Apr 9 16:13 authorized_keys2
-rw------- 1 user2 admins 1743 Apr 6 15:18 id_rsa
-rw-r--r-- 1 user2 admins 401 Apr 6 15:18 id_rsa.pub
-rw-r--r-- 1 user2 admins 786 Apr 2 10:15 known_hosts
 
Old 04-09-2015, 09:38 AM   #10
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Try this:

Code:
scp -vvv -P 44 -i /home/user1/.ssh/id_rsa user1@remote_machine1IP:"filename" user2@remote_machine2IP:/usr/local/apache/conf
If that also doesn't work then check PasswordAuthentication parameter in /etc/ssh/sshd_config should be set to yes. If possible share sshd_config from destination. Also share the output of ls -al /dev/tty from other server (you have shared from only one server).
 
Old 04-09-2015, 10:00 AM   #11
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
Try this:

Code:
scp -vvv -P 44 -i /home/user1/.ssh/id_rsa user1@remote_machine1IP:"filename" user2@remote_machine2IP:/usr/local/apache/conf
If that also doesn't work then check PasswordAuthentication parameter in /etc/ssh/sshd_config should be set to yes. If possible share sshd_config from destination. Also share the output of ls -al /dev/tty from other server (you have shared from only one server).
crw-rw-rw- 1 root tty 5, 0 Apr 6 15:21 /dev/tty (for user2)

PasswordAuthentication parameter is set to yes.

user2 sshd_config file:

Port 44
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# Disable legacy (protocol version 1) support in the server for new
# installations. In future the default will change to require explicit
# activation of protocol 1
Protocol 2

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 1024

# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

RSAAuthentication yes
#PubkeyAuthentication yes
AuthorizedKeysFile .ssh/authorized_keys
#AuthorizedKeysCommand none
#AuthorizedKeysCommandRunAs nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
#PermitEmptyPasswords no
#PasswordAuthentication yes

#ChallengeResponseAuthentication yes
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no
#KerberosUseKuserok yes

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication. Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
#UsePAM no
UsePAM yes

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL LANGUAGE
AcceptEnv XMODIFIERS

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ShowPatchLevel no
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10
#PermitTunnel no
#ChrootDirectory none


# override default of no subsystems
Subsystem sftp /usr/libexec/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
# X11Forwarding no
# AllowTcpForwarding no
# ForceCommand cvs server

AllowGroups admins sshgroup

PermitRootLogin no

MaxAuthTries 4

ClientAliveInterval 900
ClientAliveCountMax 0

X11Forwarding yes

IgnoreRhosts yes
HostbasedAuthentication no

PermitEmptyPasswords no

PermitUserEnvironment no

# no default banner path
#Banner none
Banner /etc/issue.net
X11Forwarding no
LogLevel INFO
 
Old 04-09-2015, 10:09 AM   #12
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
I am bit confused here, I just realized that you are executing this command from a remote location. The reason I am saying so because both user1 and user2 are on the same command line and it is in bit confusing format. If you are trying to copy file from server1 to server2, remotely shouldn't the command look like:

Code:
ssh -i /home/user1/.ssh/id_rsa user1@remote_machine1IP 'scp /full_path/"filename" user2@remote_machine2IP:/usr/local/apache/conf'
You can put port numbers accordingly. I have also noticed that on destination server PubKeyAuthentication is commented out.
 
Old 04-09-2015, 10:13 AM   #13
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by T3RM1NVT0R View Post
I am bit confused here, I just realized that you are executing this command from a remote location. The reason I am saying so because both user1 and user2 are on the same command line and it is in bit confusing format. If you are trying to copy file from server1 to server2, remotely shouldn't the command look like:

Code:
ssh -i /home/user1/.ssh/id_rsa user1@remote_machine1IP 'scp /full_path/"filename" user2@remote_machine2IP:/usr/local/apache/conf'
You can put port numbers accordingly. I have also noticed that on destination server PubKeyAuthentication is commented out.
When I run this command, the output is

debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug3: start over, passed a different list publickey,gssapi-with-mic,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /home/user1/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
user1@remote_machine1IP's password:
debug3: packet_send2: adding 48 (len 64 padlen 16 extra_pad 64)
debug2: we sent a password packet, wait for reply
debug1: Authentication succeeded (password).
debug2: fd 4 setting O_NONBLOCK
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: client_session2_setup: id 0
debug1: Sending environment.
debug3: Ignored env HOSTNAME
debug3: Ignored env TERM
debug3: Ignored env SHELL
debug3: Ignored env HISTSIZE
debug3: Ignored env USER
debug3: Ignored env LS_COLORS
debug3: Ignored env PATH
debug3: Ignored env MAIL
debug3: Ignored env PWD
debug3: Ignored env INPUTRC
debug3: Ignored env JAVA_HOME
debug1: Sending env LANG = en_US.UTF-8
debug2: channel 0: request env confirm 0
debug3: Ignored env HOME
debug3: Ignored env SHLVL
debug3: Ignored env LOGNAME
debug3: Ignored env LESSOPEN
debug3: Ignored env DISPLAY
debug3: Ignored env G_BROKEN_FILENAMES
debug3: Ignored env HISTTIMEFORMAT
debug3: Ignored env _
debug1: Sending command: scp /usr/local/apache/conf/"ip.txt" e_kirtiloglu@10.11.92.94:/usr/local/apache/conf
debug2: channel 0: request exec confirm 0
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel 0: rcvd adjust 2097152
debug2: channel 0: read<=0 rfd 4 len 0
debug2: channel 0: read failed
debug2: channel 0: close_read
debug2: channel 0: input open -> drain
debug2: channel 0: ibuf empty
debug2: channel 0: send eof
debug2: channel 0: input drain -> closed
debug2: channel 0: rcvd ext data 3226

debug2: channel 0: written 3226 to efd 6
debug2: channel 0: rcvd ext data 38
debug2: channel 0: rcvd ext data 38
debug2: channel 0: rcvd ext data 57
debug2: channel 0: rcvd ext data 16
debug2: channel 0: rcvd eof
debug2: channel 0: output open -> drain
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug2: channel 0: rcvd close
debug3: channel 0: will not send data after close
debug2: channel 0: obuf_empty delayed efd 6/(149)
Permission denied, please try again.
Permission denied, please try again.
Permission denied (publickey,gssapi-with-mic,password).
lost connection
debug2: channel 0: written 149 to efd 6
debug3: channel 0: will not send data after close
debug2: channel 0: obuf empty
debug2: channel 0: close_write
debug2: channel 0: output drain -> closed
debug2: channel 0: almost dead
debug2: channel 0: gc: notify user
debug2: channel 0: gc: user detached
debug2: channel 0: send close
debug2: channel 0: is dead
debug2: channel 0: garbage collecting
debug1: channel 0: free: client-session, nchannels 1
debug3: channel 0: status: The following connections are open:
#0 client-session (t4 r0 i3/0 o3/0 fd -1/-1 cfd -1)

debug3: channel 0: close_fds r -1 w -1 e 6 c -1
debug1: fd 0 clearing O_NONBLOCK
debug1: Transferred: stdin 0, stdout 0, stderr 0 bytes in 0.2 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.0
debug1: Exit status 1

Last edited by Revenge7; 04-13-2015 at 07:07 AM.
 
Old 04-14-2015, 02:49 AM   #14
Revenge7
Member
 
Registered: Mar 2015
Posts: 38

Original Poster
Rep: Reputation: Disabled
Smile

I wrote it as

scp -r -vvv -P 44 user1@remote_machineIP1:/usr/local/apache/conf/"$NAME$i.$EXTENSION.$(date +%F_%R)"
user2@remote_machineIP2:/usr/local/apache/conf

and it worked. Thanks for your interest.
 
1 members found this post helpful.
Old 04-14-2015, 05:41 AM   #15
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Thanks for sharing how it worked for you and marking the thread as solved.

Enjoy Linux!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission denied (publickey,gssapi-with-mic,password). sandeep002gupta Linux - Server 2 10-30-2014 09:38 AM
[SOLVED] ssh problem. (Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).) Satyaveer Arya Linux - Networking 4 10-19-2013 04:43 PM
Permission denied (publickey, gssapi-keyex,gssapi-with-mic,password) Huaqing Wang Linux - Newbie 1 06-27-2012 08:51 PM
Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password,keyboard-inte ract MilanK Linux - Newbie 1 03-20-2012 04:44 AM
Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password) scman64 Linux - Newbie 1 12-13-2011 01:20 AM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration