LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-21-2003, 06:53 PM   #31
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15

Well, I switched over to RH 9.0 now - my friend had actually bought a box so I thought I would give it a try over my downloaded / burned cds.... I like it a lot more than mdk so far.

running the newest kernel on it rh and instead of getting the old errors when trying to install it, I get "error 2" Ill try to post a log in a few once my class gets let out. Maybe it will give you some more insight into what my problem is ( if your still willing to help )




-Michael

 
Old 07-21-2003, 09:55 PM   #32
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
[root@***** aureal]# make install10
make install AUCHIP=AU8810
make[1]: Entering directory `/home/*******/aureal'
cc -D__KERNEL__ -DMODULE -DAU8810 -mpentium -O6 -fomit-frame-pointer -Wall -pipe -I/usr/src/linux/include -c -o au_audio.o au_audio.c
`-mpentium' is deprecated. Use `-march=pentium' or `-mcpu=pentium' instead.
In file included from au_vortex.h:50,
from au_audio.c:49:
/usr/include/linux/autoconf.h:1:2: #error Invalid kernel header included in userspace
In file included from au_vortex.h:61,
from au_audio.c:49:
/usr/include/linux/string.h:8:2: warning: #warning Using kernel header in userland!
In file included from /usr/include/linux/sched.h:14,
from au_vortex.h:63,
from au_audio.c:49:
/usr/include/linux/timex.h:173: field `time' has incomplete type
In file included from /usr/include/linux/bitops.h:69,
from /usr/include/asm/system.h:7,
from /usr/include/linux/sched.h:16,
from au_vortex.h:63,
from au_audio.c:49:
/usr/include/asm/bitops.h:327:2: warning: #warning This includefile is not available on all architectures.
/usr/include/asm/bitops.h:328:2: warning: #warning Using kernel headers in userspace: atomicity not guaranteed
In file included from /usr/include/linux/signal.h:4,
from /usr/include/linux/sched.h:25,
from au_vortex.h:63,
from au_audio.c:49:
/usr/include/asm/signal.h:107: parse error before "sigset_t"
/usr/include/asm/signal.h:110: parse error before '}' token
In file included from /usr/include/linux/sched.h:81,
from au_vortex.h:63,
from au_audio.c:49:
/usr/include/linux/timer.h:45: parse error before "spinlock_t"
/usr/include/linux/timer.h:53: parse error before '}' token
/usr/include/linux/timer.h:67: parse error before "tvec_base_t"
/usr/include/linux/timer.h:101: parse error before "tvec_bases"
/usr/include/linux/timer.h: In function `init_timer':
/usr/include/linux/timer.h:105: dereferencing pointer to incomplete type
/usr/include/linux/timer.h:105: dereferencing pointer to incomplete type
/usr/include/linux/timer.h:106: dereferencing pointer to incomplete type
/usr/include/linux/timer.h: In function `timer_pending':
/usr/include/linux/timer.h:121: dereferencing pointer to incomplete type
In file included from au_vortex.h:64,
from au_audio.c:49:
/usr/include/linux/delay.h:13:23: asm/delay.h: No such file or directory
In file included from au_vortex.h:66,
from au_audio.c:49:
/usr/include/linux/malloc.h:3:2: warning: #warning The Use of linux/malloc.h is
deprecated, use linux/slab.h
In file included from au_audio.c:49:
au_vortex.h:71:25: asm/uaccess.h: No such file or directory
In file included from au_audio.c:49:
au_vortex.h: At top level:
au_vortex.h:147: parse error before "wait_queue_head_t"
au_vortex.h:147: warning: no semicolon at end of struct or union
au_vortex.h:164: parse error before ':' token
au_vortex.h:165: parse error before ':' token
au_vortex.h:166: parse error before ':' token
au_vortex.h:167: parse error before ':' token
au_vortex.h:168: warning: type defaults to `int' in declaration of `wave_stream_t'
au_vortex.h:168: warning: data definition has no type or storage class
au_vortex.h:178: parse error before "wave_stream_t"
au_vortex.h:178: warning: no semicolon at end of struct or union
au_vortex.h:179: warning: type defaults to `int' in declaration of `record_stream'
au_vortex.h:179: warning: data definition has no type or storage class
au_vortex.h:180: warning: type defaults to `int' in declaration of `wave_device_t'
au_vortex.h:180: warning: data definition has no type or storage class
au_vortex.h:198: parse error before "wait_queue_head_t"
au_vortex.h:198: warning: no semicolon at end of struct or union
au_vortex.h:199: warning: type defaults to `int' in declaration of `owait'
au_vortex.h:199: warning: data definition has no type or storage class
au_vortex.h:206: parse error before '}' token
au_vortex.h:206: warning: type defaults to `int' in declaration of `midi_device_t'
au_vortex.h:206: warning: data definition has no type or storage class
au_vortex.h:225: parse error before "spinlock_t"
au_vortex.h:225: warning: no semicolon at end of struct or union
au_vortex.h:226: warning: type defaults to `int' in declaration of `wave_head'
au_vortex.h:226: warning: data definition has no type or storage class
au_vortex.h:227: parse error before '*' token
au_vortex.h:227: warning: type defaults to `int' in declaration of `wave_tail'
au_vortex.h:227: warning: data definition has no type or storage class
au_vortex.h:228: parse error before "midi"
au_vortex.h:228: warning: type defaults to `int' in declaration of `midi'
au_vortex.h:228: warning: data definition has no type or storage class
au_vortex.h:229: parse error before ':' token
au_vortex.h:230: parse error before ':' token
au_vortex.h:231: parse error before ':' token
au_vortex.h:232: warning: type defaults to `int' in declaration of `au_device_t'au_vortex.h:232: warning: data definition has no type or storage class
au_vortex.h:253: parse error before '*' token
au_vortex.h:254: parse error before '*' token
au_vortex.h:255: parse error before '*' token
au_vortex.h:256: parse error before '*' token
au_vortex.h:257: parse error before '*' token
au_vortex.h:261: parse error before '*' token
au_vortex.h:262: parse error before '*' token
au_vortex.h:263: parse error before '*' token
au_vortex.h:267: parse error before '*' token
au_vortex.h:268: parse error before '*' token
au_vortex.h:269: warning: `struct inode' declared inside parameter list
au_vortex.h:273: parse error before '*' token
au_vortex.h:274: parse error before '*' token
au_vortex.h:278: parse error before '*' token
au_vortex.h:278: warning: type defaults to `int' in declaration of `dev_head'
au_vortex.h:278: warning: data definition has no type or storage class
au_vortex.h:279: parse error before '*' token
au_vortex.h:279: warning: type defaults to `int' in declaration of `dev_tail'
au_vortex.h:279: warning: data definition has no type or storage class
au_vortex.h:282: parse error before '*' token
au_vortex.h:282: warning: type defaults to `int' in declaration of `find_device'au_vortex.h:282: warning: data definition has no type or storage class
au_vortex.h:283: parse error before '*' token
au_vortex.h:283: warning: type defaults to `int' in declaration of `find_device_by_pcidev'
au_vortex.h:283: warning: data definition has no type or storage class
au_vortex.h:284: parse error before '*' token
au_vortex.h:285: parse error before '*' token
au_vortex.h:392: parse error before "au_device_t"
au_audio.c:55: warning: `struct inode' declared inside parameter list
au_audio.c:56: warning: `struct vm_area_struct' declared inside parameter list
au_audio.c:57: warning: `struct inode' declared inside parameter list
au_audio.c:58: warning: `struct inode' declared inside parameter list
au_audio.c:59: parse error before '*' token
au_audio.c:64: variable `audio_fops' has initializer but incomplete type
au_audio.c:66: unknown field `owner' specified in initializer
au_audio.c:66: warning: excess elements in struct initializer
au_audio.c:66: warning: (near initialization for `audio_fops')
au_audio.c:67: unknown field `llseek' specified in initializer
au_audio.c:67: warning: excess elements in struct initializer
au_audio.c:67: warning: (near initialization for `audio_fops')
au_audio.c:68: unknown field `read' specified in initializer
au_audio.c:68: warning: excess elements in struct initializer
au_audio.c:68: warning: (near initialization for `audio_fops')
au_audio.c:69: unknown field `write' specified in initializer
au_audio.c:69: warning: excess elements in struct initializer
au_audio.c:69: warning: (near initialization for `audio_fops')
au_audio.c:70: unknown field `poll' specified in initializer
au_audio.c:70: warning: excess elements in struct initializer
au_audio.c:70: warning: (near initialization for `audio_fops')
au_audio.c:71: unknown field `ioctl' specified in initializer
au_audio.c:71: warning: excess elements in struct initializer
au_audio.c:71: warning: (near initialization for `audio_fops')
au_audio.c:72: unknown field `mmap' specified in initializer
au_audio.c:72: warning: excess elements in struct initializer
au_audio.c:72: warning: (near initialization for `audio_fops')
au_audio.c:73: unknown field `open' specified in initializer
au_audio.c:73: warning: excess elements in struct initializer
au_audio.c:73: warning: (near initialization for `audio_fops')
au_audio.c:74: unknown field `release' specified in initializer
au_audio.c:74: warning: excess elements in struct initializer
au_audio.c:74: warning: (near initialization for `audio_fops')
au_audio.c:96: parse error before '*' token
au_audio.c:97: parse error before '*' token
au_audio.c:98: parse error before '*' token
au_audio.c:99: parse error before '*' token
au_audio.c:99: parse error before '*' token
au_audio.c:99: warning: type defaults to `int' in declaration of `find_wave_device'
au_audio.c:99: warning: data definition has no type or storage class
au_audio.c:100: parse error before '*' token
au_audio.c:101: parse error before '*' token
au_audio.c:102: parse error before '*' token
au_audio.c:103: parse error before '*' token
au_audio.c:104: parse error before '*' token
au_audio.c:105: parse error before '*' token
au_audio.c:106: parse error before '*' token
au_audio.c:113: parse error before '*' token
au_audio.c: In function `au_dsp_register':
au_audio.c:119: `dev' undeclared (first use in this function)
au_audio.c:119: (Each undeclared identifier is reported only once
au_audio.c:119: for each function it appears in.)
au_audio.c:119: warning: passing arg 1 of `register_sound_dsp' from incompatible pointer type
au_audio.c: At top level:
au_audio.c:123: parse error before '*' token
au_audio.c: In function `au_dsp_unregister':
au_audio.c:126: `dev' undeclared (first use in this function)
au_audio.c: At top level:
au_audio.c:130: parse error before '*' token
au_audio.c: In function `au_audio_register':
au_audio.c:136: `dev' undeclared (first use in this function)
au_audio.c:136: warning: passing arg 1 of `register_sound_special' from incompatible pointer type
au_audio.c: At top level:
au_audio.c:140: parse error before '*' token
au_audio.c: In function `au_audio_unregister':
au_audio.c:142: `dev' undeclared (first use in this function)
au_audio.c: In function `au_audio_read':
au_audio.c:148: `dev' undeclared (first use in this function)
au_audio.c:148: dereferencing pointer to incomplete type
au_audio.c:149: `wdev' undeclared (first use in this function)
au_audio.c:150: `stream' undeclared (first use in this function)
au_audio.c:158: warning: implicit declaration of function `printk'
au_audio.c:158: `KERN_WARNING' undeclared (first use in this function)
au_audio.c:158: parse error before string constant
au_audio.c:159: `ENXIO' undeclared (first use in this function)
au_audio.c:163: dereferencing pointer to incomplete type
au_audio.c:164: `ESPIPE' undeclared (first use in this function)
au_audio.c:167: warning: implicit declaration of function `access_ok'
au_audio.c:167: `VERIFY_WRITE' undeclared (first use in this function)
au_audio.c:168: `EFAULT' undeclared (first use in this function)
au_audio.c:184: warning: implicit declaration of function `spin_lock_irqsave'
au_audio.c:187: warning: implicit declaration of function `spin_unlock_irqrestore'
au_audio.c:191: dereferencing pointer to incomplete type
au_audio.c:191: `O_NONBLOCK' undeclared (first use in this function)
au_audio.c:192: `EAGAIN' undeclared (first use in this function)
au_audio.c:193: warning: implicit declaration of function `interruptible_sleep_on'
au_audio.c:194: warning: implicit declaration of function `signal_pending'
au_audio.c:194: `current' undeclared (first use in this function)
au_audio.c:195: `ERESTARTSYS' undeclared (first use in this function)
au_audio.c: In function `au_audio_write':
au_audio.c:203: `dev' undeclared (first use in this function)
au_audio.c:203: dereferencing pointer to incomplete type
au_audio.c:204: `wdev' undeclared (first use in this function)
au_audio.c:205: `stream' undeclared (first use in this function)
au_audio.c:212: `KERN_WARNING' undeclared (first use in this function)
au_audio.c:212: parse error before string constant
au_audio.c:213: `ENXIO' undeclared (first use in this function)
----------------------------------------------------------------Further down...

au_audio.c:1061: `stream' undeclared (first use in this function)
au_audio.c:1067: `size' undeclared (first use in this function)
au_audio.c:1070: warning: implicit declaration of function `copy_from_user'
au_audio.c:1070: `mem' undeclared (first use in this function)
au_audio.c:1083: `dev' undeclared (first use in this function)
au_audio.c: At top level:
au_audio.c:1105: parse error before '*' token
au_audio.c: In function `au_handle_timer':
au_audio.c:1107: `wdev' undeclared (first use in this function)
au_audio.c:1107: `dev' undeclared (first use in this function)
au_audio.c:1108: `stream' undeclared (first use in this function)
au_audio.c:1121: warning: implicit declaration of function `wake_up_interruptible'
au_audio.c: At top level:
au_audio.c:64: storage size of `audio_fops' isn't known
make[1]: *** [au_audio.o] Error 1
make[1]: Leaving directory `/home/*******/aureal'
make: *** [install10] Error 2


maybe this will help?

-Michael

 
Old 07-21-2003, 11:25 PM   #33
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
try this

http://rpmfind.net//linux/RPM/PLD/di...25_2.i686.html
 
Old 07-22-2003, 09:05 AM   #34
joesbox
Member
 
Registered: Feb 2003
Location: hampton va
Distribution: ubuntu
Posts: 502

Rep: Reputation: 30
good find David.
i didn't even know that there was an rpm out there. i was under the impression that this project was dead, but according to the build date it is still on going (in the rpm field al least).
 
Old 07-22-2003, 11:27 AM   #35
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Ok, I got the file and opened it as root. Then I guess it installed itself but still no sound.
 
Old 07-22-2003, 04:06 PM   #36
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
try running this now

redhat-config-soundcard

and check your volume controls, basically if you have volume controls you should have sound in most cases.


If there is anything else plugged in that might cause a conflict unplug it. I have seen devices on the com port or usb kill sound before.


you could also try to run this

kudzu
 
Old 07-22-2003, 10:55 PM   #37
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
I have everything unplugged except monitor, power supply, modem, mouse/keyboard, and sound.

When I typed that command into consol it said that there were no sound cards found and when I went into volume control I got this error pop-up.

"Volume control is unable to run correctly.

Unable to open audio device '/dev/mixer'.
Please check that you have permissions to open '/dev/mixer'
and that you have sound support in your kernel.

Press Quit to exit Volume control"

kudzu command wasn't found

Thanks for keeping at it, it really means a lot!


-Michael

 
Old 07-22-2003, 11:12 PM   #38
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
did you try it as root
 
Old 07-22-2003, 11:23 PM   #39
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
I actually did a search for it, found the file... did su in terminal, typed in password then tried to use the program but it messed up my mouse for some reason ( until i restarted ). It locked it in the lower left hand corner and once I moved it up a little it would shoot right back down... I guess I could try it again though.
 
Old 07-23-2003, 10:15 PM   #40
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
yea... still dosnt work.

Would it be possible to install wine then use that to install the driver? or is that just program based?


-Michael

 
Old 07-24-2003, 03:47 PM   #41
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
 
Old 07-25-2003, 12:18 AM   #42
joesbox
Member
 
Registered: Feb 2003
Location: hampton va
Distribution: ubuntu
Posts: 502

Rep: Reputation: 30
try this. su to root and chmod 666 /dev/mixer and chmod 666 /dev/dsp. this will give everyone permission to execute the device.

as far as the wine thing, i don't think that this would work. the drivers are like apples and oranges.

hope that this will work for you.
 
Old 07-25-2003, 03:46 PM   #43
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Didnt change anything, when I try and go into it, it still says I dont have permission




-Michael
 
Old 07-25-2003, 06:11 PM   #44
joesbox
Member
 
Registered: Feb 2003
Location: hampton va
Distribution: ubuntu
Posts: 502

Rep: Reputation: 30
did you su to root???
 
Old 07-25-2003, 10:32 PM   #45
777SPy
Member
 
Registered: Jul 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Yep, went into terminal, typed su then my password to get into root, followed the commands just as you typed them then tried to go into what I had before when I got the error and got the same error again...


sound is becomming over-rated slowly.


Do you think I could use the soundcard built into my motherboard? Its a KM2M Combo MS-6738 (v1.x) Micro ATX Mainboard ... comments? suggestions?


Im willing to try ANYTHING ( other than going out and buying a new soundcard... budget is a little tight right now )


Thanks for everything so far guys...

-Michael

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Aureal Vortex soundcard is deafening me dasbooter Linux - Hardware 5 08-24-2005 03:23 PM
Clipping and stereo swapping with aureal sq1500 akqw Linux - Hardware 1 11-05-2003 05:13 PM
Aureal Vortex / Slackware 9.0 mikail Linux - Hardware 4 10-12-2003 11:53 PM
Aureal Vortex sq1500 Driver Installation 777SPy Linux - Hardware 2 07-16-2003 12:06 PM
aureal vortex 2 with suse 8.1 febisfebi Linux - Hardware 0 02-25-2003 12:54 AM


All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration