LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-12-2007, 04:17 PM   #1
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Rep: Reputation: 15
Audio when logged in as root, not when normal user?


Having started off just doing everything as root (I know!) i've now created a normal user account for day to day use. however, almost nothing works, LOL!

The most significant of which is I have no audio when im logged in as a standard user (created using the 'adduser -d /home/ldj/ ldj' command, but i do when im logged in as root.

what do i need to do to 'enable' audio? im guessing as audio works as root its a permissions issue?
When i run xmms from a terminal i get the error:

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): No such file or directory


If anyone can shed some light on this blighter it would be appreciated.

Thanks
 
Old 01-12-2007, 04:55 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Add yourself to the "audio" group. You probably also want to be part of groups like video, cdrom, etc.
 
Old 01-12-2007, 05:03 PM   #3
LDJ
Member
 
Registered: Nov 2004
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks, done that to those three groups but it is still giving the same error.
Tried rebooting to see if it helps but no joy
 
  


Reply

Tags
audio, audiovideo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
startx does not load when logged in as a normal user? xunzi Linux - Newbie 0 06-29-2004 08:37 AM
KDE users - Having root file manager while still logged in as normal user thegeekster Linux - General 1 04-27-2004 10:47 PM
Ugly fonts when logged in as normal user Abdul Linux - Software 2 03-09-2004 01:46 AM
mozilla works fine when logged in as a user but crashes when logged in as root jimi Linux - General 6 04-02-2003 08:34 PM
Modem connection fast when logged in as root slow when normal user Fennek Linux - Networking 0 03-17-2003 10:59 AM


All times are GMT -5. The time now is 11:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration