LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 05-30-2009, 08:11 PM   #1
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Rep: Reputation: 16
Audio skips when scrolling, skips horribly when watching video with Compiz enabled


[SOLVED!]

Hi, I'm really new to Linux and I am deciding to migrate from Windows once I can fix this.

The problem is that when I have Compiz enabled, my sound would skip a lot when I scroll down a page ( With any program, like firefox, pdf viewer), load a page with firefox and it skips for a second when I open an application. When I don't do anything the audio runs pretty smoothly by itself. It especially happens in full screen when I play video with vlc or some other program and with flash videos.

To note: I used to have a problem with the video on all the players when compiz is on ( they were skipping/cluttering as well ), I fixed vlc by making it use the X11 output module, and now video runs smoothly but not the audio.

When I have compiz off playback works way better, still a little clutter though.

Is there any way to run smooth audio in movie playback in fullscreen and have smooth audio while doing other tasks with compiz enabled?


Quote:
[root@Kiboney Kiboney]# cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0x90300000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0x90210000 irq 17
2 [U0x46d0x8c1 ]: USB-Audio - USB Device 0x46d:0x8c1
USB Device 0x46d:0x8c1 at usb-0000:00:1d.7-3.1, high speed
Thanks in advance!

Last edited by Kiboney; 06-02-2009 at 10:20 PM.
 
Old 05-31-2009, 12:06 AM   #2
vansch76
Member
 
Registered: Aug 2007
Location: Asheville, NC, USA
Distribution: Ubunutu 10.04
Posts: 137

Rep: Reputation: 18
Hi Kib

what distro are you using?
did the problem happen under windows?
how much ram does your computer have?
What kind of sound card does your computer have?
does the problem really only happen with compiz
or does it happen with other programs?
It sounds like compiz enhances the problem so it
surfaces.

If you supply more info someone will be able to
help you.

Im not an expert, but we do need more info.

Vanessa
 
Old 05-31-2009, 12:39 AM   #3
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
I think if you weren't using the most suitable video driver specified in Xorg.conf could cause similar problem. To start with that line of thinking, do you know if your using ATI video card or NVIDIA card?

Maybe if you do lspci from a command terminal, and post the output of lspci here on this thread, as that will provide lots of info about your hardware.

Last edited by greengrocer; 05-31-2009 at 12:46 AM.
 
Old 05-31-2009, 01:06 AM   #4
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by vansch76 View Post
Hi Kib

what distro are you using?
did the problem happen under windows?
how much ram does your computer have?
What kind of sound card does your computer have?
does the problem really only happen with compiz
or does it happen with other programs?
It sounds like compiz enhances the problem so it
surfaces.

If you supply more info someone will be able to
help you.

Im not an expert, but we do need more info.

Vanessa
Hi Vanessa, I'm sorry I forgot to specify my system configuration.

I'm using Fedora core 10,
The problem does not exist in windows
I have 2 gb ram, 3.2 ghz CPU
It says I have two audio devices, when I typed $ lspci to the console these are the audio devices it displays:
Quote:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01) Perhaps the one I'm using, I don't know how to find out in Linux

01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
I'm not sure but in windows it said it was a sigmatel STAC9221D or something like that, could that be the first audio device in some way?

Yes, the problem really only happens in Compiz, rarely without.
And I am using an ATI card, Radeon HD 4850 I believe.

Here is the full lspci output:
Quote:
[root@Kiboney ~]# lspci
00:00.0 Host bridge: Intel Corporation 82955X Memory Controller Hub
00:01.0 PCI bridge: Intel Corporation 82955X PCI Express Root Port
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
04:00.0 Ethernet controller: Intel Corporation 82573V Gigabit Ethernet Controller (Copper) (rev 03)
05:00.0 Modem: Broadcom Corporation BCM4212 v.90 56k modem (rev 02)
05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
05:02.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
05:04.0 FireWire (IEEE 1394): Texas Instruments TSB82AA2 IEEE-1394b Link Layer Controller (rev 01)
05:05.0 RAID bus controller: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid] Serial ATA Controller (rev 02)
[root@Kiboney ~]# cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0x90300000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0x90210000 irq 17
2 [U0x46d0x8c1 ]: USB-Audio - USB Device 0x46d:0x8c1
USB Device 0x46d:0x8c1 at usb-0000:00:1d.7-3.1, high speed

Last edited by Kiboney; 05-31-2009 at 01:10 AM.
 
Old 05-31-2009, 05:53 AM   #5
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
Quote:
VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
Your computer has an ATI graphics card. Have you installed the ATI drivers for it?

Have a look at your xorg.conf file which is found in the /etc/X11 folder (eg": type into a terminal window gedit /etc/X11/xorg.conf). What you might want to look for is mention of fglrx, which is the video driver you might want to be using because you have an ATI Radeon graphics card.

Also check out http://www.fedorafaq.org/#radeon

Last edited by greengrocer; 05-31-2009 at 05:58 AM.
 
Old 05-31-2009, 12:30 PM   #6
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
I downloaded the official ati drivers for Linux ( http://support.amd.com/us/gpudownloa...6&lang=English ), as I recall compiz did not work without the drivers.

It says I am using fglrx, is that the driver as I mentioned above?

Quote:
Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
BusID "PCI:1:0:0"
Update/edit

I don't really remember, but I think I did not have a xorg.conf file at all before, then I created this with some assistance. Is it possible that this xorg.conf does not work or that the real one is in another directory for Fedora 10?

Last edited by Kiboney; 05-31-2009 at 12:32 PM.
 
Old 05-31-2009, 02:30 PM   #7
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
One more update:

It seems that Xorg cannot find the correct driver for my Video Card when I input Xorg -configure :1 ( to reconfigure the xorg.conf ), but how is the video working at all? What can anybody make of this?

Quote:
[root@Kiboney Kiboney]# Xorg -configure :1

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-128.1.1.el5 i686
Current Operating System: Linux Kiboney 2.6.27.21-170.2.56.fc10.i686 #1 SMP Mon Mar 23 23:37:54 EDT 2009 i686
Build Date: 10 March 2009 07:20:48PM
Build ID: xorg-x11-server 1.5.3-15.fc10
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sun May 31 15:27:06 2009

List of video drivers:
mach64
ati
neomagic
siliconmotion
dummy
ast
i810
apm
cirrus
ztv
i740
trident
i128
rendition
v4l
nv
tdfx
nouveau
radeon
glint
geode
vmware
r128
amd
sisusb
mga
intel
openchrome
fglrx
savage
sis
voodoo
s3virge
fbdev
vesa

(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found

Backtrace:
0: Xorg(xorg_backtrace+0x3b) [0x812be9b]
1: Xorg(xf86SigHandler+0x51) [0x80bcca1]
2: [0x24f400]
3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxProbeMain+0x406) [0x10a6436]
4: Xorg(xf86CallDriverProbe+0x20c) [0x80a29dc]
5: Xorg(DoConfigure+0x200) [0x80ae3d0]
6: Xorg(InitOutput+0xa7b) [0x80a458b]
7: Xorg(main+0x279) [0x806b539]
8: /lib/libc.so.6(__libc_start_main+0xe5) [0xa686e5]
9: Xorg [0x806ab21]

Fatal server error:
Caught signal 11. Server aborting


Aborted
After that everything turns to as it was before - GUI seems to be running and all.

I'm really new to this, am I doing anything wrong here?

EDIT:

Quote:
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
Weird because according to lspci
Quote:
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
Is that PCI:0@1:0:1? If that is I guess we're onto something here!
Also, why is it pointing at the wrong PCI slot anyway? The PCI slot according to lspci is:
Quote:
01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
Can I change were xorg is pointing at? And is fglrx the same as http://support.amd.com/us/gpudownloa...6&lang=English?
How come xorg is displaying the GUI at all when it's pointing at the wrong device, if it's wrong...

Last edited by Kiboney; 05-31-2009 at 03:32 PM.
 
Old 05-31-2009, 09:57 PM   #8
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
Anybody?
 
Old 06-01-2009, 05:17 AM   #9
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
Do you accidentally have two Device sections in your xorg.conf file? as it is possible to have more than one specified. The "Screen" section of the xorg.conf file is the section where it is specified which "Device" is being used.

I would have thought fglrx driver in the device section of xorg.conf file would be best, but you could try replacing fglrx with ati and see what that does.

You can use CTRL+ALT+Backspace to restart X server without full reboot, after editing xorg.conf.

and remember to save a backup before you start tinkering with xorg.conf
 
Old 06-01-2009, 06:35 AM   #10
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
Okay I changed the driver fglrx to agi and no luck ( black screen ), I when into command line to debug and it said that I was missing the module 'ati', then it said "Fatal server error: no screens found" or something like that.
Just in case, here is the whole xorg.conf:

Quote:
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
Option "Xinerama" "off"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 06-01-2009, 07:23 AM   #11
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
These are complete stabs in the dark, but what happens if you try the 'vesa' driver instead? i'd expect compositing desktop not to work, but what about the playback of video and audio when you start moving things around the screen, scrolling PDF files and so on?

Also maybe changing the settings on these:

Option "OpenGLOverlay" "off" <-- try "on"
Option "VideoOverlay" "on" <-- try "off"
 
Old 06-01-2009, 03:19 PM   #12
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
When I move windows in Compiz the sound and video do not seem to get effected at all, but scrolling pdf files and web pages make the sound clutter a lot. Doing so in metacity, without compiz the sound and video run very smoothly in almost any situation.Stand by as I experiment with the settings...

Last edited by Kiboney; 06-01-2009 at 04:36 PM.
 
Old 06-01-2009, 03:51 PM   #13
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
Okay when I changed to vesa it did not work ( half of the screen was cluttery, second half blank, completely crashed X ), changing OpenGLOverlay and VideoOverlay did not help with the sound cluttering, same as before...
 
Old 06-02-2009, 03:52 PM   #14
Kiboney
Member
 
Registered: May 2009
Distribution: Fedora 11, Ubuntu, Slackware
Posts: 32

Original Poster
Rep: Reputation: 16
No ideas anyone?
 
Old 06-02-2009, 04:04 PM   #15
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 384

Rep: Reputation: 34
Try rebuilding your xorg.conf. On Fedora that would be system-config-display I think. You may need to change the driver part to fglrx afterwards. Also check if you have a recent version of the ati driver.
 
  


Reply

Tags
audio, clutter, compiz, fedora, music, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Webcam recording audio skips BigVig Debian 1 03-10-2009 10:25 PM
amarok skips sound on audio cds warpman Slackware 1 04-15-2008 06:12 PM
Audio in Web Browser Skips halfpower Slackware 9 02-23-2007 07:52 AM
audio skips in mozplugger verbose Linux - Software 22 02-12-2006 12:32 AM
Digital Audio Extraction w/ XMMS - disk skips r_jensen11 Linux - Software 0 01-18-2004 12:03 PM


All times are GMT -5. The time now is 11:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration