LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-22-2007, 10:02 AM   #1
sumesh.pt
Member
 
Registered: Nov 2007
Posts: 57

Rep: Reputation: 15
audio problem


I have fedora 6 installed in my machine. Audio was working perfectly till yesterday.

yesterday i when i tried playing audio files, the audio was not working. the video however works. i am using mplayer to play my videos (this is the only player installed in my pc). i tried youtube videos also..no sound again.

a few youtube videos were open overnight and the next day morning this is wahts happening. i did play around with the preference options also. now i ahve put everying in the maximum volume, and unmuted stage.

i checked the earphone, which works perfectly on other systems.

can any body suggest how to go ahead in resolvn this issue? i hav how to check the audio system of the machine. plz help

thanks
Sumesh
 
Old 11-22-2007, 10:28 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Test things from commandline - this way you get more helpful messages.
I think fedora's tool is system-config-soundcard or system-config-alsa.

Check the tools available with

apropos alsa

Check the audio playback by playing a wav file.
Try doing this with mplayer, from the command line - mplayer produces a lot of output that can highlight the problem.

You can check the drivers are installed with

lsmod | grep snd

And you check the system log after an unsuccessful attempt with

dmesg

You also have to watch fedora's rapid release cycles - older versions go legacy rather fast, so it is important to keep up. FC6 is no longer maintained, and the fedora legacy project has collapsed.
 
Old 11-22-2007, 11:04 AM   #3
sumesh.pt
Member
 
Registered: Nov 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Dear Simon,
Thanks a lot for the adivces. I followed exactly what you said. But I am sorry to say, I have not been able to find out the problem. I add all the responses here. Would you be able to guide me further?


[QUOTE=Simon Bridge;2967537]Test things from commandline - this way you get more helpful messages.
I think fedora's tool is system-config-soundcard or system-config-alsa.

Check the tools available with

apropos alsa


I tried the command amixer The following appeared. it looked everyging working fine.
[root@onsager sumesh]# amixer
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 250 [98%]
Front Right: Playback 250 [98%]
Simple mixer control 'Front',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 127
Mono:
Front Left: Playback 124 [98%] [on]
Front Right: Playback 124 [98%] [on]
Simple mixer control 'Surround',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 127
Mono:
Front Left: Playback 127 [100%] [on]
Front Right: Playback 127 [100%] [on]
Simple mixer control 'Center',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 127
Mono: Playback 127 [100%] [on]
Simple mixer control 'LFE',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 127
Mono: Playback 127 [100%] [on]
Simple mixer control 'Line In as Output',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'Mic as Output',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 14 [100%] [on]
Front Right: Capture 14 [100%] [on]
Simple mixer control 'Input Source',0
Capabilities: enum
Items: 'Mic' 'Front Mic' 'Line'
Item0: 'Line'
Simple mixer control 'Mux',0
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 4
Front Left: Capture 4 [100%]
Front Right: Capture 4 [100%]


I tried speakertest
[root@onsager sumesh]# speaker-test

speaker-test 1.0.12

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
0 - Front Left
Time per period = 2.664468
0 - Front Left


Check the audio playback by playing a wav file.
Try doing this with mplayer, from the command line - mplayer produces a lot of output that can highlight the problem.


I tried playing files in mplayer. It says audio started
MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) D CPU 3.00GHz (Family: 15, Model: 6, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing E=mc2.avi.
AVI file format detected.
VIDEO: [XVID] 480x272 12bpp 25.000 fps 805.4 kbps (98.3 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.1 (build 2439/release)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 480 x 272 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.76:1 - prescaling to correct movie aspect.
VO: [xv] 480x272 => 480x272 Planar YV12
A: 6.7 V: 6.7 A-V: 0.004 ct: 0.000 169/169 2% 0% 0.8% 0 0


You can check the drivers are installed with

lsmod | grep snd


I tried this

[root@onsager sumesh]# lsmod | grep snd
bash: lsmod: command not found


And you check the system log after an unsuccessful attempt with

dmesg


When i tried this, the only place where audio appeared looked like this. i hav no idea whether it means something. only excerpt copied

device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: Disabled at runtime.
SELinux: Unregistering netfilter hooks
audit(1195742369.480:2): selinux=0 auid=4294967295
input: PC Speaker as /class/input/input2
ACPI: PCI Interrupt 0000:00:1f.3[B] -> GSI 19 (level, low) -> IRQ 185
sd 0:0:0:0: Attached scsi generic sg0 type 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
e100: Intel(R) PRO/100 Network Driver, 3.5.10-k2-NAPI
e100: Copyright(c) 1999-2005 Intel Corporation
GSI 21 sharing vector 0x32 and IRQ 21

Thanks for reading the whole thing. any suggestions ?

Regards,
Sumesh
 
Old 11-23-2007, 02:18 AM   #4
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Playback device is default
... reset the default soundcard. (use the asoundconf(1) "set-default-card" macro - man asoundconf).

Quote:
Playing E=mc2.avi.
... I said to use a .wav file. The avi is a container format and we do not know that mplayer is using (or even has) the correct codecs to play the contents. That's why I asked about other files.

In this case, mplayer hopes the video format is mpeg-4 and the audio is mp3.

Quote:
AO: [oss]
... try using alsa instead of oss for audio.

Quote:
bash: lsmod: command not found
... I keep getting that off you guys - I don't get it. Purhaps you need to "su -" first? Anyway, try the full path to the command:

/bin/lsmod | grep snd
(Use "whereis lsmod" to find the full path)
 
Old 11-23-2007, 11:45 AM   #5
sumesh.pt
Member
 
Registered: Nov 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Dear Simon,

Quote:
Originally Posted by Simon Bridge View Post
... reset the default soundcard. (use the asoundconf(1) "set-default-card" macro - man asoundconf).
it looks like 'asoundconf' is not there in my pc.
Here is what I tried.
[root@onsager sumesh]# man asoundconf
No manual entry for asoundconf
I tried installation
[root@onsager sumesh]# yum install asoundconf
\Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
adobe-linux-i386 100% |=========================| 951 B 00:00
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
freshrpms 100% |=========================| 1.9 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do
[root@onsager sumesh]#
I tried locating it
[root@onsager pcm]# locate asound
/etc/asound.state
/lib/libasound.so.2
/lib/libasound.so.2.0.0
/lib64/libasound.so.2
/lib64/libasound.so.2.0.0
/usr/include/linux/ultrasound.h
/usr/include/sound/asound.h
/usr/include/sound/asound_fm.h
/usr/share/doc/alsa-lib-1.0.12/asoundrc.txt
[root@onsager pcm]#

I did search in google. it looks like many hav reported such problems..but none says how to get this asoundconf worked.

... I said to use a .wav file. The avi is a container format and we do not know that mplayer is using (or even has) the correct codecs to play the contents. That's why I asked about other files.

In this case, mplayer hopes the video format is mpeg-4 and the audio is mp3.


... try using alsa instead of oss for audio.
i changed it from system->preferences->sound->options. but same
[/QUOTE]
... I keep getting that off you guys - I don't get it. Purhaps you need to "su -" first? Anyway, try the full path to the command:

/bin/lsmod | grep snd
(Use "whereis lsmod" to find the full path)[/QUOTE]

I am root now. this is how the lsmod thing showed up
[root@onsager ~]# /bin/lsmod | grep snd
bash: /bin/lsmod: No such file or directory
[root@onsager ~]# cd /bin/lsmod
bash: cd: /bin/lsmod: No such file or directory
[root@onsager ~]#

Let me thank you in very advance expecting the guidance.
Regards,
Sumesh

Last edited by sumesh.pt; 11-23-2007 at 11:47 AM.
 
Old 11-23-2007, 09:32 PM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Code:
[root@onsager ~]# /bin/lsmod | grep snd
... that's not what I said to do... what I said was:
Quote:
try the full path to the command:
/bin/lsmod | grep snd
(Use "whereis lsmod" to find the full path)
In fedora, that could be /sbin/lsmod instead of /bin/lsmod. But it is possible that some weird installation could by /usr/share/bin/lsmod instead... or anything really. In general, if an expected command doesn't run, find it and try the full path.

You instruction should take the form:

/path/to/lsmod | grep snd

Quote:
I am root now.
... you obviously don't have roots PATH. I'm guessing you have su'd into root right? To gain roots PATH, you have to put a dash after the su like this

$ su -
Password:
#

Have you tried mplayer with a wav file?
Have you tried using alsa instead of oss for playback?
Have you tried system-config-soundcard?

asoundconf in fedora (LQ) ... though that's f7.
 
Old 11-25-2007, 09:52 AM   #7
sumesh.pt
Member
 
Registered: Nov 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Simon Bridge View Post
... that's not what I said to do... what I said was:


In fedora, that could be /sbin/lsmod instead of /bin/lsmod. But it is possible that some weird installation could by /usr/share/bin/lsmod instead... or anything really. In general, if an expected command doesn't run, find it and try the full path.

You instruction should take the form:

/path/to/lsmod | grep snd
Yes, finally I could get the path. But i dont knwo what to do with this? google says it is an editor. many grps also discuss it to some'relaoding'. wat do i do next wtiht after this command. when i do ti, it gives a list. unfortunately, i dont understand what it means.

Quote:
... you obviously don't have roots PATH. I'm guessing you have su'd into root right? To gain roots PATH, you have to put a dash after the su like this

$ su -
Password:
#
Thanks, I did it.

Quote:
/Have you tried mplayer with a wav file?
Yes, I did. no change.

Quote:
Have you tried using alsa instead of oss for playback?
Yes, I tried, no difference.

Quote:
Have you tried system-config-soundcard?
yes i did. some box appeared. it gave the option for checking the sound. i tried. i iddnt hear any sound. so it gave the message
"Automatic detection of the sound card did not work. This audio device will not be available on the system.You can create /root/scsconfig.log, /root/scsrun.log on the System tab and file a new bug
at http://bugzilla.redhat.com.
Please click OK to continue
"
i went to the system tab and clicked on the reload audio drivers.
it gave the message
"Unable to remove kernel modules. You need to reboot your box for the changes to take effect."
God, I dont knwo what it means.


Quote:
/asoundconf in fedora (LQ) ... though that's f7.
I tried al the things given in this thread. If you dont mind, I will list what happend then also.

how I "execute the asoundconf(1) set-default-card macro."

[root@onsager modprobe.d]# asoundconf(1) set-default-card macro
-bash: syntax error near unexpected token `1'
[root@onsager modprobe.d]# man asoundconf
No manual entry for asoundconf
[root@onsager modprobe.d]# asoundconf list
-bash: asoundconf: command not found
[root@onsager modprobe.d]#

essentially,whatever to be done with the asoundconf is not working.
Ya..so still suffering with it. but i am ready to try to fix it. hope you will continue to help.
Many thanks
Sumesh

Last edited by sumesh.pt; 11-25-2007 at 09:59 AM.
 
Old 11-26-2007, 02:48 AM   #8
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
Could it be a flash problem?

http://www.linuxquestions.org/questi...irefox-453292/

Or a pulse-audio problem?

http://forums.fedoraforum.org/showthread.php?t=171083

Or possibly a firefox problem?

http://www.oreillynet.com/onlamp/blo...ash_video.html
 
Old 11-26-2007, 07:16 AM   #9
sumesh.pt
Member
 
Registered: Nov 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ehawk View Post
Mine is not browser related problem..no files also cud be played indepnedenly. do u stil think its browser related?

[Quote/] Or a pulse-audio problem?
http://forums.fedoraforum.org/showthread.php?t=171083 [/QUOTE]

Mine is fedora 6. if i understand correctly, pulse audi is for fedora 7 &8. rit?

Thaks,
 
Old 11-26-2007, 09:05 AM   #10
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Yes, finally I could get the path. But i dont knwo what to do with this?
Enter
it
into
a
terminal
like
I
told
you.
Quote:
Originally Posted by me
/path/to/lsmod | grep snd
I don't know what you were googling but none of these things are editors.
man lsmod
man grep
... if you want to find out what they do.

roots path
Quote:
Thanks, I did it.
Well??? What happens when you enter "lsmod | grep snd" now???

I don't believe it's taking me this long to get a module listing!

Quote:
Mine is fedora 6. if i understand correctly, pulse audi is for fedora 7 &8. rit?
This is correct - FC6-Gnome uses ESD while FC6-KDE uses arts. As FC6 is depreciated, I doubt there will be pulseaudio packages for it - though you could install from source if you wanted.

Quote:
[root@onsager modprobe.d]# man asoundconf
No manual entry for asoundconf
Here, let me:
Code:
$ asoundconf list
Names of available sound cards:
ICH5
$ asoundconf set-default-card ICH5
... your card will be different. But it looks like asoundconf(1) is not installed.

Try entering the following:
# rpm -qa | grep alsa
# apropos alsa

Either your alsa system is broken or your soundcard is.
 
Old 11-26-2007, 10:26 AM   #11
sumesh.pt
Member
 
Registered: Nov 2007
Posts: 57

Original Poster
Rep: Reputation: 15
Thanks Simon for patiently bearing me. Its working. I dont know what made it to work. But is done now. But ofcourse, if you are willing I would like to clarify the 'asoundconf'.
The commands you dicated are:
Quote:
Originally Posted by Simon Bridge View Post
Code:
$ asoundconf list
Names of available sound cards:
ICH5
$ asoundconf set-default-card ICH5
and when i repeated i got,

Code:
[root@onsager ~]# asoundconf list
-bash: asoundconf: command not found
[root@onsager ~]# rpm -qa|grep alsa
alsa-lib-1.0.14-0.1.rc1.fc6
alsa-lib-1.0.14-0.1.rc1.fc6
alsa-utils-1.0.14-0.2.rc1.fc6
[root@onsager ~]# apropos alsa
aconnect             (1)  - ALSA sequencer connection manager
alsa-lib            (rpm) - The Advanced Linux Sound Architecture (ALSA) library.
alsa-utils          (rpm) - Advanced Linux Sound Architecture (ALSA) utilities
alsactl              (1)  - advanced controls for ALSA soundcard driver
alsamixer            (1)  - soundcard mixer for ALSA soundcard driver, with ncurses interface
amidi                (1)  - read from and write to ALSA RawMIDI ports
amixer               (1)  - command-line mixer for ALSA soundcard driver
aplay                (1)  - command-line sound recorder and player for ALSA soundcard driver
arecord [aplay]      (1)  - command-line sound recorder and player for ALSA soundcard driver
aseqdump             (1)  - show the events received at an ALSA sequencer port
aseqnet              (1)  - ALSA sequencer connectors over network
speaker-test         (1)  - command-line speaker test tone generator for ALSA
[root@onsager ~]#
Doesnt it mean that this is not installed in my machine. how to get it? is it possible to use yum? which package comes with it?

Thaks a lot once again,
Sumesh

Last edited by sumesh.pt; 11-26-2007 at 10:30 AM.
 
Old 11-26-2007, 07:24 PM   #12
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Its working. I don't know what made it to work.
Huh? Then it may just be that the soundcard needed to be reseated.

asoundconf
Quote:
Doesnt it mean that this is not installed in my machine.
That would be right. Also check that lsmod is installed - it's important.

Code:
simon@indigo-prime:~$ apropos alsa
aconnect (1)         - ALSA sequencer connection manager
alsactl (1)          - advanced controls for ALSA soundcard driver
alsamixer (1)        - soundcard mixer for ALSA soundcard driver, with ncurses interface
amidi (1)            - read from and write to ALSA RawMIDI ports
amixer (1)           - command-line mixer for ALSA soundcard driver
aplay (1)            - command-line sound recorder and player for ALSA soundcard driver
arecord (1)          - command-line sound recorder and player for ALSA soundcard driver
aseqdump (1)         - show the events received at an ALSA sequencer port
aseqnet (1)          - ALSA sequencer connectors over network
asoundconf (1)       - utility to read and change the user's ALSA library configuration
speaker-test (1)     - command-line speaker test tone generator for ALSA
It would be the only one of the regular tools you are missing.

I haven't used fedora in a long while now. But the posts of others suggest that it should be part of a default install. Did you leave off any packages?

You can use a gui, pirut or yumex, to browse the alsa packages and see where fedora puts this tool. Or you can try

yum provides asoundconf
 
Old 11-27-2007, 09:00 AM   #13
sumesh.pt
Member
 
Registered: Nov 2007
Posts: 57

Original Poster
Rep: Reputation: 15
lsmod is installed in the machine. but asoundconf is not. i tried with yum, installed all the packages of alsa. but asoundconf was not part of any. i searched for asoundconf also. noway. can one independently install asoundconf?
i add the results of the commands you suggested.
Code:
[root@onsager sumesh]# locate lsmod
/sbin/lsmod
/usr/lib64/python2.4/lib-dynload/itertoolsmodule.so
/usr/share/man/man8/lsmod.8.gz
[root@onsager sumesh]# locate asoundconf
[root@onsager sumesh]# apropos alsa
aconnect             (1)  - ALSA sequencer connection manager
alsa-lib            (rpm) - The Advanced Linux Sound Architecture (ALSA) library.
alsa-utils          (rpm) - Advanced Linux Sound Architecture (ALSA) utilities
alsactl              (1)  - advanced controls for ALSA soundcard driver
alsamixer            (1)  - soundcard mixer for ALSA soundcard driver, with ncurses interface
amidi                (1)  - read from and write to ALSA RawMIDI ports
amixer               (1)  - command-line mixer for ALSA soundcard driver
aplay                (1)  - command-line sound recorder and player for ALSA soundcard driver
arecord [aplay]      (1)  - command-line sound recorder and player for ALSA soundcard driver
aseqdump             (1)  - show the events received at an ALSA sequencer port
aseqnet              (1)  - ALSA sequencer connectors over network
speaker-test         (1)  - command-line speaker test tone generator for ALSA
[root@onsager sumesh]#
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio CD problem J_K9 Linux - Software 22 03-31-2005 01:59 PM
Audio CD problem anacharya Mandriva 4 02-16-2005 10:59 PM
Audio Problem NickT Linux - Hardware 4 05-07-2004 10:52 PM
Audio CD Problem jbone Mandriva 5 02-22-2004 11:28 PM
audio Cd problem boToo Linux - Newbie 3 08-26-2003 07:25 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration