LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2013, 01:49 PM   #1
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Rep: Reputation: 24
Audio line in not working


I have Linux Mint 15 Cinammon installed on my iMac. Works great. When I go to the sound preferences and select the input option, Audio line in works perfectly. I am able to record from the radio I have attached to my iMac which is connected to my iMac by the audio input jack.

When I try Linux 15 MATE or LM15 XFCE, the line in does not work. No audio. Why is this? What is so special about Cinammon that MATE and XFCE don't have?

Any info you require, let me know. Thanks!!
 
Old 07-26-2013, 02:39 PM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Have you checked the mixer setting for both systems? Make sure the MATE and XFCE settings are the same as the Cinnamon ones.
jdk
 
Old 07-26-2013, 02:44 PM   #3
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Original Poster
Rep: Reputation: 24
Yes. all the settings are the same and unmuted.
 
Old 07-26-2013, 07:27 PM   #4
DarkShadow
LQ Newbie
 
Registered: Jul 2013
Posts: 18

Rep: Reputation: 0
@ rmcellig

Have you tried using pavucontrol package (pulse audio volume control). It's better than the default sound preferences app. With pavucontrol you can choose the source of the recording i.e microphone, line-in and etc...

You can also choose Monitor from the recording tab. This is similar to Mix that lets you record anything playing through your speakers.

Last edited by DarkShadow; 07-26-2013 at 07:30 PM.
 
Old 07-26-2013, 08:33 PM   #5
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Original Poster
Rep: Reputation: 24
Yes I have that installed. Here are some screenshots that might help you out.

I can't belive that Apple is using a sound card that is not readily available in other computers.

What puzzles me is why Mint 15 Cinammon works fine but other distros I try don't. Is it a kernel issue, config file issue, driver issue? There must be an answer to this and I have to say I really appreciate all the help!!!

If you want me to reboot my iMac into Cinammon and explore some files or something like that to see why it works there and not in the other distros. Right now I am in Crunchbang 11 trible booting with Mac OS X, Mint Cinammon 15, and Crunchbang 11.
Attached Thumbnails
Click image for larger version

Name:	sound.jpg
Views:	87
Size:	108.2 KB
ID:	13084   Click image for larger version

Name:	card.png
Views:	31
Size:	16.3 KB
ID:	13085  
 
Old 07-26-2013, 10:09 PM   #6
DarkShadow
LQ Newbie
 
Registered: Jul 2013
Posts: 18

Rep: Reputation: 0
The screenshot for pavucontrol is correct at line-in. Do not use alsamixer. I tried to replicate your situation using a Mint Mate LiveCD.

At first, I tried to hear audio playing from Line-in. I didn't hear anything from line-in. After googling, I saw and ran the code below. After running the command I was able to hear sound from line-in. BTW, you can load the loopback module as a regular user.

Code:
pactl load-module module-loopback
I ran ffmpeg to record the audio playing from line-in and it worked.

Code:
ffmpeg -f alsa -i pulse -acodec pcm_s16le out.wav
Then I ran mplayer to play TV from my wintv card and use pulse audio and it worked as well.

Code:
mplayer -tv driver=v4l2:device=/dev/video0:norm=ntsc:input=1:alsa:adevice=pulse tv://

NOTE:
This is not permanent. You have to issue the command to load the loopback module after each reboot.

I'm not using Mint as my main OS, so I don't know which file to edit to run this command at boot automatically.

My guess is /etc/bash.bashrc or /etc/local

Last edited by DarkShadow; 07-27-2013 at 12:32 AM.
 
Old 07-27-2013, 05:11 AM   #7
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Original Poster
Rep: Reputation: 24
Thanks a lot! I will try this out.

So I just enter the first code into the terminal?

I use arecord to record my shows. As long as I can see the audio bar moving in the pulse audio settings, I know that line in is working fine.

I will post back results.

 
Old 07-27-2013, 09:21 AM   #8
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Original Poster
Rep: Reputation: 24
OK. Here goes. I am booted into the Mint 15 MATE CD. I went to Alsamixer and made sure that Input Source is set to Line and that Cature levels are up. I then went to sound preferences, clicked on the Input tab. I can see the input levels so this is working. When I rebooted into my Linux Mint 11 CD xfce, sound in didn't work. I did notice something and was wondering if this maes a difference.

The Mint 11 XFCE CD has Alsamixer 1.0.24.2
The Mint 14 MATE CD has Alsamixer 1.0.25

Not sure what version pauvcontrol is though.

What I really need to get working is my installed copy of Crunchbang 11 on my iMac. Any ideas?

Are you able to test Crunchbang as well? I will continue at my end and see what I come up with and await what you come up with.

Thanks so much!!
 
Old 07-27-2013, 12:13 PM   #9
DarkShadow
LQ Newbie
 
Registered: Jul 2013
Posts: 18

Rep: Reputation: 0
Hi rmcellig

Have you tried a test recording after loading the loopback module?

I did this test on Mint Mate 15 with a LiveCD. In order to hear audio from Line-in you have to load the loopback module first.
Code:
pactl load-module module-loopback
Also, I only used pavucontrol during this test. I never touched alsamixer nor the default sound preferences app from Mint 15. Just use pavucontrol only for now. BTW, if you're using a LiveCD as well, pavucontrol is not installed by default. You need to install pavucontrol. Yes, you can install apps when using a LiveCD.


I don't own a Imac, but Crunchbang is available for PC. I will try crunchbang via LiveCD and see what happens there.

- Later

Last edited by DarkShadow; 07-27-2013 at 12:52 PM.
 
Old 07-27-2013, 01:31 PM   #10
DarkShadow
LQ Newbie
 
Registered: Jul 2013
Posts: 18

Rep: Reputation: 0
Hi rmcellig

I've just finish testing crunchbang 11 via a LiveCD.

At first, there was no audio from Line-in. Then I loaded the loopback module and audio was heard.

Since crunchbang is using pavucontrol by default, I didn't have to install anything.

Open the volume control and select Line from the input tab. DO NOT USE ALSAMIXER

As you play the radio connected to Line open a terminal and run

Code:
arecord -v -f cd out.wav
Then press Crtl-C to quit recording.

Run
Code:
aplay out.wav
to playback the audio file.

My tests were successful with both Mint 15 Mate and crunchbang 11 loading the loopback module.

You need to load the module first before recording from line-in. Also, don't use alsamixer because pavucontrol from Mint and crunchbang does the job well.

Do a test recording and let me know the results.

Last edited by DarkShadow; 07-27-2013 at 01:43 PM.
 
Old 07-27-2013, 02:44 PM   #11
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Original Poster
Rep: Reputation: 24
Thanks DarkShadow,

I am now booted into #! on my iMac. I followed your instructions. Still nothing. Here is a screenshot. Let me know what else I should do or if I am doing something wrong.

Randy
Attached Thumbnails
Click image for larger version

Name:	2013-07-27--1374950617_1315x507_scrot.png
Views:	27
Size:	187.8 KB
ID:	13086  
 
Old 07-27-2013, 02:47 PM   #12
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Original Poster
Rep: Reputation: 24
Code:
randy@crunchbang:~$ arecord -v -f cd out.wav
Recording WAVE 'out.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
ALSA <-> PulseAudio PCM I/O Plugin
Its setup is:
  stream       : CAPTURE
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 44100
  exact rate   : 44100 (44100/1)
  msbits       : 16
  buffer_size  : 22050
  period_size  : 5512
  period_time  : 125000
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 5512
  period_event : 0
  start_threshold  : 1
  stop_threshold   : 22050
  silence_threshold: 0
  silence_size : 0
  boundary     : 1445068800
^CAborted by signal Interrupt...
randy@crunchbang:~$ aplay out.wav
Playing WAVE 'out.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
randy@crunchbang:~$


---------- Post added 07-27-13 at 02:48 PM ----------

No audio at all on playback. Just hiss.
 
Old 07-27-2013, 02:55 PM   #13
rmcellig
Member
 
Registered: Sep 2009
Posts: 252
Blog Entries: 1

Original Poster
Rep: Reputation: 24
Just to let you know. My radio is also hooked up to my old Dell 3000 using #! 11. Works fine.

What I want (and I get pretty driven when I have computer problems to solve), is to get this working on my iMac. Like I said before Line in works great in Mint 15 MATE, Cinammon and xfce flavors. I'm starting to wonder if this is a kernel issue. Maybe it needs to be upgraded? Just thinking outload .

Are ther any commands I should issue that would give you more info regarding the sound card etc... in my iMac?
 
Old 07-27-2013, 03:04 PM   #14
DarkShadow
LQ Newbie
 
Registered: Jul 2013
Posts: 18

Rep: Reputation: 0
Looks fine to me. I don't understand why it is not working for you.

Is the connection from your radio to Line input secure?
Is the volume on the radio high enough to be heard through the Line input?
Are you ruuning crunchbang in a virtual machine?
 
Old 07-27-2013, 03:10 PM   #15
DarkShadow
LQ Newbie
 
Registered: Jul 2013
Posts: 18

Rep: Reputation: 0
Sorry, but I don't own a mac. I can't comment on that. I feel bad it didn't work for you. If this is a Mac and crunchbang issue then this is beyond my lack of Mac hardware knowledge.
: /

Last edited by DarkShadow; 07-27-2013 at 03:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptic package not working from xcfe yet working from the command line onerous Debian 8 11-15-2012 04:40 PM
lmms - No audio-driver working - falling back to dummy-audio-driver GuySkarpz Linux - Software 3 01-20-2009 04:58 PM
media problem with .avi --- audio only in vlc working rest amarock ,etc. not working fedex Linux - Newbie 1 12-22-2007 09:06 AM
SiS Audio Line in not working Amir Linux - Hardware 1 03-27-2005 12:25 PM
can i use this line for audio recording? tacca Linux - Hardware 0 10-23-2004 10:53 AM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration