LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-03-2009, 09:52 AM   #1
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Rep: Reputation: 15
Smile Audio Files


I'm using Slackware 12.2
There are lots of media players installed, but non of them are playing
audio files. What should I do now?
 
Old 07-03-2009, 09:58 AM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Here is a link to a slackware multimedia howto. Maybe you can find something useful to solve your issue.
 
Old 07-03-2009, 11:19 AM   #3
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Original Poster
Rep: Reputation: 15
Post confused

Is there any problem in sound driver?

The sound is OK when I do test sound through settings.

Is it because of Plugin.

Should I have to install plugin.
 
Old 07-03-2009, 11:40 AM   #4
veerain
Member
 
Registered: Mar 2005
Posts: 473

Rep: Reputation: 49
Try unmute the volume with alsamixer. Or try changing the jacks.
 
Old 07-03-2009, 08:20 PM   #5
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Original Poster
Rep: Reputation: 15
Talking group

Oh got it.
When I log in as root, I can play.
Now I think I have to change setting for user account.
How to do that?
 
Old 07-03-2009, 11:59 PM   #6
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Original Poster
Rep: Reputation: 15
I'm still waiting for someone's help :cry:

Only I can play audio files when I log in as root, but when I log in as normal user I can't.
 
Old 07-07-2009, 12:41 AM   #7
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Original Poster
Rep: Reputation: 15
Angry Waiting

I'm still stucked here. Ignoring me ????
 
Old 07-07-2009, 01:00 AM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You may need to make yourself a member of the "audio" group to be able to write to the /dev/dsp device.

Last edited by jschiwal; 07-07-2009 at 04:29 AM.
 
Old 07-07-2009, 01:26 AM   #9
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Original Poster
Rep: Reputation: 15
Smile

42 min ?
My second last post was posted on 4th of July.
And the last one just today 7th of July.

I think I'm already in the group audio.
I've already choosed the groups like audio, cdrom, floppy, plugdev and video during the process of adduser.

When I log in, the startup music sounds.
It even sounds when I click Test Sound In Sound System from settings.

When I Play with Amarok. The error message is like this:

Error Loading Media
Could not open file.
file:///home/soul/Nymphetamine.mp3

There are other media players also. They are Kaabodle, zine, juk, audacious, etc.
They gets stucked without giving error message.



The result of 'ls -l /dev/dsp*'
is crw-rw---- 1 root audio 14, 3 2009-06-14 17:49 /dev/dsp

The result of 'ls -l /dev/audio*'
is crw-rw---- 1 root audio 14, 4 2009-06-14 17:49 /dev/audio
 
Old 07-07-2009, 04:55 AM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I caught the time, and missed the date of those posts.

Your prior posts indicated no sound as a regular user. The last post indicates that you may not have mp3 support. By the way, you can enter the command "groups". This command will print out the groups you are a member of.

Try playing a free format like ogg. The error you get in amarok could be due to a version built without mp3 support.

It is confusing why media players work as root, but not as regular user, yet, system sounds work as a regular user. Usually it is an all or nothing proposition. Whenever my sound quits working, I will run "alsaconf" followed by my distro's sound config tool.

A quick test could be to create a new user. Log in as that user and see if system sounds work. Then try playing an ogg using ogg123 or mplayer. Finally try an mp3 using mpg123 or mplayer. A program you launch from the terminal may provide more feedback.
 
Old 07-07-2009, 06:21 AM   #11
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Original Poster
Rep: Reputation: 15
Smile Thanks

Yes it supports .ogg format.
Now to make the players able to play .mp3 format files?
 
Old 07-07-2009, 08:25 PM   #12
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
If you can play ogg files, then your sound system is working. It is a matter of codecs or installing mp3 enabled package versions. I also don't know if you are using amarok 1.4 or amarok 2.0. Amarok 1.4 uses either xine or yuaup libraries for it's sound engine. Amarok 2.0 uses kde's phonon.
Make sure you have liblame and libmad installed. These are the most common mp3 libraries. Also install libfaad. This is used for AAC support.

The problem could also be that the player package was built without mp3 support enabled. If the repo package description said it plays mp3s, then it is probably just a matter of installing the library packages.
 
Old 07-08-2009, 10:21 AM   #13
SolitudeSensus
Member
 
Registered: May 2009
Posts: 73

Original Poster
Rep: Reputation: 15
Smile Permission

I can play the mp3 file that has been downloaded. According to its properties:
Permissions : -rw-r--r--
Owner : test
Group : root


I can't play the mp3 file that has been copied from XP's drive (NTFS). It's properties are:
Permissions : -rwx------
Owner : root
Group : root

Last edited by SolitudeSensus; 07-08-2009 at 10:23 AM.
 
Old 07-08-2009, 10:35 AM   #14
karamarisan
Member
 
Registered: Jul 2009
Location: Illinois, US
Distribution: Fedora 11
Posts: 374

Rep: Reputation: 55
That's a different issue. Because you're not root or in the group root, you use the third triplet of letters, which lacks read permissions. Change that file's ownership and permissions (run man chmod and man chgrp) - should be owned by you and either the group users or the group with the same name as your username, and should have permissions like -rw-r--r-- or -rw-------.
 
Old 07-09-2009, 07:54 PM   #15
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You can use the "uid=<yourusername>,gid=<yourgroup>" mount options when mounting that ntfs XP partition. This will give you ownership rights. After that, you won't need to su to root to copy an mp3 file. Since the NTFS filesystem isn't a native Linux filesystem, the ownership & permissions of the directories & files are determined when it is mounted.
 
  


Reply

Tags
account, audio, etc, files, group, media, player, user


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
smplayer: video+audio stutters with pulseaudio, audio files play fine GamerX Linux - Desktop 1 02-06-2009 09:53 PM
problem in mounting cdrom(audio files running but not reading data files) amit_usual Linux - Newbie 7 12-29-2007 06:52 AM
trim audio files dka Linux - Software 1 01-02-2007 01:17 PM
Reading audio data files as an actual audio file? Erik_the_Red Linux - Software 1 06-01-2005 08:22 AM
how to split up audio files? SciYro Linux - General 3 10-27-2004 12:25 PM


All times are GMT -5. The time now is 06:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration