LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2007, 07:20 AM   #1
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Audio CD's (am I being thick) ???


Ok, so I can play digital tracks fine (Undergrounds "Born Slippy" playing as I type).

I can't play audio CD's, either in my user account or my partners account (which is what I'm trying to correct).

Kscd seems to see CD's, but doesn't output any audio. Amarok gives me the error that it cannot read the audio CD.

I have not idea what I need to look at (apart from the glaringly obvious i.e. that the CD output is turned up in a mixer, that it's not muted etc etc).

I did have to add users to the /etc/fstab before kscd would "see" the CD. Both my and my partners accounts are in the CDROM group.

Can anyone else suggest what I need to look at please ?

regards

John
 
Old 08-04-2007, 11:38 AM   #2
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Is the audio cable inside the case plugged in? This is usually a thin grey cable with a flat plug on either end, one end of which goes into the back of the CD drive, and the other end of which goes into your soundcard (or motherboard for onboard sound).

Have you tried it with different CDs? Some CDs have something very annoying called Copy Control, which often stops them being played on computers (although a good ripping program can still rip them).

I'm sure there are other possible causes too.
 
Old 08-04-2007, 11:55 AM   #3
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
I just seem to get this
Quote:
CD-ROM read or access error (or no audio disc in drive).
Please make sure you have access permissions to:
/dev/cdrom
Which it why I think I'm being thick.

If I look under /dev I can find /cdrom1 and /cdrom2 both show as links to block device scd1 and scd0 respectively. There is no indication of just /dev/cdrom - hence nothing to make symlinks to or from.

I've tried telling KsCD to look at /dev/scd1 and 0 but get the same error.

I suspect that whatever it is that I'm doing wrong is right in front of my face. I just can't see what it is!

regards

John

p.s. Oh and as far as the play protection thing, Clares (my partner) "Pink" CD is produced by Sony BMG so it's possible, but the 2 others I tried aren't so ?......
 
Old 08-04-2007, 12:25 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
For me, /dev/cdrom is a link like this lrwxrwxrwx 1 root root 3 2007-08-04 15:11 /dev/cdrom -> hdb
So make a link called /dev/cdrom pointing at /dev/scd ?
My permissions look like this
Code:
ls -l /dev/hdb
brw-rw---- 1 root cdrom 3, 64 2007-08-04 15:11 /dev/hdb
Hope this helps
 
Old 08-05-2007, 10:06 AM   #5
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by tredegar
For me, /dev/cdrom is a link like this lrwxrwxrwx 1 root root 3 2007-08-04 15:11 /dev/cdrom -> hdb
So make a link called /dev/cdrom pointing at /dev/scd ?
My permissions look like this
Code:
ls -l /dev/hdb
brw-rw---- 1 root cdrom 3, 64 2007-08-04 15:11 /dev/hdb
Hope this helps
Which is whats confusing me lots. My system doesn't have a file etc for /dev/cdrom only /dev/cdrom1 and /dev/cdrom2 they in turn, appear to be links to /dev/scd1 and /dev/scd0, the permissions for which, are like this

Quote:
ls -l /dev/scd0
brwxrwxrwx 1 root cdrom 11, 0 2007-08-04 12:31 /dev/scd0
and
Quote:
/dev/scd1
brwxrwxrwx 1 root cdrom 11, 1 2007-08-04 12:31 /dev/scd1
It doesn't matter which device the disk is in, I get no audio output. If I then try configuring KsCD to use "direct digital playback" I get the same error as previously posted.

I've just changed the permissions so that others can read & write to the /dev/dsp and I'm gonna see if I can get any sound out of it.

regards

John
 
Old 08-05-2007, 10:41 AM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Quote:
My system doesn't have a file etc for /dev/cdrom only /dev/cdrom1 and /dev/cdrom2 they in turn, appear to be links to /dev/scd1 and /dev/scd0
OK, if there isn't a /dev/cdrom, you need to make it like this (as root)

ln -s /dev/scd /dev/cdrom
ls -l /dev/cdrom


That should do it.
 
Old 08-05-2007, 04:50 PM   #7
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by tredegar
OK, if there isn't a /dev/cdrom, you need to make it like this (as root)

ln -s /dev/scd /dev/cdrom
ls -l /dev/cdrom


That should do it.
I've created the link ok, but it still seems to make no difference i.e. it just told me about permissions for /dev/scd0.

I unchecked the "use direct digital playback" box and now it seems that it can in fact see the disc, but I still get no audio output.

Any other ideas ???

regards

John
 
Old 08-05-2007, 05:21 PM   #8
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,825

Rep: Reputation: 221Reputation: 221Reputation: 221
Quote:
Kscd seems to see CD's, but doesn't output any audio. Amarok gives me the error that it cannot read the audio CD.
Have you tried launching your cdplayer as root? If a song plays then you know it's a permission prob.

Also is it playing if you put a headphone into the jack on the front of the drive?

Last edited by teckk; 08-05-2007 at 05:24 PM.
 
Old 08-05-2007, 07:20 PM   #9
dv502
Member
 
Registered: Sep 2006
Location: USA - NYC
Distribution: Whatever icon you see!
Posts: 642

Rep: Reputation: 57
Here are some suggestions

1. If you got a read disc error, try a different cd to see if the error appears again. If not, then the cd you are trying to play is damage.

2. Run dmesg to see which device node your cdrom is pointing to. An example from my pc

[dvelez@localhost ~]$ dmesg | grep -i dvd
hdc: Optiarc DVD RW AD-7170A, ATAPI CD/DVD-ROM drive
hdc: ATAPI 48X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(66)

As you can see, hdc is my dvd or cdrom drive

3. Open kmix or other to see if the cd playback is muted, ie turn off. If it is muted, unmute it and move the slider up.

4. Check your audio cable connecting to your drive to the soundcard or onboard soundcard.

end

Last edited by dv502; 08-05-2007 at 07:22 PM.
 
Old 08-06-2007, 12:30 PM   #10
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Not sure if this question will help much, but is this some kind of external CD drive? I ask since it shows up as an /dev/scdX device, whereas I think most internal ones will appear as /dev/hdX (or occasionally /dev/sdX if you have a SATA drive).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio CD's fearmymullet Linux - Laptop and Netbook 2 10-03-2006 03:02 PM
Audio cd's Cast-Away Slackware 4 05-17-2004 04:45 PM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 08:52 AM
Audio CD's wolfenstineus Linux - Newbie 4 07-30-2003 07:16 PM
Trouble playing commercial audio cd's. MP3 cd's ok. barryww1956 Linux - General 7 12-17-2001 08:42 PM


All times are GMT -5. The time now is 10:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration