LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-08-2010, 02:16 AM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Rep: Reputation: 51
Attempt to make CentOS Installation size < 400 MB


I have installed CentOS 5.4 with selecting the least package. The Aim is to make it least to < 400 MB. All I had this ananconda-ks.cfg file when it got installed:
Code:
# Kickstart file automatically generated by anaconda.

install
cdrom
lang en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp
rootpw --iscrypted $1$MpPd/Wzi$wbHw34wjGoE/H2ac/CW1M1
firewall --enabled --port=22:tcp
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc Asia/Kolkata
bootloader --location=mbr --driveorder=sda --append="rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --linux
#part /boot --fstype ext3 --size=100
#part swap --size=512
#part / --fstype ext3 --size=100 --grow

%packages
@admin-tools
@base
@core
@dns-server
@development-libs
@development-tools
@editors
@gnome-software-development
@graphical-internet
@java
@java-development
@legacy-network-server
@legacy-software-development
@legacy-software-support
@mail-server
@mysql
@network-server
@openfabrics-enterprise-distribution
@printing
@server-cfg
@system-tools
@text-internet
@web-server
@smb-server
@x-software-development
@base-x
keyutils
trousers
fipscheck
device-mapper-multipath
pth
perl-libxml-perl
perl-Convert-ASN1
pth-devel
python-imaging
imake
vim-X11
bsh-demo
telnet-server
talk-server
rsh-server
openssl097a
compat-openldap
openmotif22
openldap-servers
vnc-server
krb5-server
system-config-bind
system-config-boot
net-snmp-utils
mod_auth_kerb
mod_nss
mod_authz_ldap
mesa-libGLU-devel
xorg-x11-resutils
xorg-x11-xsm
xorg-x11-server-Xnest
xorg-x11-xfs-utils
xorg-x11-server-Xvfb
-sabayon
-system-config-lvm
-setroubleshoot
-system-config-kdump
-system-config-rootpassword
-acpid
-readahead
-ksh
-lftp
-crash
-coolkey
-numactl
-mgetty
-fbset
-man-pages
-dump
-dosfstools
-mdadm
-ftp
-nano
-finger
-irqbalance
-pcmciautils
-redhat-lsb
-mlocate
-sos
-mtools
-dos2unix
-microcode_ctl
-ibmasm
-cpuspeed
-iptstate
-specspo
-setuptool
-pinfo
-ipsec-tools
-rp-pppoe
-unix2dos
-mtr
-mkbootdisk
-tree
-irda-utils
-amtu
-rng-utils
-ypbind
-pax
-nc
-oddjob
-smartmontools
-ccid
-anacron
-telnet
-setarch
-eject
-bluez-utils
-logwatch
-gnupg
-talk
-gpm-devel
-xulrunner-devel
-xmlsec1-devel
-coolkey-devel
-boost-devel
-libuser-devel
-hesiod-devel
-libusb-devel
-libvorbis-devel
-splint
-valgrind
-systemtap
-subversion
-texinfo
-gcc-gfortran
-rcs
-ctags
-dogtail
-swig
-dev86
-doxygen
-cvs
-oprofile
-cscope
-libgnomeprintui22-devel
-eel2-devel
-gail-devel
-bug-buddy
-devhelp
-gnome-panel-devel
-libgtop2-devel
-gnome-desktop-devel
-evolution-data-server-devel
-at-spi-devel
-evolution
-nspluginwrapper
-gnome-themes
-evolution-webcal
-ekiga
-evolution-connector
-xmlrpc
-xmlrpc-javadoc
-dovecot
-spamassassin
-libmlx4
-libibverbs-utils
-perftest
-libsdp
-libnes
-openmpi
-libcxgb3
-dapl
-libibcm
-ofed-docs
-librdmacm-utils
-infiniband-diags
-qperf
-ibutils
-dapl-utils
-zsh
-zisofs-tools
-hwbrowser
-nmap
-xdelta
-bluez-hcidump
-OpenIPMI
-bluez-gnome
-slrn
-fetchmail
-mutt
-cadaver
-gdm
-synaptics
-linuxwacom
-glx-utils
-wdaemon
The Number of RPMs were: 774 earlier.
The Size was 2.0 GB. I started deleting non-required packages.
And now my list of rpm -qa > lattestone says:
Code:
centos-release-notes-5.4-4
rootfiles-8.1-1.1.1
mktemp-1.5-23.2.2
libSM-1.0.1-3.1
ncurses-5.5-24.20060715
libxml2-2.6.26-2.1.2.8
libgcrypt-1.4.4-5.el5
audiofile-0.2.6-5
libdaemon-0.10-5.el5
cpp-4.1.2-46.el5
libdrm-2.0.2-1.1
dmidecode-2.9-1.el5
libxslt-1.1.17-2.el5_2.2
ttmkfdir-3.0.9-23.el5
setserial-2.17-19.2.2
libXext-1.0.1-2.1
libXfixes-4.0.1-2.1
libXtst-1.0.1-3.1
libselinux-1.33.4-5.5.el5
python-2.4.3-27.el5
alsa-lib-1.0.17-1.el5
cryptsetup-luks-1.0.3-5.el5
audit-libs-python-1.7.13-2.el5
usermode-1.88-3.el5.2
postgresql-libs-8.1.11-1.el5_1.1
MAKEDEV-3.23-1.2
prelink-0.4.0-2.el5
gettext-0.14.6-4.el5
lockdev-1.0.1-10
dbus-libs-1.1.2-12.el5
rpm-libs-4.4.2.3-18.el5
kbd-1.12-21.el5
pygobject2-doc-2.12.1-5.el5
elfutils-libs-0.137-3.el5
libdbi-drivers-0.8.1a-1.2.2
glibc-headers-2.5-42
readline-devel-5.1-3.el5
netpbm-devel-10.35.58-8.el5
slang-devel-2.0.6-4.el5
db4-devel-4.3.29-10.el5
mx-2.0.6-2.2.2
mod_ssl-2.2.3-31.el5.centos
compat-libstdc++-296-2.96-138
libibverbs-1.1.2-4.el5
elfutils-libelf-devel-static-0.137-3.el5
fontconfig-devel-2.4.1-7.el5
e2fsprogs-devel-1.39-23.el5
newt-devel-0.52.2-12.el5
mod_authz_ldap-0.26-9.el5
basesystem-8.0-5.1.1.el5.centos
nash-5.1.19.6-54
kernel-headers-2.6.18-164.el5
gnu-efi-3.0c-1.1
libgcc-4.1.2-46.el5
glib2-2.12.3-4.el5_3.1
audit-libs-1.7.13-2.el5
libcap-1.10-26
libpng-1.2.10-7.1.el5_3.2
info-4.8-14.el5
nspr-4.7.4-1.el5_3.1
gawk-3.1.5-14.el5
sqlite-3.3.6-5
libgpg-error-1.4-2
diffutils-2.8.1-15.2.3.el5
gdbm-1.8.0-26.2.1
less-394-6.el5
tcl-8.4.13-4.el5
libfontenc-1.0.2-2.2.el5
hesiod-3.1.0-8
iptables-ipv6-1.3.5-5.3.el5
keyutils-1.2-1.el5
cpio-2.6-23.el5
gpm-1.20.1-74.1
procmail-3.22-17.1.el5.centos
pkgconfig-0.21-2.el5
checkpolicy-1.33.1-4.el5
libvolume_id-095-14.21.el5
sysfsutils-2.0.0-6
jwhois-3.2.3-8.el5
attr-2.4.32-1.1
nss-tools-3.12.3.99.3-1.el5.centos.2
m4-1.4.5-3.el5.1
vconfig-1.9-2.1
zip-2.31-2.el5
hdparm-6.6-2
libart_lgpl-2.3.17-4
netpbm-10.35.58-8.el5
centos-release-5-4.el5.centos.1
libX11-1.0.3-11.el5
libXmu-1.0.2-5
libXinerama-1.0.1-2.1
libXpm-3.5.5-3
libXres-1.0.1-3.1
libXxf86dga-1.0.1-3.1
startup-notification-0.8-4.1
libXevie-1.0.1-3.1
e2fsprogs-libs-1.39-23.el5
openssl-0.9.8e-12.el5
cairo-1.2.4-5.el5
cups-libs-1.3.7-11.el5
logrotate-3.7.4-9
libgssapi-0.10-2
mesa-libGLU-6.5.1-7.7.el5
qt-3.3.6-23.el5
pygobject2-2.12.1-5.el5
libselinux-python-1.33.4-5.5.el5
pam-0.99.6.2-6.el5
passwd-0.73-1
SysVinit-2.86-15.el5
bind-libs-9.3.6-4.P1.el5
nscd-2.5-42
vim-minimal-7.0.109-6.el5
tar-1.15.1-23.0.1.el5
sudo-1.6.9p17-5.el5
hpijs-1.6.7-4.1.el5.4
at-3.1.8-82.fc6
samba-common-3.0.33-3.14.el5
gd-2.0.33-9.4.el5_1.1
pyxf86config-0.3.31-2.fc6
curl-7.15.5-2.1.el5_3.5
lsof-4.78-3
python-iniparse-0.2.3-4.el5
kernel-devel-2.6.18-164.el5
dbus-glib-0.73-8.el5
policycoreutils-1.33.12-14.6.el5
rpm-python-4.4.2.3-18.el5
dhclient-3.0.5-21.el5
dnsmasq-2.45-1.el5_2.1
vixie-cron-4.1-76.el5
openssh-server-4.3p2-36.el5
dhcpv6-client-1.0.10-17.el5
yum-3.2.22-20.el5.centos
kernel-2.6.18-164.el5
nfs-utils-1.0.9-42.el5
gmp-4.1.4-10.el5
gdb-6.8-37.el5
libdbi-0.8.1-2.1
libgpg-error-devel-1.4-2
libattr-devel-2.4.32-1.1
libgomp-4.4.0-6.el5
diffstat-1.41-1.2.3.el5
libmng-devel-1.0.9-5.1
nss-devel-3.12.3.99.3-1.el5.centos.2
libXau-devel-1.0.1-3.1
pcsc-lite-devel-1.4.4-0.1.el5
gmp-devel-4.1.4-10.el5
libtiff-devel-3.8.2-7.el5_3.4
libart_lgpl-devel-2.3.17-4
expat-devel-1.95.8-8.2.1
libxslt-python-1.1.17-2.el5_2.2
alchemist-1.0.36-2.el5
webalizer-2.01_10-30.1
sgml-common-0.6.3-18
httpd-manual-2.2.3-31.el5.centos
tomcat5-servlet-2.4-api-5.5.23-0jpp.7.el5_3.2
compat-glibc-headers-2.3.4-2.26
compat-glibc-2.3.4-2.26
gcc-4.1.2-46.el5
libXp-1.0.0-8.1.el5
openmotif22-2.2.3-18
xrestop-0.2-6.2.2
elfutils-libelf-devel-0.137-3.el5
Xaw3d-1.5E-10.1
libxml2-devel-2.6.26-2.1.2.8
alsa-lib-devel-1.0.17-1.el5
pam-devel-0.99.6.2-6.el5
mod_auth_kerb-5.1-3.el5
screen-4.0.3-1.el5
filesystem-2.4.0-2.el5.centos
glibc-common-2.5-42
desktop-backgrounds-basic-2.0-41.el5.centos
mailcap-2.1.23-1.fc6
chkconfig-1.3.30.1-2
libstdc++-4.1.2-46.el5
libICE-1.0.1-2.1
atk-1.12.2-1.fc6
bash-3.2-24.el5
freetype-2.2.1-21.el5_3
sed-4.1.5-5.fc6
cyrus-sasl-lib-2.1.22-5.el5
keyutils-libs-1.2-1.el5
elfutils-libelf-0.137-3.el5
libusb-0.1.12-5.1
procps-3.2.7-11.1.el5
iptables-1.3.5-5.3.el5
ORBit2-2.14.3-5.el5
libogg-1.1.3-3.el5
libXfont-1.2.2-1.0.3.el5_1
libmng-1.0.9-5.1
hmaccalc-0.9.6-1.el5
groff-1.18.1.1-11.1
desktop-file-utils-0.10-7
grep-2.5.1-55.el5
libXdmcp-1.0.1-2.1
mingetty-1.07-5.2.2
bc-1.06-21
rsync-2.6.8-3.1
udftools-1.0.0b3-0.1.el5
ed-0.2-39.el5_2
traceroute-2.0.1-5.el5
pam_smb-1.1.7-7.2.1
libhugetlbfs-1.3-3.el5
libFS-1.0.0-3.1
pcsc-lite-libs-1.4.4-0.1.el5
crontabs-1.10-8
libXt-1.0.2-3.1.fc6
libXi-1.0.1-3.1
libXxf86misc-1.0.1-3.1
libXTrap-1.0.0-3.1
libxkbfile-1.0.3-3.1
grub-0.97-13.5
device-mapper-1.02.32-1.el5
krb5-libs-1.6.1-36.el5
fontconfig-2.4.1-7.el5
pango-1.14.9-6.el5.centos
kpartx-0.4.7-30.el5
libsemanage-1.9.1-4.4.el5
nfs-utils-lib-1.0.8-7.6.el5
paps-0.6.6-18.el5
m2crypto-0.16-6.el5.6
yum-metadata-parser-1.1.2-3.el5.centos
cracklib-2.8.9-3.3
libuser-0.54.7-2.el5.5
which-2.16-7
net-snmp-libs-5.3.2.2-7.el5
ppp-2.4.4-2.el5
lvm2-2.02.46-8.el5
libselinux-utils-1.33.4-5.5.el5
apr-util-1.2.7-7.el5_3.2
PyQt-3.16-4
pam_pkcs11-0.5.3-23
SDL-1.2.10-8.el5
alsa-utils-1.0.17-1.el5
autofs-5.0.1-0.rc2.131.el5
python-numeric-23.7-2.2.2
wget-1.11.4-2.el5
pkinit-nss-0.7.6-1.el5
parted-1.8.1-23.el5
nss_db-2.2-35.3
hicolor-icon-theme-0.9-2.1
dbus-1.1.2-12.el5
openssh-4.3p2-36.el5
dmraid-1.0.0.rc13-53.el5
wpa_supplicant-0.5.10-8.el5
cyrus-sasl-2.1.22-5.el5
fipscheck-1.2.0-1.el5
setools-3.0-3.el5
yum-fastestmirror-1.1.16-13.el5.centos
yum-updatesd-0.9-2.el5
pciutils-devel-2.2.3-7.el5
bsh-manual-1.3.0-9jpp.1
indent-2.2.9-14.fc6
nspr-devel-4.7.4-1.el5_3.1
libjpeg-devel-6b-37
bison-2.3-2.1
rwho-0.17-26
byacc-1.9-29.2.2
libacl-devel-2.2.39-3.el5
libgcrypt-devel-1.4.4-5.el5
pstack-1.2-7.2.2
sqlite-devel-3.3.6-5
pygtk2-codegen-2.10.1-12.el5
libstdc++-devel-4.1.2-46.el5
distcache-1.4.5-14.1
xterm-215-8.el5
xml-common-0.6.3-18
dejavu-lgc-fonts-2.10-1
openjade-1.3.2-27
pth-2.0.7-6.el5
openib-1.4.1-3.el5
libXcomposite-0.3-5.1
tix-8.4.0-11.fc6
gcc-c++-4.1.2-46.el5
libselinux-devel-1.33.4-5.5.el5
cyrus-sasl-devel-2.1.22-5.el5
openssl097a-0.9.7a-9.el5_2.1
libxslt-devel-1.1.17-2.el5_2.2
openldap-devel-2.3.43-3.el5
krb5-devel-1.6.1-36.el5
gtk-doc-1.7-1.fc6
setup-2.5.58-7.el5
tzdata-2009k-1.el5
termcap-5.5-1.20060701.1
comps-extras-11.1-1.1.el5.centos
words-3.0-9.1
zlib-1.2.3-3
popt-1.10.2.3-18.el5
libjpeg-6b-37
db4-4.3.29-10.el5
libtermcap-2.0.8-46.1
libsepol-1.15.2-2.el5
readline-5.1-3.el5
bzip2-libs-1.0.3-4.el5_2
libacl-2.2.39-3.el5
libXau-1.0.1-3.1
libtiff-3.8.2-7.el5_3.4
gnutls-1.4.1-3.el5_2.1
iproute-2.6.18-10.el5
libIDL-0.8.7-1.fc6
libsysfs-2.0.0-6
libvorbis-1.1.2-3.el5_3.3
lcms-1.18-0.1.beta1.el5_3.2
vim-common-7.0.109-6.el5
binutils-2.17.50.0.6-12.el5
iputils-20020927-46.el5
pcre-6.6-2.el5_1.7
libevent-1.1a-3.2.1
ethtool-6-3.el5
sgpio-1.2.0_10-2.el5
acl-2.2.39-3.el5
shared-mime-info-0.19-5.el5
time-1.7-27.2.2
file-4.17-15.el5_3.1
symlinks-1.2-24.2.2
rdist-6.1.5-44
libaio-0.3.106-3.2
patch-2.5.4-29.2.3.el5
redhat-menus-6.7.8-3.el5
bitstream-vera-fonts-1.10-7
libXrender-0.9.1-3.1
libXxf86vm-1.0.1-3.1
libXcursor-1.1.7-1.1
libXfontcache-1.0.2-3.1
libdmx-1.0.2-3.1
libXdamage-1.0.3-2.1
tk-8.4.13-5.el5_1.1
shadow-utils-4.0.17-14.el5
coreutils-5.97-23.el5
openldap-2.3.43-3.el5
libXft-2.1.10-1.1
e2fsprogs-1.39-23.el5
rhpl-0.194.1-1
psmisc-22.2-7
esound-0.2.36-3
ntsysv-1.3.30.1-2
python-sqlite-1.1.7-1.2.1
gamin-python-0.1.7-8.el5
util-linux-2.13-0.52.el5
authconfig-5.3.21-6.el5
sip-4.4.5-3
libpcap-0.9.4-14.el5
device-mapper-event-1.02.32-1.el5
net-tools-1.60-78.el5
nss_ldap-253-21.el5
krb5-workstation-1.6.1-36.el5
pam_ccreds-3-5
tmpwatch-2.9.7-1.1.el5.2
sox-12.18.1-1
python-ldap-2.2.0-2.1
PyXML-0.8.4-4
tcpdump-3.9.4-14.el5
psacct-6.3.2-44.el5
libutempter-1.1.4-4.el5
htmlview-4.0.0-2.el5
initscripts-8.45.30-2.el5.centos
rpm-4.4.2.3-18.el5
dbus-python-0.70-7.el5
sysklogd-1.4.1-44.el5
portmap-4.0-65.2.2.1
dmraid-events-1.0.0.rc13-53.el5
module-init-tools-3.3-0.pre3.1.54.el5
kudzu-devel-1.2.57.1.21-1.el5.centos
unixODBC-2.2.11-7.1
zlib-devel-1.2.3-3
libtermcap-devel-2.0.8-46.1
libpfm-3.2-0.060926.4.el5
elfutils-0.137-3.el5
flex-2.5.4a-41.fc6
rusers-0.17-47
glibc-devel-2.5-42
freetype-devel-2.2.1-21.el5_3
libfontenc-devel-1.0.2-2.2.el5
libdrm-devel-2.0.2-1.1
gdbm-devel-1.8.0-26.2.1
keyutils-libs-devel-1.2-1.el5
libcap-devel-1.10-26
httpd-2.2.3-31.el5.centos
mod_python-3.2.8-3.1
opensp-1.5.2-4
compat-libf2c-34-3.4.6-4
compat-libstdc++-33-3.2.3-61
libXvMC-1.0.2-2.1
librdmacm-1.0.8-5.el5
compat-gcc-34-c++-3.4.6-4
python-devel-2.4.3-27.el5
openldap-clients-2.3.43-3.el5
lockdev-devel-1.0.1-10
bsh-javadoc-1.3.0-9jpp.1
openssl-devel-0.9.8e-12.el5
dbus-devel-1.1.2-12.el5
rpm-devel-4.4.2.3-18.el5
mod_nss-1.0.3-8.el5
krb5-server-1.6.1-36.el5
cracklib-dicts-2.8.9-3.3
xkeyboard-config-0.8-9.el5
glibc-2.5-42
expat-1.95.8-8.2.1
tcp_wrappers-7.6-40.7.el5
nss-3.12.3.99.3-1.el5.centos.2
libattr-2.4.32-1.1
libidn-0.6.5-1.1
gzip-1.3.5-10.el5.centos
slang-2.0.6-4.el5
make-3.81-3.el5
gamin-0.1.7-8.el5
wireless-tools-28-2.el5
cyrus-sasl-plain-2.1.22-5.el5
unzip-5.52-3.el5
pam_passwdqc-1.0.2-1.2.2
rsh-0.17-40.el5
redhat-logos-4.9.99-11.el5.centos
libXrandr-1.1.1-3.1
libXaw-1.0.2-8.1
libXv-1.0.1-4.1
libXScrnSaver-1.1.0-3.1
findutils-4.2.27-6.el5
newt-0.52.2-12.el5
mesa-libGL-6.5.1-7.7.el5
device-mapper-multipath-0.4.7-30.el5
python-elementtree-1.2.6-5
udev-095-14.21.el5
libxml2-python-2.6.26-2.1.2.8
apr-1.2.7-11.el5_3.1
bind-utils-9.3.6-4.P1.el5
pam_krb5-2.2.14-10
pycairo-1.2.0-1.1
pyorbit-2.14.1-3.el5
tcsh-6.14-14.el5
python-urlgrabber-3.1.0-5.el5
fipscheck-lib-1.2.0-1.el5
mcstrans-0.2.11-3.el5
openssh-clients-4.3p2-36.el5
mkinitrd-5.1.19.6-54
libtool-ltdl-1.5.22-6.1
ltrace-0.5-13.45svn.el5
pfmon-3.2-0.060926.5.el5
libpng-devel-1.2.10-7.1.el5_3.2
libogg-devel-1.1.3-3.el5
libsepol-devel-1.15.2-2.el5
bitmap-fonts-0.3-5.1.1
compat-libgcc-296-2.96-138
compat-gcc-34-3.4.6-4
compat-gcc-34-g77-3.4.6-4
compat-openldap-2.3.43_2.2.29-3.el5
Its total RPM are :439.
The df -h says:
Code:
[root@localhost ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              14G  1.2G   13G   9% /
/dev/sda1              99M   12M   83M  12% /boot
tmpfs                 125M     0  125M   0% /dev/shm
[root@localhost ~]#
It has reached to 1.2 GB.
What package I can delete without actually interfering with system operations.

Last edited by your_shadow03; 01-08-2010 at 02:17 AM.
 
Old 01-08-2010, 02:37 AM   #2
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Quote:
Originally Posted by your_shadow03 View Post
What package I can delete without actually interfering with system operations.
You need to specify what you want the machine to do. Eg. Is it just a web server? Then get rid of X.


However assuming you are not going to be compiling anything on this machine you could emove *-devel and *gcc* packages. You can also get rid of any locales that you don't use (not sure how this is set up on CentOS).


Evo2.
 
Old 01-08-2010, 02:46 AM   #3
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,274

Rep: Reputation: 148Reputation: 148
First you get a definite idea which things you dont need because linux include development libraries, gui, packages, servers, utilities etc, i think you can get some idea by referring how to build own linux distro from linux scratch
http://www.linuxfromscratch.org/
 
Old 01-08-2010, 02:58 AM   #4
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Sorry for the missing point.
All I want to run is Fedora DS on this Machine.
I need openLDAP, JAVA and PAM as a least package.
I just wnat to install fedora DS RPM Pkg.Thats it.
 
Old 01-08-2010, 03:04 AM   #5
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
*-devel* removal made it to 884 MB...Great !!
But when I am trying to remove:

#yum remove *gcc* it displays each and every package to remove:
Code:
bc-headers           i386   2.5-42                        installed 2.0 M
 gmp                     i386   4.1.4-10.el5                  installed 1.7 M
 gnutls                  i386   1.4.1-3.el5_2.1               installed 813 k
 gpm                     i386   1.20.1-74.1                   installed 306 k
 grep                    i386   2.5.1-55.el5                  installed 428 k
 groff                   i386   1.18.1.1-11.1                 installed 5.1 M
 grub                    i386   0.97-13.5                     installed 1.0 M
 gtk-doc                 noarch 1.7-1.fc6                     installed 405 k
 gzip                    i386   1.3.5-10.el5.centos           installed 173 k
 hdparm                  i386   6.6-2                         installed  74 k
 hesiod                  i386   3.1.0-8                       installed  20 k
 hicolor-icon-theme      noarch 0.9-2.1                       installed  17 k
 hmaccalc                i386   0.9.6-1.el5                   installed  78 k
 htmlview                noarch 4.0.0-2.el5                   installed 5.4 k
 httpd                   i386   2.2.3-31.el5.centos           installed 3.1 M
 httpd-manual            i386   2.2.3-31.el5.centos           installed 3.4 M
 indent                  i386   2.2.9-14.fc6                  installed 187 k
 info                    i386   4.8-14.el5                    installed 267 k
 initscripts             i386   8.45.30-2.el5.centos          installed 5.2 M
 iproute                 i386   2.6.18-10.el5                 installed 2.0 M
 iputils                 i386   20020927-46.el5               installed 262 k
 jwhois                  i386   3.2.3-8.el5                   installed 255 k
 kbd                     i386   1.12-21.el5                   installed 2.5 M
 kernel                  i686   2.6.18-164.el5                installed  41 M
 keyutils                i386   1.2-1.el5                     installed  60 k
 keyutils-libs           i386   1.2-1.el5                     installed  32 k
 kpartx                  i386   0.4.7-30.el5                  installed 867 k
 krb5-libs               i386   1.6.1-36.el5                  installed 1.4 M
 krb5-server             i386   1.6.1-36.el5                  installed 1.1 M
 krb5-workstation        i386   1.6.1-36.el5                  installed 1.6 M
 lcms                    i386   1.18-0.1.beta1.el5_3.2        installed 391 k
 less                    i386   394-6.el5                     installed 166 k
 libFS                   i386   1.0.0-3.1                     installed  51 k
 libICE                  i386   1.0.1-2.1                     installed 106 k
 libIDL                  i386   0.8.7-1.fc6                   installed 198 k
 libSM                   i386   1.0.1-3.1                     installed  46 k
 libacl                  i386   2.2.39-3.el5                  installed  24 k
 libaio                  i386   0.3.106-3.2                   installed  31 k
 libart_lgpl             i386   2.3.17-4                      installed 153 k
 libattr                 i386   2.4.32-1.1                    installed  14 k
 libcap                  i386   1.10-26                       installed  43 k
 libdaemon               i386   0.10-5.el5                    installed  48 k
 libdbi                  i386   0.8.1-2.1                     installed  73 k
 libdbi-drivers          i386   0.8.1a-1.2.2                  installed  26 k
 libdrm                  i386   2.0.2-1.1                     installed  28 k
 libevent                i386   1.1a-3.2.1                    installed  31 k
 libfontenc              i386   1.0.2-2.2.el5                 installed  23 k
 libgcrypt               i386   1.4.4-5.el5                   installed 512 k
 libgomp                 i386   4.4.0-6.el5                   installed  94 k
 libgpg-error            i386   1.4-2                         installed 187 k
 libgssapi               i386   0.10-2                        installed  35 k
 libhugetlbfs            i386   1.3-3.el5                     installed  79 k
 libibverbs              i386   1.1.2-4.el5                   installed  95 k
 libidn                  i386   0.6.5-1.1                     installed 586 k
 libjpeg                 i386   6b-37                         installed 267 k
 libmng                  i386   1.0.9-5.1                     installed 424 k
 libogg                  i386   2:1.1.3-3.el5                 installed  24 k
 libpcap                 i386   14:0.9.4-14.el5               installed 192 k
 libpfm                  i386   3.2-0.060926.4.el5            installed 138 k
 libpng                  i386   2:1.2.10-7.1.el5_3.2          installed 567 k
 librdmacm               i386   1.0.8-5.el5                   installed  40 k
 libselinux              i386   1.33.4-5.5.el5                installed  90 k
 libselinux-python       i386   1.33.4-5.5.el5                installed 128 k
 libselinux-utils        i386   1.33.4-5.5.el5                installed  40 k
 libsemanage             i386   1.9.1-4.4.el5                 installed 380 k
 libsepol                i386   1.15.2-2.el5                  installed 238 k
 libstdc++               i386   4.1.2-46.el5                  installed 904 k
 libsysfs                i386   2.0.0-6                       installed 136 k
 libtermcap              i386   2.0.8-46.1                    installed  11 k
 libtiff                 i386   3.8.2-7.el5_3.4               installed 723 k
 libtool-ltdl            i386   1.5.22-6.1                    installed  50 k
 libuser                 i386   0.54.7-2.el5.5                installed 1.5 M
 libutempter             i386   1.1.4-4.el5                   installed  36 k
 libvolume_id            i386   095-14.21.el5                 installed  30 k
 libvorbis               i386   1:1.1.2-3.el5_3.3             installed 1.2 M
 libxml2                 i386   2.6.26-2.1.2.8                installed 1.5 M
 libxml2-python          i386   2.6.26-2.1.2.8                installed 2.3 M
 libxslt                 i386   1.1.17-2.el5_2.2              installed 1.8 M
 libxslt-python          i386   1.1.17-2.el5_2.2              installed 306 k
 lockdev                 i386   1.0.1-10                      installed  21 k
 logrotate               i386   3.7.4-9                       installed  53 k
 lsof                    i386   4.78-3                        installed 830 k
 lvm2                    i386   2.02.46-8.el5                 installed 5.8 M
 m2crypto                i386   0.16-6.el5.6                  installed 1.7 M
 m4                      i386   1.4.5-3.el5.1                 installed 241 k
 make                    i386   1:3.81-3.el5                  installed 1.0 M
 mcstrans                i386   0.2.11-3.el5                  installed  20 k
 mingetty                i386   1.07-5.2.2                    installed  29 k
 mkinitrd                i386   5.1.19.6-54                   installed 915 k
 mktemp                  i386   3:1.5-23.2.2                  installed  13 k
 mod_auth_kerb           i386   5.1-3.el5                     installed  30 k
 mod_authz_ldap          i386   0.26-9.el5                    installed 187 k
 mod_nss                 i386   1.0.3-8.el5                   installed 197 k
 mod_python              i386   3.2.8-3.1                     installed 1.1 M
 mod_ssl                 i386   1:2.2.3-31.el5.centos         installed 173 k
 module-init-tools       i386   3.3-0.pre3.1.54.el5           installed 783 k
 mx                      i386   2.0.6-2.2.2                   installed 2.1 M
 ncurses                 i386   5.5-24.20060715               installed 2.7 M
 net-snmp-libs           i386   1:5.3.2.2-7.el5               installed 3.2 M
 net-tools               i386   1.60-78.el5                   installed 746 k
 netpbm                  i386   10.35.58-8.el5                installed 2.1 M
 newt                    i386   0.52.2-12.el5                 installed 237 k
 nscd                    i386   2.5-42                        installed 114 k
 nspr                    i386   4.7.4-1.el5_3.1               installed 245 k
 nss                     i386   3.12.3.99.3-1.el5.centos.2    installed 2.6 M
 nss-tools               i386   3.12.3.99.3-1.el5.centos.2    installed 2.9 M
 nss_db                  i386   2.2-35.3                      installed 1.6 M
 nss_ldap                i386   253-21.el5                    installed 3.3 M
 ntsysv                  i386   1.3.30.1-2                    installed  20 k
 openib                  noarch 1.4.1-3.el5                   installed  26 k
 openjade                i386   1.3.2-27                      installed 3.2 M
 openldap                i386   2.3.43-3.el5                  installed 593 k
 openldap-clients        i386   2.3.43-3.el5                  installed 366 k
 opensp                  i386   1.5.2-4                       installed 2.9 M
 openssh                 i386   4.3p2-36.el5                  installed 727 k
 openssh-clients         i386   4.3p2-36.el5                  installed 847 k
 openssh-server          i386   4.3p2-36.el5                  installed 475 k
 openssl                 i686   0.9.8e-12.el5                 installed 3.3 M
 openssl097a             i386   0.9.7a-9.el5_2.1              installed 2.0 M
 pam                     i386   0.99.6.2-6.el5                installed 2.4 M
 pam_ccreds              i386   3-5                           installed  32 k
 pam_krb5                i386   2.2.14-10                     installed 254 k
 pam_passwdqc            i386   1.0.2-1.2.2                   installed  51 k
 pam_pkcs11              i386   0.5.3-23                      installed 758 k
 pam_smb                 i386   1.1.7-7.2.1                   installed  66 k
 parted                  i386   1.8.1-23.el5                  installed 1.3 M
 passwd                  i386   0.73-1                        installed  23 k
 patch                   i386   2.5.4-29.2.3.el5              installed 105 k
 pcre                    i386   6.6-2.el5_1.7                 installed 219 k
 pcsc-lite-libs          i386   1.4.4-0.1.el5                 installed  35 k
 pfmon                   i386   3.2-0.060926.5.el5            installed 1.4 M
 pkgconfig               i386   1:0.21-2.el5                  installed 107 k
 pkinit-nss              i386   0.7.6-1.el5                   installed 594 k
 policycoreutils         i386   1.33.12-14.6.el5              installed 2.0 M
 popt                    i386   1.10.2.3-18.el5               installed 124 k
 portmap                 i386   4.0-65.2.2.1                  installed  57 k
 postgresql-libs         i386   8.1.11-1.el5_1.1              installed 495 k
 ppp                     i386   2.4.4-2.el5                   installed 811 k
 prelink                 i386   0.4.0-2.el5                   installed 1.7 M
 procps                  i386   3.2.7-11.1.el5                installed 363 k
 psacct                  i386   6.3.2-44.el5                  installed  98 k
 psmisc                  i386   22.2-7                        installed 149 k
 pstack                  i386   1.2-7.2.2                     installed  887
 pth                     i386   2.0.7-6.el5                   installed 246 k
 pygobject2              i386   2.12.1-5.el5                  installed 270 k
 pygtk2-codegen          i386   2.10.1-12.el5                 installed 678 k
 pyorbit                 i386   2.14.1-3.el5                  installed 101 k
 python                  i386   2.4.3-27.el5                  installed  21 M
 python-elementtree      i386   1.2.6-5                       installed 299 k
 python-iniparse         noarch 0.2.3-4.el5                   installed 131 k
 python-ldap             i386   2.2.0-2.1                     installed 497 k
 python-numeric          i386   23.7-2.2.2                    installed 1.8 M
 python-sqlite           i386   1.1.7-1.2.1                   installed 115 k
 python-urlgrabber       noarch 3.1.0-5.el5                   installed 467 k
 pyxf86config            i386   0.3.31-2.fc6                  installed 168 k
 rdist                   i386   1:6.1.5-44                    installed 162 k
 readline                i386   5.1-3.el5                     installed 337 k
 redhat-logos            noarch 4.9.99-11.el5.centos          installed  27 M
 redhat-menus            noarch 6.7.8-3.el5                   installed 731 k
 rhpl                    i386   0.194.1-1                     installed 914 k
 rpm                     i386   4.4.2.3-18.el5                installed 3.5 M
 rpm-libs                i386   4.4.2.3-18.el5                installed 2.0 M
 rpm-python              i386   4.4.2.3-18.el5                installed 118 k
 rsh                     i386   0.17-40.el5                   installed  62 k
 rsync                   i386   2.6.8-3.1                     installed 392 k
 rusers                  i386   0.17-47                       installed  26 k
 rwho                    i386   0.17-26                       installed  32 k
 samba-common            i386   3.0.33-3.14.el5               installed  22 M
 screen                  i386   4.0.3-1.el5                   installed 739 k
 sed                     i386   4.1.5-5.fc6                   installed 321 k
 setools                 i386   3.0-3.el5                     installed 2.9 M
 setserial               i386   2.17-19.2.2                   installed  29 k
 sgml-common             noarch 0.6.3-18                      installed 131 k
 sgpio                   i386   1.2.0_10-2.el5                installed  13 k
 shadow-utils            i386   2:4.0.17-14.el5               installed 2.6 M
 shared-mime-info        i386   0.19-5.el5                    installed 800 k
 sip                     i386   4.4.5-3                       installed 551 k
 slang                   i386   2.0.6-4.el5                   installed 813 k
 sox                     i386   12.18.1-1                     installed 659 k
 sqlite                  i386   3.3.6-5                       installed 413 k
 sudo                    i386   1.6.9p17-5.el5                installed 457 k
 symlinks                i386   1.2-24.2.2                    installed 8.8 k
 sysfsutils              i386   2.0.0-6                       installed 109 k
 sysklogd                i386   1.4.1-44.el5                  installed 118 k
 tar                     i386   2:1.15.1-23.0.1.el5           installed 1.6 M
 tcl                     i386   8.4.13-4.el5                  installed 2.7 M
 tcp_wrappers            i386   7.6-40.7.el5                  installed 241 k
 tcpdump                 i386   14:3.9.4-14.el5               installed 942 k
 time                    i386   1.7-27.2.2                    installed  17 k
 tmpwatch                i386   2.9.7-1.1.el5.2               installed  16 k
 tomcat5-servlet-2.4-api i386   5.5.23-0jpp.7.el5_3.2         installed 250 k
 traceroute              i386   3:2.0.1-5.el5                 installed  58 k
 ttmkfdir                i386   3.0.9-23.el5                  installed  99 k
 udev                    i386   095-14.21.el5                 installed 5.0 M
 udftools                i386   1.0.0b3-0.1.el5               installed 164 k
 unixODBC                i386   2.2.11-7.1                    installed 1.8 M
 unzip                   i386   5.52-3.el5                    installed 285 k
 usermode                i386   1.88-3.el5.2                  installed 535 k
 util-linux              i386   2.13-0.52.el5                 installed 4.5 M
 vim-common              i386   2:7.0.109-6.el5               installed  15 M
 vim-minimal             i386   2:7.0.109-6.el5               installed 581 k
 vixie-cron              i386   4:4.1-76.el5                  installed 619 k
 wget                    i386   1.11.4-2.el5                  installed 1.4 M
 which                   i386   2.16-7                        installed  31 k
 wireless-tools          i386   1:28-2.el5                    installed 176 k
 wpa_supplicant          i386   1:0.5.10-8.el5                installed 592 k
 xml-common              noarch 0.6.3-18                      installed 1.1 k
 yum                     noarch 3.2.22-20.el5.centos          installed 3.2 M
 yum-fastestmirror       noarch 1.1.16-13.el5.centos          installed  47 k
 yum-metadata-parser     i386   1.1.2-3.el5.centos            installed  53 k
 yum-updatesd            noarch 1:0.9-2.el5                   installed  55 k
 zip                     i386   2.31-2.el5                    installed 295 k
 zlib                    i386   1.2.3-3                       installed  77 k

Transaction Summary
==============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove     301 Package(s)

Is this ok [y/N]: N
Exiting on user Command
Complete!
[root@localhost ~]#
I dont think its safe to remove that.

Last edited by your_shadow03; 01-08-2010 at 03:11 AM.
 
Old 01-08-2010, 04:02 AM   #6
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
As I tried removing packages, now something weird happened.
I am unable to get IP from dhcp.
What package I need to install?
 
0 members found this post helpful.
Old 01-08-2010, 04:15 AM   #7
Web31337
Member
 
Registered: Sep 2009
Location: Russia
Distribution: Gentoo, LFS
Posts: 399
Blog Entries: 71

Rep: Reputation: 65
if you can't deal with centos, use different distro.
say, gentoo, debian or slack.
/dev/sda3 is 14G, why you waste your and our time to make it 250 or 400M? next i suppose will be 600. I already mentioned debian takes around 400M, with some tweaks you can make a router system from it, will only take 100-150M. or even less.
 
Old 01-08-2010, 05:10 AM   #8
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Quote:
Originally Posted by your_shadow03 View Post
As I tried removing packages, now something weird happened.
I am unable to get IP from dhcp.
What package I need to install?
What package did you uninstall?

Evo2.
 
Old 01-08-2010, 05:10 AM   #9
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Guys..

I started again installing CentOS 5.4 just to install from First CD deselecting every additional packages and it come up with:
Code:
[root@localhost ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              14G  672M   13G   5% /
/dev/sda1              99M   12M   83M  12% /boot
tmpfs                 125M     0  125M   0% /dev/shm
[root@localhost ~]#
I tried removing selinux, iptables from the yum remove <pkgname> utility.
I am sure it can brought to 400 MB.
Here is the list of latest rpm -qa .
Code:
filesystem-2.4.0-2.el5.centos
tzdata-2009k-1.el5
cracklib-dicts-2.8.9-3.3
centos-release-notes-5.4-4
libgcc-4.1.2-46.el5
rootfiles-8.1-1.1.1
zlib-1.2.3-3
glib2-2.12.3-4.el5_3.1
popt-1.10.2.3-18.el5
expat-1.95.8-8.2.1
bash-3.2-24.el5
libsepol-1.15.2-2.el5
nspr-4.7.4-1.el5_3.1
readline-5.1-3.el5
sed-4.1.5-5.fc6
elfutils-libelf-0.137-3.el5
libgpg-error-1.4-2
libgcrypt-1.4.4-5.el5
libpng-1.2.10-7.1.el5_3.2
libacl-2.2.39-3.el5
libcap-1.10-26
libtiff-3.8.2-7.el5_3.4
diffutils-2.8.1-15.2.3.el5
slang-2.0.6-4.el5
libXau-1.0.1-3.1
iproute-2.6.18-10.el5
gnutls-1.4.1-3.el5_2.1
grep-2.5.1-55.el5
hmaccalc-0.9.6-1.el5
less-394-6.el5
cpio-2.6-23.el5
iputils-20020927-46.el5
checkpolicy-1.33.1-4.el5
ethtool-6-3.el5
wireless-tools-28-2.el5
libvolume_id-095-14.21.el5
sgpio-1.2.0_10-2.el5
libXdmcp-1.0.1-2.1
udftools-1.0.0b3-0.1.el5
file-4.17-15.el5_3.1
hdparm-6.6-2
centos-release-5-4.el5.centos.1
crontabs-1.10-8
xorg-x11-filesystem-7.1-2.fc6
libXrender-0.9.1-3.1
libXfixes-4.0.1-2.1
libXrandr-1.1.1-3.1
libXinerama-1.0.1-2.1
libselinux-1.33.4-5.5.el5
e2fsprogs-libs-1.39-23.el5
e2fsprogs-1.39-23.el5
findutils-4.2.27-6.el5
krb5-libs-1.6.1-36.el5
python-2.4.3-27.el5
cairo-1.2.4-5.el5
libsemanage-1.9.1-4.4.el5
rpm-libs-4.4.2.3-18.el5
pango-1.14.9-6.el5.centos
audit-libs-python-1.7.13-2.el5
python-sqlite-1.1.7-1.2.1
cracklib-2.8.9-3.3
udev-095-14.21.el5
SysVinit-2.86-15.el5
openldap-2.3.43-3.el5
passwd-0.73-1
cups-libs-1.3.7-11.el5
device-mapper-event-1.02.32-1.el5
logrotate-3.7.4-9
rpm-python-4.4.2.3-18.el5
libselinux-utils-1.33.4-5.5.el5
net-tools-1.60-78.el5
authconfig-5.3.21-6.el5
vim-minimal-7.0.109-6.el5
python-iniparse-0.2.3-4.el5
gtk2-2.10.4-20.el5
ecryptfs-utils-75-5.el5
yum-fastestmirror-1.1.16-13.el5.centos
fipscheck-lib-1.2.0-1.el5
dbus-libs-1.1.2-12.el5
dbus-1.1.2-12.el5
dbus-glib-0.73-8.el5
mcstrans-0.2.11-3.el5
dmraid-events-1.0.0.rc13-53.el5
openssh-server-4.3p2-36.el5
sysklogd-1.4.1-44.el5
dhcpv6-client-1.0.10-17.el5
module-init-tools-3.3-0.pre3.1.54.el5
kernel-2.6.18-164.el5
hal-0.5.8.1-52.el5
pm-utils-0.99.3-10.el5.centos
setup-2.5.58-7.el5
basesystem-8.0-5.1.1.el5.centos
glibc-common-2.5-42
nash-5.1.19.6-54
termcap-5.5-1.20060701.1
gnu-efi-3.0c-1.1
glibc-2.5-42
chkconfig-1.3.30.1-2
mktemp-1.5-23.2.2
audit-libs-1.7.13-2.el5
libtermcap-2.0.8-46.1
info-4.8-14.el5
ncurses-5.5-24.20060715
nss-3.12.3.99.3-1.el5.centos.2
sqlite-3.3.6-5
freetype-2.2.1-21.el5_3
bzip2-libs-1.0.3-4.el5_2
libstdc++-4.1.2-46.el5
gawk-3.1.5-14.el5
libattr-2.4.32-1.1
keyutils-libs-1.2-1.el5
libjpeg-6b-37
db4-4.3.29-10.el5
libxml2-2.6.26-2.1.2.8
atk-1.12.2-1.fc6
libsysfs-2.0.0-6
keyutils-1.2-1.el5
pcre-6.6-2.el5_1.7
libusb-0.1.12-5.1
procps-3.2.7-11.1.el5
gzip-1.3.5-10.el5.centos
binutils-2.17.50.0.6-12.el5
tcl-8.4.13-4.el5
tcp_wrappers-7.6-40.7.el5
mingetty-1.07-5.2.2
gdbm-1.8.0-26.2.1
dmidecode-2.9-1.el5
cyrus-sasl-lib-2.1.22-5.el5
sysfsutils-2.0.0-6
ed-0.2-39.el5_2
libhugetlbfs-1.3-3.el5
setserial-2.17-19.2.2
redhat-logos-4.9.99-11.el5.centos
bitstream-vera-fonts-1.10-7
libX11-1.0.3-11.el5
libXext-1.0.1-2.1
libXcursor-1.1.7-1.1
libXi-1.0.1-3.1
grub-0.97-13.5
device-mapper-1.02.32-1.el5
shadow-utils-4.0.17-14.el5
kpartx-0.4.7-30.el5
coreutils-5.97-23.el5
openssl-0.9.8e-12.el5
fontconfig-2.4.1-7.el5
newt-0.52.2-12.el5
cryptsetup-luks-1.0.3-5.el5
libXft-2.1.10-1.1
libselinux-python-1.33.4-5.5.el5
python-elementtree-1.2.6-5
yum-metadata-parser-1.1.2-3.el5.centos
pam-0.99.6.2-6.el5
util-linux-2.13-0.52.el5
m2crypto-0.16-6.el5.6
libuser-0.54.7-2.el5.5
usermode-1.88-3.el5.2
device-mapper-multipath-0.4.7-30.el5
lvm2-2.02.46-8.el5
rpm-4.4.2.3-18.el5
tar-1.15.1-23.0.1.el5
psmisc-22.2-7
MAKEDEV-3.23-1.2
prelink-0.4.0-2.el5
rhpl-0.194.1-1
python-urlgrabber-3.1.0-5.el5
hicolor-icon-theme-0.9-2.1
trousers-0.3.1-4.el5
initscripts-8.45.30-2.el5.centos
yum-3.2.22-20.el5.centos
policycoreutils-1.33.12-14.6.el5
openssh-4.3p2-36.el5
dmraid-1.0.0.rc13-53.el5
kbd-1.12-21.el5
fipscheck-1.2.0-1.el5
openssh-clients-4.3p2-36.el5
setools-3.0-3.el5
dhclient-3.0.5-21.el5
mkinitrd-5.1.19.6-54
hwdata-0.213.16-1.el5
pciutils-2.2.3-7.el5
kudzu-1.2.57.1.21-1.el5.centos
 
Old 01-08-2010, 05:16 AM   #10
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
what pkges out of these can i remove through yum?
 
Old 01-08-2010, 05:17 AM   #11
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Big Edit:

Also, are you sure you want to remove iptables: that's your firewall.
You lmay be able to get rid of the cracklib packages, but not sure what would be using them.


Quote:
All I want to run is Fedora DS on this Machine.
Sorry I have no idea what "DS" is.

Evo2.

Last edited by evo2; 01-08-2010 at 05:21 AM. Reason: Missed some info from OP.
 
Old 01-08-2010, 05:18 AM   #12
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
no..dhcp problem was in the last setup.
this is a fresh installation..(suggested by http://wiki.centos.org/FAQ/CentOS5#h...cc6c916eb3cb6e)
All i want to setup is fedora ds server.
My colleauge has suggested to make it under minimum (<250 mb)

Last edited by your_shadow03; 01-08-2010 at 05:23 AM.
 
Old 01-08-2010, 05:51 AM   #13
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Fedora Directory Server (DS)is what I am talking about.It is same like Red Hat Directory Server.
It resembles LDAP setup.
http://www.linuxmail.info/389-direct...owto-centos-5/
 
Old 01-08-2010, 06:02 AM   #14
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Ok, so just to run something similar to LDAP..

I'd be getting rid of X for sure. Here is a list of package that look like they could go (assuming you aren't using raid or lvm)

Code:
lvm2
higolor-icon-theme
dmraid
pciutils
kpartx
fontconfig
libXrender
libXfixes
libXrandr
libXinerama
cairo
libX11
libXcursor
Evo2.
 
Old 01-08-2010, 06:21 AM   #15
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,462
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Did that too:
Code:
 Erasing        : gtk2                                                     2/4
  Erasing        : libXcursor                                               3/4
  Erasing        : trousers                                                 4/4

Removed:
  libXcursor.i386 0:1.1.7-1.1

Dependency Removed:
  ecryptfs-utils.i386 0:75-5.el5            gtk2.i386 0:2.10.4-20.el5
  trousers.i386 0:0.3.1-4.el5

Complete!
[root@localhost ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              14G  651M   13G   5% /
/dev/sda1              99M   12M   83M  12% /boot
tmpfs                 125M     0  125M   0% /dev/shm
[root@localhost ~]# yum remove cairo
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package cairo.i386 0:1.2.4-5.el5 set to be erased
--> Processing Dependency: libcairo.so.2 for package: pango
--> Processing Dependency: cairo >= 1.2.2 for package: pango
--> Running transaction check
---> Package pango.i386 0:1.14.9-6.el5.centos set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch         Version                     Repository         Size
================================================================================
Removing:
 cairo         i386         1.2.4-5.el5                 installed         1.1 M
Removing for dependencies:
 pango         i386         1.14.9-6.el5.centos         installed         783 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       2 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : cairo                                                    1/2
  Erasing        : pango                                                    2/2

Removed:
  cairo.i386 0:1.2.4-5.el5

Dependency Removed:
  pango.i386 0:1.14.9-6.el5.centos

Complete!
[root@localhost ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              14G  649M   13G   5% /
/dev/sda1              99M   12M   83M  12% /boot
tmpfs                 125M     0  125M   0% /dev/shm
[root@localhost ~]# yum remove libX11
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package libX11.i386 0:1.0.3-11.el5 set to be erased
--> Processing Dependency: libX11.so.6 for package: libXrender
--> Processing Dependency: libX11.so.6 for package: libXext
--> Processing Dependency: libX11.so.6 for package: libXft
--> Processing Dependency: libX11.so.6 for package: libXi
--> Processing Dependency: libX11.so.6 for package: libXfixes
--> Processing Dependency: libX11.so.6 for package: libXrandr
--> Processing Dependency: libX11.so.6 for package: libXinerama
--> Running transaction check
---> Package libXext.i386 0:1.0.1-2.1 set to be erased
---> Package libXfixes.i386 0:4.0.1-2.1 set to be erased
---> Package libXft.i386 0:2.1.10-1.1 set to be erased
---> Package libXi.i386 0:1.0.1-3.1 set to be erased
---> Package libXinerama.i386 0:1.0.1-2.1 set to be erased
---> Package libXrandr.i386 0:1.1.1-3.1 set to be erased
---> Package libXrender.i386 0:0.9.1-3.1 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch         Version               Repository         Size
================================================================================
Removing:
 libX11              i386         1.0.3-11.el5          installed         2.7 M
Removing for dependencies:
 libXext             i386         1.0.1-2.1             installed          74 k
 libXfixes           i386         4.0.1-2.1             installed          19 k
 libXft              i386         2.1.10-1.1            installed          78 k
 libXi               i386         1.0.1-3.1             installed          42 k
 libXinerama         i386         1.0.1-2.1             installed         8.3 k
 libXrandr           i386         1.1.1-3.1             installed          17 k
 libXrender          i386         0.9.1-3.1             installed          46 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       8 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : libXfixes                                                1/8
  Erasing        : libXinerama                                              2/8
  Erasing        : libXi                                                    3/8
  Erasing        : libXrandr                                                4/8
  Erasing        : libXrender                                               5/8
  Erasing        : libXext                                                  6/8
  Erasing        : libX11                                                   7/8
  Erasing        : libXft                                                   8/8

Removed:
  libX11.i386 0:1.0.3-11.el5

Dependency Removed:
  libXext.i386 0:1.0.1-2.1                libXfixes.i386 0:4.0.1-2.1
  libXft.i386 0:2.1.10-1.1                libXi.i386 0:1.0.1-3.1
  libXinerama.i386 0:1.0.1-2.1            libXrandr.i386 0:1.1.1-3.1
  libXrender.i386 0:0.9.1-3.1

Complete!
[root@localhost ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              14G  645M   13G   5% /
/dev/sda1              99M   12M   83M  12% /boot
tmpfs                 125M     0  125M   0% /dev/shm
[root@localhost ~]# yum remove fontconfig
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package fontconfig.i386 0:2.4.1-7.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch         Version                Repository         Size
================================================================================
Removing:
 fontconfig         i386         2.4.1-7.el5            installed         361 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : fontconfig                                               1/1

Removed:
  fontconfig.i386 0:2.4.1-7.el5

Complete!
[root@localhost ~]# yum remove kpartx
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package kpartx.i386 0:0.4.7-30.el5 set to be erased
--> Processing Dependency: kpartx = 0.4.7-30.el5 for package: device-mapper-multipath
--> Processing Dependency: kpartx for package: dmraid
--> Processing Dependency: kpartx >= 0.4.7-9 for package: mkinitrd
--> Running transaction check
---> Package device-mapper-multipath.i386 0:0.4.7-30.el5 set to be erased
---> Package dmraid.i386 0:1.0.0.rc13-53.el5 set to be erased
--> Processing Dependency: libdmraid.so.1.0.0.rc13-17 for package: dmraid-events
--> Processing Dependency: libdmraid.so.1.0.0.rc13-17(Base) for package: dmraid-events
--> Processing Dependency: dmraid = 1.0.0.rc13-53.el5 for package: dmraid-events
---> Package mkinitrd.i386 0:5.1.19.6-54 set to be erased
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Running transaction check
---> Package dmraid-events.i386 0:1.0.0.rc13-53.el5 set to be erased
---> Package kernel.i686 0:2.6.18-164.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch     Version               Repository     Size
================================================================================
Removing:
 kpartx                      i386     0.4.7-30.el5          installed     867 k
Removing for dependencies:
 device-mapper-multipath     i386     0.4.7-30.el5          installed     6.1 M
 dmraid                      i386     1.0.0.rc13-53.el5     installed     1.6 M
 dmraid-events               i386     1.0.0.rc13-53.el5     installed     6.6 k
 kernel                      i686     2.6.18-164.el5        installed      41 M
 mkinitrd                    i386     5.1.19.6-54           installed     915 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       6 Package(s)

Is this ok [y/N]: N
Seems like kpartx is dangerous to remove.

Again Tried:
Code:
[root@localhost ~]# yum remove kpartx
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package kpartx.i386 0:0.4.7-30.el5 set to be erased
--> Processing Dependency: kpartx = 0.4.7-30.el5 for package: device-mapper-multipath
--> Processing Dependency: kpartx for package: dmraid
--> Processing Dependency: kpartx >= 0.4.7-9 for package: mkinitrd
--> Running transaction check
---> Package device-mapper-multipath.i386 0:0.4.7-30.el5 set to be erased
---> Package dmraid.i386 0:1.0.0.rc13-53.el5 set to be erased
--> Processing Dependency: libdmraid.so.1.0.0.rc13-17 for package: dmraid-events
--> Processing Dependency: libdmraid.so.1.0.0.rc13-17(Base) for package: dmraid-events
--> Processing Dependency: dmraid = 1.0.0.rc13-53.el5 for package: dmraid-events
---> Package mkinitrd.i386 0:5.1.19.6-54 set to be erased
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Running transaction check
---> Package dmraid-events.i386 0:1.0.0.rc13-53.el5 set to be erased
---> Package kernel.i686 0:2.6.18-164.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch     Version               Repository     Size
================================================================================
Removing:
 kpartx                      i386     0.4.7-30.el5          installed     867 k
Removing for dependencies:
 device-mapper-multipath     i386     0.4.7-30.el5          installed     6.1 M
 dmraid                      i386     1.0.0.rc13-53.el5     installed     1.6 M
 dmraid-events               i386     1.0.0.rc13-53.el5     installed     6.6 k
 kernel                      i686     2.6.18-164.el5        installed      41 M
 mkinitrd                    i386     5.1.19.6-54           installed     915 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       6 Package(s)

Is this ok [y/N]: NExiting on user Command
Complete!
[root@localhost ~]# yum remove dmraid
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package dmraid.i386 0:1.0.0.rc13-53.el5 set to be erased
--> Processing Dependency: libdmraid.so.1.0.0.rc13-17 for package: dmraid-events
--> Processing Dependency: libdmraid.so.1.0.0.rc13-17(Base) for package: dmraid-events
--> Processing Dependency: dmraid = 1.0.0.rc13-53.el5 for package: dmraid-events
--> Processing Dependency: dmraid for package: mkinitrd
--> Running transaction check
---> Package dmraid-events.i386 0:1.0.0.rc13-53.el5 set to be erased
---> Package mkinitrd.i386 0:5.1.19.6-54 set to be erased
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Running transaction check
---> Package kernel.i686 0:2.6.18-164.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch       Version                   Repository       Size
================================================================================
Removing:
 dmraid              i386       1.0.0.rc13-53.el5         installed       1.6 M
Removing for dependencies:
 dmraid-events       i386       1.0.0.rc13-53.el5         installed       6.6 k
 kernel              i686       2.6.18-164.el5            installed        41 M
 mkinitrd            i386       5.1.19.6-54               installed       915 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       4 Package(s)

Is this ok [y/N]: N
Exiting on user Command
Complete!
[root@localhost ~]# yum remove higolor-icon-theme
Loaded plugins: fastestmirror
Setting up Remove Process
No Match for argument: higolor-icon-theme
Loading mirror speeds from cached hostfile
 * addons: ftp.iitm.ac.in
 * base: ftp.iitm.ac.in
 * extras: ftp.iitm.ac.in
 * updates: ftp.iitm.ac.in
addons                                                   |  951 B     00:00
base                                                     | 2.1 kB     00:00
extras                                                   | 1.1 kB     00:00
updates                                                  | 1.9 kB     00:00
No Packages marked for removal
[root@localhost ~]# yum remove hicolor
Loaded plugins: fastestmirror
Setting up Remove Process
No Match for argument: hicolor
Loading mirror speeds from cached hostfile
 * addons: ftp.iitm.ac.in
 * base: ftp.iitm.ac.in
 * extras: ftp.iitm.ac.in
 * updates: ftp.iitm.ac.in
No Packages marked for removal
[root@localhost ~]# yum remove hicolor-icon-theme
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package hicolor-icon-theme.noarch 0:0.9-2.1 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                   Arch          Version         Repository        Size
================================================================================
Removing:
 hicolor-icon-theme        noarch        0.9-2.1         installed         17 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : hicolor-icon-theme                                       1/1

Removed:
  hicolor-icon-theme.noarch 0:0.9-2.1

Complete!
[root@localhost ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              14G  643M   13G   5% /
/dev/sda1              99M   12M   83M  12% /boot
tmpfs                 125M     0  125M   0% /dev/shm
[root@localhost ~]# yum remove pciutils
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package pciutils.i386 0:2.2.3-7.el5 set to be erased
--> Processing Dependency: pciutils >= 2.2.1 for package: pm-utils
--> Running transaction check
---> Package pm-utils.i386 0:0.99.3-10.el5.centos set to be erased
--> Processing Dependency: pm-utils >= 0.99.3-6 for package: hal
--> Running transaction check
---> Package hal.i386 0:0.5.8.1-52.el5 set to be erased
--> Processing Dependency: hal >= 0.2.96 for package: kudzu
--> Running transaction check
---> Package kudzu.i386 0:1.2.57.1.21-1.el5.centos set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package        Arch       Version                        Repository       Size
================================================================================
Removing:
 pciutils       i386       2.2.3-7.el5                    installed       157 k
Removing for dependencies:
 hal            i386       0.5.8.1-52.el5                 installed       1.1 M
 kudzu          i386       1.2.57.1.21-1.el5.centos       installed       426 k
 pm-utils       i386       0.99.3-10.el5.centos           installed       109 k

Transaction Summary
================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       4 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : hal                                                      1/4
  Erasing        : pciutils                                                 2/4
  Erasing        : kudzu                                                    3/4
  Erasing        : pm-utils                                                 4/4

Removed:
  pciutils.i386 0:2.2.3-7.el5

Dependency Removed:
  hal.i386 0:0.5.8.1-52.el5              kudzu.i386 0:1.2.57.1.21-1.el5.centos
  pm-utils.i386 0:0.99.3-10.el5.centos

Complete!
[root@localhost ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              14G  641M   13G   5% /
/dev/sda1              99M   12M   83M  12% /boot
tmpfs                 125M     0  125M   0% /dev/shm
[root@localhost ~]#

Last edited by your_shadow03; 01-08-2010 at 06:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Break-In attempt on www.centos.org unSpawn Linux - Security 0 07-08-2009 06:16 PM
LXer: Attempt of VNC setup on Ubuntu Hardy PV DomU at Xen 3.3 CentOS 5.2 Dom0 (all 64 LXer Syndicated Linux News 0 10-10-2008 09:41 PM
First Slackware Installation Attempt carlosinfl Slackware - Installation 12 06-03-2008 06:18 PM
MFC5840CN installation - one last ditch attempt! Mark01450 Linux - Newbie 3 12-04-2007 06:56 PM
My first attempt to make the XP switch killswitch1968 Linux - Newbie 5 03-09-2004 12:19 AM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration