LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2003, 09:13 PM   #1
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
ATI Radeon drivers for Mandrake 9.0


I've been trying to install the ATI drivers for my radeon 9700 pro and I've run into a few problems.

I installed the rpm with the --force arguement, but when the rpm was installing I get:

tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Error: no kernel module build environment - please consult readme.
Installed: qt3 (gcc 3.2) based control panel application


After this I tried and run make.sh but I get this error message:
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h


Okay, From what I understand, I should install the kernel source, so I run:

urmpi kernel-source

And it goes through some long process, but I never get any kind of message that it completed, and the last message in the konsole is something like (trying to remember this)

Cannot delete /linux, /linux is a directory

So, I went back and tried make.sh again, but got the same error. Now I'm totally confused.

Much thanks to anyone who took the time to read this quite long-winded post and replies with some help. Thank you.
 
Old 10-09-2003, 03:14 PM   #2
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
Well, tried again today, but I still cant get this thing working. When I try to urpmi kerner-source, it tells me I have everything installed, and I don't know how to retry installing the source.
 
Old 10-09-2003, 11:26 PM   #3
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
Okay, I know I have the kernel source installed. I was just looking in the wrong directory. So, I decide to edit the make.sh file. I go to the line that states the linuxincludes and change it to the directory in which my source is in. I run the file again, and now it says that the kernel version in my directory doesnt match the current kernel "". Then it said something about possibly changing the symlinks, but I dont know what these are or how to edit them. So what exactly would I do to edit the symlink?
 
Old 11-02-2003, 09:22 PM   #4
Shinobi
Member
 
Registered: Mar 2003
Posts: 46

Rep: Reputation: 15
From the readme:

2.4 Generating a customized kernel module
-----------------------------------------

The FireGL 8700/8800 uses the performance capacity of your workstation
intensively. A precisely tailored kernel module is needed to support some
features, for example, AGP support, busmaster DMA transfers, or memory
mapping. Such a module is loaded at boot time or when the x-server starts
up and remains present for usage with the driver all the time.

Note:
If the module is missing, you do not have hardware-accelerated
3D-support and the 2D driver might abort while loading. See
the console outputs of X11 and /var/log/XFree86.0.log for results.

You are in need to start the kernel module build manually
- if you spot having no hardware 3D support (run fglrxinfo to check)
- if you have done any important system changes, e.g. a changed kernel
- if you were adviced so whilst the driver installation

The binary package provides fully working kernel modules for a few
distributions and kernel versions. So, for some cases, you don't need
to build a kernel module yourself. The installer will notify you if
installation of provided modules did succeed.

The FireGL provided kernel modules will not fit your needs, for example,
- if you have a new or customized Linux kernel, or
- if you have kernel symbols versioning enabled.

In these cases you must build the configured sources of your kernel
at /usr/src/linux - this is allowed to be a symlink.
To build a customized kernel module you need administrator privileges.
You must manually start two shell scripts to build a customized kernel
module.

Perform the following steps:
- get the matching Linux kernel source
- run "make distclean"
- setup that kernel source with the config file matching your kernel
- run "make dep" on the kernel source tree
- go to "/lib/module/fglrx/build_mod" and enter "./make.sh"
- go to "/lib/module/fglrx" and enter "./make_install.sh"

Enter /lib/module/fglrx/build_mod and enter (as root) "./make.sh".
Thus you will create a new customer-specific kernel module.
If the creation fails, look up for the reason in the
shell and in the related logfile "make.log".

Note: Ignore the following warning that may turn up in some configurations:

compiling...
/tmp/ccOWu6AI.s: Assembler messages:
/tmp/ccOWu6AI.s:9: Warning: Ignoring changed section attributes
for .modinfo

A specific combination of Linux kernel sources and C compiler triggers this
warning. Similar messages turn up if you build your own Linux kernel. This
is a widely known Linux issue that does not affect your builds.

There are some kernel sources arround that produce further warnings about
some sort of pointer conversion. You can ignore this warnings as well.

To set up a kernel module build you need Linux kernel headers that match
exactly the kernel you are running.
If your kernel is configured SMP with P-III support and agpgart enabled,
you must have a kernel source that is configured exactly the same way.

If your kernel was built by your Linux distribution and supplied as binary:
- Get the related source RPM file
- Extract the matching configuration settings contained there.
(RedHat Linux files may reside in the subdir "configs".
SuSE Linux: find the files in the SRPMs.
Latest SuSE versions will present /proc/config.gz for the running kernel.)
- Set up your kernel source with these settings:
(1) copy the config file to /usr/src/linux<your-extension>/.config
(For SuSE config.gz first apply "gunzip config.gz" at a temp location.)
(2) run "make oldconfig" for exact importing
- Run "make dependencies" ("make dep").

Note:
If you want to build multiple modules for multiple kernel configurations,
run "make distclean" after each cycle and setup the config file again.

If you cannot build the matching kernel headers
(1) build a new kernel from scratch that is optimally customized to
your machine,
(2) install the new kernel and boot it
(3) continue with setup - if the kernel runs.

Perform the final step on each customized kernel module build:
- Go to /lib/modules/fglrx
- Start ./make_install.sh
This copies the matching kernel module into the loadable modules tree of your
running kernel. The script also updates the module loader dependency list.

On machines that use identical kernels and kernel configuration the results
of the kernel module build are interchangeable. Copy the module into
/lib/modules/fglrx
and setup the new module for usage by running the script
./make_install.sh
that you can find in the same directory.
________________________________

I can't find my matching source kernel (2.4.20-9) which is the only one supporting nvidia nforce2 -- I'm up the proverbial Shi+ creak if you catch my drift. Oh well back to windows for the 3rd time. I'll try Linux some other day I guess

 
Old 11-02-2003, 09:44 PM   #5
Shinobi
Member
 
Registered: Mar 2003
Posts: 46

Rep: Reputation: 15
I finally located the source rpm for my kernel. Once I installed that (also had to get the latest gcc) the ATI install went fine without errors.

Now I get this error when trying to play americas army: Couldn't set video mode: Couldn't find matching GLX visual

Tux racer plays like a slide show as well.

Looks like ATI's support for linux SUCKS ASS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 08:52 PM
Trouble installing ATI Radeon 9600 Drivers in Mandrake RAMMS+EIN Linux - Hardware 2 05-27-2005 04:58 PM
ATi Radeon 9000 Pro and Radeon(flgrx) driver included on Mandrake 10.1 Official St3althcAt Linux - Hardware 1 05-07-2005 09:30 PM
Problems after installing ATI radeon drivers in Mandrake 10 Cetrocet Mandriva 8 05-21-2004 05:32 PM
ati.2 radeon drivers issh1 Linux - Hardware 0 04-12-2003 08:05 PM


All times are GMT -5. The time now is 04:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration