LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2004, 09:51 PM   #1
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Rep: Reputation: 15
ati for linux


what distro of linux is the best for ati? they just will not work correctly with suse.
 
Old 09-19-2004, 10:12 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Can you be a bit more specific? What are you
trying to achieve? Installing ATI's binary drivers,
have the card work with X' native drivers?


Cheers,
Tink
 
Old 09-19-2004, 10:25 PM   #3
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
thanks for the reply

i want to play 3d games. ut2004, americas army, etc. i have been using suse for the last 3 weeks. i always get a segmentation fault when trying to run these games. i have searched far and wide trying to get this corrected but it seems ati and suse just do not mix.

as for your question, i do not really know what you mean. i installed the drivers which suse provided from there site.

i know my drivers are installed correctly

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 1.3 (X4.3.0-3.11.1)


x1-6-00-07-e9-6d-24-c0:/usr/local/games/ut2004 # glxgears
8363 frames in 5.0 seconds = 1672.600 FPS
9229 frames in 5.0 seconds = 1845.800 FPS
9229 frames in 5.0 seconds = 1845.800 FPS
 
Old 09-19-2004, 10:31 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Can you give an example of how you invoke the
game(s) and maybe the output from ~/.xsession-errors?

According to glxgears the drivers are just dandy :)

You could strace the games that crash, or check
the output of
ldd `which <game>`
to see whether there's any problems with other
libraries ...



Cheers,
Tink
 
Old 09-19-2004, 10:37 PM   #5
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
dude thanx for the quick reply.

you are talking over my head. if you can explain how to do what you ask i will be happy to do it.

thanx again
 
Old 09-19-2004, 10:39 PM   #6
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
maybe i understand the first question

if i want to play ut2004
i log in as root
i type ./ut2004

same with americas army

then i alwayse get this fault

x1-6-00-07-e9-6d-24-c0:/usr/local/games/ut2004 # ./ut2004
WARNING: ALC_EXT_capture is subject to change!
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
x1-6-00-07-e9-6d-24-c0:/usr/local/games/ut2004 #


i cannot find where the logfile is
 
Old 09-19-2004, 10:52 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I've done some of your homework
and found this:
Quote:
LD_PRELOAD - Posted by Anonymous -
Reply | Reply with History | Feb 15 2004 10:22:08 | 80.58.46.235
yes i got:

Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.

History:

Exiting due to error

then i put into System dir ( /us/games/ut2004/System )

ln -s /usr/lib/libGL.so.1
ln -s /usr/lib/libGLcore.so.1

and initiate ut2004 with

LD_PRELOAD=/usr/lib/tls/libGL.so.1
ut2004demo

it works fine... :)

Cheers,
Tink
 
Old 09-19-2004, 10:59 PM   #8
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
thanx

i will give this a shot tomorrow, although this is not the same error i am getting.

i appreciate the help.

let ya know what happens tomorrow.

 
Old 09-20-2004, 04:13 AM   #9
rntm
LQ Newbie
 
Registered: Jul 2004
Location: Hamburg, Germany
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
[Edit: Hey, that's in the wrong Thread ..]

Last edited by rntm; 09-21-2004 at 04:58 AM.
 
Old 09-20-2004, 07:14 AM   #10
ant123
LQ Newbie
 
Registered: Aug 2004
Location: English
Posts: 16

Rep: Reputation: 0
You can use mandrake for ati video cards,
I use mandrake 10 and ati radeon 7000 with no GRAPHICAL problems.

I dont like mandrake though, i want suse 9.1 pro. How did you install it?
 
Old 09-20-2004, 11:21 AM   #11
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
download the suse personal iso and boot to your cd rom and install it. just as easy as installing windows. just make sure you know which drive you install it on or it will wipe out your windblows install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux and ATI x800 XT PE zitstif Linux - Hardware 13 10-19-2005 04:12 AM
ATI Graphics Card and Rendering Linux Vs. ATI xmeson Slackware 2 09-02-2004 01:09 PM
ATI, linux, and fglrx coyote399 Linux - Software 8 05-20-2004 06:04 AM
ATI 9700 Linux no go sam00 Slackware 11 11-09-2003 02:08 AM
ATI TV in LInux digital bots Linux - Newbie 1 06-30-2002 03:46 AM


All times are GMT -5. The time now is 10:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration